Jump to content
CCleaner Community Forums
jh05787

"lost" drive letter

Recommended Posts

I just ran CCleaner for the first time and now my secondary hard drive has "disappeared" from My Computer. Has anyone experienced this and how do I get it back? Did running CCleaner effect this? Thanks.

Share this post


Link to post
Share on other sites

Welcome to the CCleaner Forums jh05787! :)

 

Sorry to hear you're having problems with your PC. :( I've never had that happen.

 

If you're on Windows XP you should probably use a Restore Point which will restore the registry to the date and time that Restore Point was created.

 

If you allows CCleaner to create a backup if it was the Issues button that caused it all you would have to do is double click on the created .reg file to restore the removed registry data - a reboot would of course probably be required.

Share this post


Link to post
Share on other sites

I just ran CCleaner for the first time and now my secondary hard drive has "disappeared" from My Computer. Has anyone experienced this and how do I get it back? Did running CCleaner effect this? Thanks.

 

Share this post


Link to post
Share on other sites

 

now my secondary hard drive has "disappeared" from My Computer.
So do you have 2 seperate hard drives, and the second one is gone? Also, do you see it in the device mananger?

Share this post


Link to post
Share on other sites

This may be worth a shot. Hopefully it'll help. go to RUN type: diskmgmt.msc and see if the drive shows up there. See if it's "online". Having not experienced this problem myself, I can't say what the fix will be. Hopefully, you can find a work around there.

Share this post


Link to post
Share on other sites

So do you have 2 seperate hard drives, and the second one is gone? Also, do you see it in the device mananger?

 

I have had 2 drives for some time. The second is still there physically but does not show up in Device Manager.

Share this post


Link to post
Share on other sites

 

I have had 2 drives for some time. The second is still there physically but does not show up in Device Manager.

It's not in device mgr? You've rebooted your machine and the drive hasn't returned? Have you tried a re-scan? It's in the device mgr. it'll be a lil icon "scan for hardware changes" try clicking for that. The drive should return and then you'll have to reboot. If it doesn't then look to your bios and see if it's in there.

Share this post


Link to post
Share on other sites

So do you have 2 seperate hard drives, and the second one is gone? Also, do you see it in the device mananger?

 

 

Don't know exactly why, but the drive did come back and everything appears in order. Thanks for the assistance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...