Jump to content
CCleaner Community Forums
Sign in to follow this  
appyface

Windows Temp Directory NOT being cleaned

Recommended Posts

Good Morning,

 

I have posted this request a few times before, and for prior versions of CCleaner, but it still persists... so I'll try again. :-)

 

I have changed the environment variables (System Properties -> Advanced -> Environment Variables) for both Current User temp directory, and Windows Temp directory, from Windows installation defaults to these hardcoded directories:

 

(user variables for current user)

TEMP = c:\tempuser

TMP = c:\tempuser

 

(system variables)

TEMP = c:\tempwin

TMP = c:\tempwin

 

CCleaner finds and cleans the user temp directory, c:\tempwin, but apparently does NOT find the windows temp directory, because it is never cleaned (regardless of setting for '...older than 48 hours').

 

Is it possible to get this fixed?

 

Thanks and regards,

---appyface

Share this post


Link to post
Share on other sites

I noticed that as well. To be sure, the Current User's Local Settings\Temp folder is the one that really matters, but some applications do indeed use the Windows Temp folder.

 

I dealt with this by simply adding an entry to my winapp2.ini:

 

[Windows Temp]

LangSecRef=3025

DetectFile=%windir%\Temp

Default=True

FileKey1=%windir%\Temp|*.*|RECURSE

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...