Jump to content
CCleaner Community Forums
Texas Skunk

Virus In Latest 1.75 Update for CCleaner

Recommended Posts

I recently downloaded the latest free, yeah,  i'm a limpet; update for CCleaner from Piriform vs File Hippo.

I also accepted the CCleaner Browser. Wanted to try it.

I ended up with the following virus:

Filename: Google Toolbar Setup [1].exe
Malware type: Trojan.Dropper.Ge

It really messed up Chrome. Reverted to a clean restore and then ran WebRoot to destroy.

Went to FileHippo and downloaded the CCleaner update with no problems. Did not accept the browser.

Share this post


Link to post
Share on other sites

The Google toolbar is not a virus.

It was in the Standard CC installer as an offer. (it's no longer there,  the CC browser gets offered instead).

It's picked up by some AVs as a PUP - a Potentially Unwanted Programe.

In this case it wasn't actually the Google toolbar but the new CCleaner browser that your AV has picked up as a PUP and got just which PUP it was wrong, probably because it's also a browser.

The main point to note is that there was almost certainly, (never say never), no virus involved, it was just a warning that you may not want to download/install that particular software. (Because doing so would change your browser - which it did).

Share this post


Link to post
Share on other sites

Curious to find out how you got the Google Toolbar when it has been gone from the past few releases. And it plugged into IE, not Chrome.

And also what does the "1.75" refers to in the heading - the latest CCleaner version is 5.61. What was the name of the installer file that you downloaded?

Share this post


Link to post
Share on other sites
13 hours ago, Dave CCleaner said:

Curious to find out how you got the Google Toolbar

The OP did say he was downloading the browser from the offer.
I think it was just the op's AV that recognised/classified the CC Browser incorrectly.
Which would seem to show that that partciular AV's definitions are not regularly updated.

I'd also noted the oddity of the version number, but assumed it was probably just a typo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...