Jump to content
CCleaner Community Forums
Dragoneer

Version 5.57 7182 (64-bit) Won't Display Easy Clean Mode

Recommended Posts

Version 5.57 7182 (64-bit) won't display Easy Clean mode. It just disappears! I already reinstalled it once and it came back, but now it disappeared again. I even restarted my system but that didn't work. How this is possible is beyond me. This is obviously a bug. Other than reinstalling it again, is there anything else that can be done to restore the Easy Clean mode?

Share this post


Link to post
Share on other sites

We have had a few reports of this. Just to confirm - were you connected to the internet the whole time? Have you made any custom tweaks to CCleaner registry entries or blocks in your Windows hosts file?

Share this post


Link to post
Share on other sites

Yes I was connected to the internet the whole time. I rarely shut down my PC. I did not make any tweaks to the registry. I used the Easy Clean mode a few times, and also viewed it several times to see how many cookies were being added but didn't use it.

Share this post


Link to post
Share on other sites

This is really strange. Just now, I closed my  browser (FF) and attempted to reopen it but it said it wasn't closed. I hit the prompt to close. Then just for the heck of it, I opened CCleaner and lo and behold, the Easy Clean mode returned!

This whole thing is really baffling to me because I didn't think it was possible for a particular feature in a program to just simply disappear.

 

Share this post


Link to post
Share on other sites

Happened to my neighbor twice.  First time, a couple of days ago.  Easy Clean was gone.  Came back the next day.  And, it just happened again right now for the second time.  She doesn't like the feature so she doesn't care if it comes back or not.  Probably eventually will.  What's strange is that we have essentially the same computers, both always have internet access and we both use the latest free version of CCleaner.  My Easy Clean has never vanished on its own.  Go figure.

Share this post


Link to post
Share on other sites

Whether it's displayed or not is controlled by a registry entry setting. Which is why Dave CCleaner was asking above.

If you haven't been 'playing' with the registry then it sounds like something else is changing it, which may be a bug in CC (probably is) or may be something else.

I suppose the next relevant question is are you using the registry cleaner?

It would be ironic if CCleaner was deleting it's own registry entries.

Share this post


Link to post
Share on other sites
2 minutes ago, nukecad said:

Whether it's displayed or not is controlled by a registry entry setting. Which is why Dave CCleaner was asking above.

If you haven't been 'playing' with the registry then it sounds like something else is changing it, which may be a bug in CC (probably is) or may be something else.

I suppose the next relevant question is are you using the registry cleaner?

It would be ironic if CCleaner was deleting it's own registry entries.

My neighbor and I do not use the registry cleaner.  However, we both have Windows 10 and last week there were several cumulative updates in advance of 1903 which we both got on the 21st.  Her Easy Clean disappearance occurred both before and after 1903 installation and like I said, mine never disappeared.  So, I doubt it's a Windows thing (but who knows?).  I'm leaning toward a bug since Dave CCleaner said it has been reported before.   No custom tweaks in the registry cleaner and no block in Windows hosts files.

Share this post


Link to post
Share on other sites
3 hours ago, nukecad said:

Whether it's displayed or not is controlled by a registry entry setting. Which is why Dave CCleaner was asking above.

If you haven't been 'playing' with the registry then it sounds like something else is changing it, which may be a bug in CC (probably is) or may be something else.

I suppose the next relevant question is are you using the registry cleaner?

It would be ironic if CCleaner was deleting it's own registry entries.

I haven't used the registry cleaner for months. I rarely ever use it to prevent possible negative effects on my PC. Windows hasn't been updated since this version of CCleaner.

Share this post


Link to post
Share on other sites

As I say the display of Easy Clean (and Software Updater, and ....) is controled by a registry entry.

I know this because I have played with them and can turn them off/on at will by changing the value of reg. entries.

Although if I turn them off they will sometimes (not always) come back after a restart, which shows that CCleaner will modify them itself at times.

I guess that in your cases some component of CCleaner is turning them off by mistake?

We'll have to wait for Dave or the devs. to track it down.

PS. I've also got 1903 on and haven't had any issues.

Share this post


Link to post
Share on other sites

@nukecad-- Thanks for info and I'll relay it to my neighbor.  If her Easy Clean comes back by itself like it did the first time, I'll post again.  As stated above, my Easy Clean is always there and has never disappeared.

Share this post


Link to post
Share on other sites
32 minutes ago, Judesman said:

I don't even have the 1809 update but "Easy Clean" still vanishes and re-appears.

It doesn't appear to be a Windows thing.  It's something in CCleaner and the devs probably have to sort it out.  Now, as far as my neighbor is concerned, her Easy Clean disappeared for the second time on Saturday.  As of this writing, it's still gone.  Mine is still there and has never vanished.

Share this post


Link to post
Share on other sites
On 5/25/2019 at 06:41, Dave CCleaner said:

We have had a few reports of this. Just to confirm - were you connected to the internet the whole time? Have you made any custom tweaks to CCleaner registry entries or blocks in your Windows hosts file?

Connected to the internet, registry entries and host files sounds like remote access on/off switch. 

Share this post


Link to post
Share on other sites

cCleaner portable: 5.57.7182 (x64)

  1. Easy Clean was not on dashboard when I originally installed
  2. Easy Clean auto-magically appeared on the dashboard today - WTF!
  3. Easy Clean  will make certain that new users don't use cCleaner. The default clean, now called Custom Clean, is fine, even for novices. Calling standard cleaner custom will frighten novices. Don't rename  Cleaner option, do away with Easy Clean option.
  4. If you must include a really dumb and useless option, allow users to choose. BTW, I also do not like the Cleaning results level of detail options - the summary is just as useless as Easy Clean.
  5. I have all updates turned off, and yet Easy Clean came outta nowhere.

The portable version can be downloaded here
https://www.ccleaner.com/ccleaner/builds

If you want portable versions of Piriform's over products, replace ccleaner/builds in the above URL with the product/builds
https://www.ccleaner.com/defraggler/builds
https://www.ccleaner.com/speccy/builds

https://www.ccleaner.com/recuva/builds

Unzip the products to a thumbdrive and you can run them on any machine without having to install the products on each machine.

Easy Clean resolution on the portable version.

  1. Navigate to the folder containing cCleaner
  2. Copy cCleaner.ini to cCleaner.in!
  3. Edit cCleaner.ini
  4. Show Easy Clean
    Change (Cfg)QuickClean=0 to (Cfg)QuickClean=1

    Hide Easy Clean
    Change (Cfg)QuickClean=1 to (Cfg)QuickClean=0
  5. Save cCleaner.ini
  6. Relaunch cCleaner

There might be similar entries in the Registry for the installed version, but there aren't any for the portable version, other than location, compatibility, skipUAC, bags, etc.

 

Share this post


Link to post
Share on other sites
4 minutes ago, Dave CCleaner said:

Just by way of an update - a fix for impacted users is expected by mid next week.

Thanks for the update.  And, by the way, my neighbor's Easy Clean, which disappeared last Saturday (the second time) came back this morning.  I'll let her know a fix is coming.

Share this post


Link to post
Share on other sites
On 25/05/2019 at 11:41, Dave CCleaner said:

We have had a few reports of this. Just to confirm - were you connected to the internet the whole time? Have you made any custom tweaks to CCleaner registry entries or blocks in your Windows hosts file?


Why would the host file be of any relevance to software changes?

Share this post


Link to post
Share on other sites
2 hours ago, Nicon said:


Why would the host file be of any relevance to software changes?

Some people use the hosts file to manually block internet hosts.  This can interfere with the proper functioning of software that relies on retrieving information from the servers in question.

Share this post


Link to post
Share on other sites
On 5/30/2019 at 12:51, Dave CCleaner said:

Just by way of an update - a fix for impacted users is expected by mid next week.

BTW, it came back again yesterday and is still showing. Weirdest thing ever. I'm glad a fix is scheduled to come out. So what is causing the problem?

Share this post


Link to post
Share on other sites

Quick point of interest.  My neighbor's Easy Clean disappeared again this morning.  I told her a fix will be coming.  My Easy Clean has never vanished.

Share this post


Link to post
Share on other sites

For the first time since this thread started, my Easy Clean has disappeared.  Hopefully the expected fix will work.

EDIT:  Easy Clean came back on its own 6 hours after I posted.

 

Edited by crizal

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×