Jump to content
CCleaner Community Forums
st8kout

Microsoft Edge holding up Ccleaner

Recommended Posts

I came here through a Google link, but then found out the whole discussion was from 2018.

I did a fresh Win10 install and now Ccleaner keeps telling me to close Edge, even though I always use Chrome. The only time Edge opened is just after the install, and you pretty much have to use it to download Chrome.

I scanned through the postings but never really saw a result or fix. Is Edge spying/tracking us?

Share this post


Link to post
Share on other sites

Try opening Win 10 Settings... Privacy....Background Apps... and make sure Microsoft Edge is turned off.

Share this post


Link to post
Share on other sites

Thank you. I never thought to check the privacy settings in Windows. I've only checked them on my iphone/ipad.

That's kind of suspicious that Microsoft keeps Edge running in the background like that, especially when you never use it. I would have never known that without CCleaner.

Share this post


Link to post
Share on other sites

It's really annoying that it automatically starts like that with the system, although there could be some logic behind it such as the UI loading significantly faster since after all if you click upon any Help sections of Windows it will often open a Microsoft Help page on their website.

Since I'm on an older build of Win10 what I do as soon as my laptop starts is to open Edge, and then immediately close it, and that gets rid of it, and CCleaner can clean it without issue.

Share this post


Link to post
Share on other sites

Google had a link to disabling Edge. You find this file: "C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe"  and simply rename it. In the example I saw, they added "old" to the "...we," lol.

Share this post


Link to post
Share on other sites

I did it yesterday. No problems found.

They also had a way to permanently delete Edge, but this way it can be easily restored should I ever want it back. 

Now I need a way to stop Microsoft's Mail from always opening when I click an email link on a website. I made Thunderbird my default email client, but Microsoft ignores that and opens Mail instead.

Share this post


Link to post
Share on other sites

You can probably change that mail client to be the default.

Type in Default into the Cortana/Search bar, then click upon Default App Settings.

Share this post


Link to post
Share on other sites
7 hours ago, st8kout said:

Now I need a way to stop Microsoft's Mail from always opening when I click an email link on a website. I made Thunderbird my default email client, but Microsoft ignores that and opens Mail instead.

Check your browser settings.

There is probably an 'Open with' setting in the browser that will overide the system default, similar to this one in Firefox:

image.thumb.png.c88b49f426ae10964bcc1df94b115004.png

Share this post


Link to post
Share on other sites

Thanks. Yep, the default app showed "Mail" even though I set Thunderbird to default in their own settings. Yet another instance of Microsoft insisting on doing things THEIR way.

Share this post


Link to post
Share on other sites
1 hour ago, st8kout said:

Yet another instance of Microsoft insisting on doing things THEIR way.

Actually in that case it's your Browser (You said you use Chrome?) that is specifically overriding the setting you made the default in Windows.
(The browser was set to use "Mail" to open email links from within the browser).

It may be worth rembering that 'Default' does not mean 'always use'; it means 'Use if nothing else is specified'.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×