Jump to content
CCleaner Community Forums
jnk_piriform

ccleaner.ini settings not being honored

Recommended Posts

I created a ticket via support but have not heard back. Posting publicly in hopes someone picks this up.

==================

Due to some compatibility issues with our current version of CCleaner (5.28) and Windows 10, we are forced to update to a newer version. The newer version has some options / features enabled that we want to turn off. We generated a new ccleaner.ini file and deployed the new version to some test computers. After the install, we copy our custom INI file to co-locate it with ccleaner.exe, however, CCleaner is not honoring the desired settings.

My INI file has these three options configured:

HelpImproveCCleaner=0
PrefsPrivacyShowOffers1stParty=0
PrefsPrivacyShareData1stParty=0

But when I go and look at these settings in the application, they do not match the settings in the INI. How do I upgrade CCleaner with these three options configured properly?

I did review the information at https://support.piriform.com/hc/en-us/articles/204045414 that talks about deploying custom settings, however, these three options do not appear in the list. Does that mean they are not supported in a managed deployment and the changes have to be made manually via the application interface?

I have attached a copy of my INI file as well as a screen shot of the application settings showing they do not match the settings in the INI file.

2019-03-20 12_31_21-CCleaner - Business Edition.png

ccleaner.ini

Share this post


Link to post
Share on other sites

Make the .ini file read-only, it should work and it's what I had to do on my mother's laptop to stop an undesired behavior of it changing settings. You're right about it changing the settings and not honoring what you prefer. It was annoying me with it changing settings so I just gave up and downgraded to 5.40.6411 which is available at:
https://filehippo.com/download_ccleaner/81935/

Share this post


Link to post
Share on other sites

We are using the Business Edition; not the "free" version. The proper settings are included in the INI. CCleaner is not changing them ... it is ignoring them.

Share this post


Link to post
Share on other sites

All the same not good. I did leave a link to this topic for the admins, I will edit it to state a paying customer has an issue with the software.

Share this post


Link to post
Share on other sites

@Andavari - I appreciate that, thank you.

So, as a paying customer, can you tell me why I get a response from a free public forum but not from support directly? This was the scenario the last time I opened a ticket also.

 

 

Share this post


Link to post
Share on other sites

Don't know why their support never answered you. On the forums it's just volunteer's and nobody working for them, although occasionally they will officially answer stuff on the forums.

Share this post


Link to post
Share on other sites

Hi this should be working correctly if you've added the settings and values you mentioned above to the ini file, and the ini file is in the same directory as the executable you use to run CCleaner. If you have a custom path, you need to put it in the same custom directory. If you have multiple instances, you need to have one ini file present for each instance you wish to automate.

Note that you may have read/write restrictions on the default install directory, which is /.../Program Files

Share this post


Link to post
Share on other sites

I agree, this should be working correctly ----- but it is not. My INI file is co-located with the executable (i.e., in the same folder). This information is in my OP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×