Jump to content
CCleaner Community Forums
Larry42

CCleaner always has to shut down Chrome

Recommended Posts

Lately, every time I run CCleaner it says it has to shut down chrome, even though I had already closed it before starting to clean. I have to check though 3 windows, and then it often doesn't clean chrome. Am I doing something wrong, or is there a known p[problem with chrome?  Any suggestions on how I might fix this issue?

Share this post


Link to post
Share on other sites

Sometimes or most of the time.... Chrome runs in the background as a task, Microsoft Edge does the same thing too. I just let CCleaner do it's thing, but that's just me.

Share this post


Link to post
Share on other sites

See if this helps:
https://forum.piriform.com/topic/40285-ccleaner-not-deleting-google-chrome-history-fix/

-----------------

@ TwistedMetal:
If you have Windows 10 v1809 ("October 2018 Update") installed.

1. To allow CCleaner to properly clean Edge without an error dialog displayed by CCleaner these keys must be present in the registry to prevent Edge from pre-loading:

Windows Registry Editor Version 5.00

; Microsoft Edge browser disable pre-loading after Windows 10 (October 2018 Update).
; This allows CCleaner to properly clean Microsoft Edge after Windows 10 (October 2018 Update).

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge]

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge\Main]
"AllowPrelaunch"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\MicrosoftEdge\TabPreloader]
"AllowTabPreloading"=dword:00000000

2. Open Microsoft Edge, and then close it - required to make sure it has no running processes. Then run CCleaner, and it will be able to properly clean it since no Edge processes will be running.

That's how I do it anyways, and it works every time.

Share this post


Link to post
Share on other sites

Well, thanks to TwistedMetal, Andavari and hazelnut. Unfortunately, Andavari and hazelnut told me how to solve a problem with Edge, but my problem is with Chrome. I had already fixed the problem with Edge by preventing Edge background ops (as hazelnut suggested), but I was hoping there was some similarly simple way to fix the Chrome problem. Unles someone else adds something I guess I'll have to live with it, like TwistedMetal.

Are there any other Chrome users reading this that don't experience this behavior with CCleaner? If so, I'd like to hear from you so that I'll know it's not a universal problem, but possibly related to some setting I can change. Thanks to all.

Share this post


Link to post
Share on other sites
7 hours ago, Larry42 said:

my problem is with Chrome

I did supply this old solution topic link from 2014 in my post, but as said it's old and Chrome is much newer now, and I know for some people they've previously stated it doesn't work:
https://forum.piriform.com/topic/40285-ccleaner-not-deleting-google-chrome-history-fix/

One workaround is to perhaps try and then use a Chrome/Chromium Clone like SRWare Iron, Vivaldi, etc., that may not necessarily be configured to run all the time --  especially if choosing the portable versions if available.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...