Jump to content
CCleaner Community Forums
Gwolf2u

CC v5.44.6577 - Chrome Beta detection missing

Recommended Posts

Hey there guys,

Using Ccleaner v5.44.6577 and it seems is not detecting my Chrome Beta ( 68.0.3440.68 )

Using normal Chrome all is fine.

Can someone else confirm this?

Share this post


Link to post
Share on other sites

Ccleaner, as a rule, doesn't support beta software as the developers just got the beta at the same time you did.  Especially with chrome and firefox because these betas can change a great deal.  You can try custom location but there's no guarantee that it won't break the beta install.

https://www.ccleaner.com/docs/ccleaner/advanced-usage/ccleaner-ini-files/how-to-clean-user-data-from-non-standard-mozilla-browsers

Replace where it says FIREFOX with CHROME

Share this post


Link to post
Share on other sites

This fix does not work.  Ccleaner is not finding Chrome Beta in its default installation location on Windows 10:  "C:\Program Files (x86)\Google\Chrome Beta\Application"

Furthermore, the referenced instruction page for Mozilla browsers describes a registry edit location that doesn't exist, so this looks like an old, outdated answer that no longer applies.  The registry setting is now in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner

The supposed fix, adding a string value (in the correct registry hive) of "CustomLocation1" with data "CHROME|"C:\Program Files (x86)\Google\Chrome Beta\Application"" doesn't work. 

The statement that Ccleaner doesn't support beta software is irrelevant to this issue.  I've been using Ccleaner with Chrome Beta for many years, and this is the first installation I have done whereby Ccleaner is not finding Chrome.  This is a bug.

I have paid for Ccleaner Professional.  Surely there must be official product support that is not from a user-to-user forum?

Share this post


Link to post
Share on other sites
7 hours ago, SteveW said:

...The registry setting is now in Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner...

The supposed fix, adding a string value (in the correct registry hive) of "CustomLocation1" with data "CHROME|"C:\Program Files (x86)\Google\Chrome Beta\Application"" doesn't work.

CCleaner settings are still stored under the registry key "Computer\HKEY_CURRENT_USER\Software\Piriform\CCleaner". The registry key "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner" is used for a few installation settings only.

If your registry key "Computer\HKEY_CURRENT_USER\Software\Piriform\CCleaner" is empty, then you probably enabled "Save all settings to INI file". Therefore, you have to add the CustomLocation1 to the ccleaner.ini file.

And you have to specify the path to the user profile, for example:
CustomLocation1=CHROME|C:\Users\<your user name>\AppData\Local\Google\Chrome Beta\User Data\Default
(Quotation marks are not necessary.)

Share this post


Link to post
Share on other sites
14 hours ago, APMichael said:

CCleaner settings are still stored under the registry key "Computer\HKEY_CURRENT_USER\Software\Piriform\CCleaner". The registry key "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner" is used for a few installation settings only.

If your registry key "Computer\HKEY_CURRENT_USER\Software\Piriform\CCleaner" is empty, then you probably enabled "Save all settings to INI file". Therefore, you have to add the CustomLocation1 to the ccleaner.ini file.

And you have to specify the path to the user profile, for example:
CustomLocation1=CHROME|C:\Users\<your user name>\AppData\Local\Google\Chrome Beta\User Data\Default
(Quotation marks are not necessary.)

Awesome!  Adding the line into the ccleaner.ini file fixed it.  This ought to be a FAQ,  Thanks for your help.

Share this post


Link to post
Share on other sites

       I have the exact same problem, everything was working fine until I decided to install chrome beta, now somehow ccleaner doesn't see my chrome beta, I mean there is no even chrome section under applications tag on ccleaner interface, it sees only opera and ie, when I reinstall ccleaner now it came with regular chrome and I have 2 different chrome version, and it sees only regular one.

         Chrome Beta is installed in default location, also "Save all settings to INI file" is not enabled, also my registry keys are not empty there are bunch of string files in it. I also didn't understand what do you mean by ccleaner.ini file? where is it? I do not see any ini files in registries nor in installed folder.

      I am scratching my head here, any help  much appreciated.

      Thanks in advance.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×