Jump to content
CCleaner Community Forums
Sign in to follow this  
david_jeffcoat

CCleaner with Firefox web browser

Recommended Posts

I use Firefox as my web browser and am running CCleaner Free.  When I open up CCleaner and select the Cleaner option I don't see Firefox listed, only Internet Explorer.  If I then click on Analyze I see that Firefox Internet Cache, Internet History and Cookies are all shown as skipped.  I can clear these files directly from Firefox by using the History functions, but how do I enable CCleaner to do this for me?  Any suggestions will be welcome. 

David J

Share this post


Link to post
Share on other sites
Quote

When I open up CCleaner and select the Cleaner option I don't see Firefox listed, only Internet Explorer.

You are looking at the "Windows" tab which shows Edge and IE browsers, click the "Applications" tab next to it and Firefox and any other browsers will be shown there.

Share this post


Link to post
Share on other sites

Thank you for the guidance, Nukecad.  So I looked at the Applications tab and, sure enough, I can see a section devoted to Firefox with five boxes, all ticked.  However when I run CCleaner and then open the Advanced Report it still shows all five Firefox options as "skipped".  I'm wondering whether there is some setting in Firefox itself which prevents CCleaner from taking control.  Interestingly I also use Mozilla Thunderbird, which also appears as an Application in CCleaner, and that seems to have been cleaned without any issue. 

Share this post


Link to post
Share on other sites

Usually CCleaner shows 'Skipped' when it is unable to delete files because they are still open in the background. (Although there could be other reasons).

In that case you should normally get a pop-up saying that Firefox is open and asking if you want to close and clean it.
Select Yes and it closes and cleans Firefox, Select No and Firefox is skipped.

Clipboard01.gif.8ee18bf6a51a0ddafb4becb59c982060.gif
BUT if you have previously ticked the 'Do not show this message again' then you won't see the pop-up again, Firefox won't be closed and you will just see the 'Skipped'.

You can turn the pop-ups back on again.
In CCleaner go to Options> Advanced and uncheck the box next to 'Hide warning messages'.

Share this post


Link to post
Share on other sites

Thanks very much, Nukecad.  I closed down Firefox then ran CCleaner and it has successfully cleared all the files in Firefox Internet Cache, History and Cookies.  Interestingly no pop-up message was appearing before to warn me that Firefox was open and the Hide warning messages box was definitely unticked.  However the problem appears to have been solved so I appreciate the help. 

Regards

David

Share this post


Link to post
Share on other sites

Are you saying that the pop-up is now showing if you try and clean when Firefox is still running?

If not then are you using winapp2? (I'd guess not), or have you previously saved your settings to a .ini file?
If you have a saved .ini file then any changes you later make to the settings in the main programme will only be temporary and will reset to the .ini settings next time you open CCleaner.

At least you now know why Firefox was being skipped, and that anything else that is still running will be skipped.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...