Jump to content
CCleaner Community Forums
arejfour

Edge Browser always seems open

Recommended Posts

Sorry to go missing for a bit (disability is playing up, no great problem).

I still suspect it's an Edge/Windows problem, especially if you have put 1803 on.

Microsoft change things and leave everyone to try and work out what they have done and catch up.

Share this post


Link to post
Share on other sites

Come to think of it this problem started when I updated to 1803 along with a myriad of other problems, most notably, a printer connectivity problem that I have managed to come up with a work around until, such time, as MS issues a patch- I hope. What a disaster with the 1803 update. MS should be ashamed of themselves sending out this update.,

Share this post


Link to post
Share on other sites

Just an update. I read an article that suggested that Edge extensions might be causing the problem. I only have two Adblock and U block. I disabled one at a time and then both with no affect-so it's not that. I would also tell you that I have System Mechanic installed on my PC and sometimes when I run the system scan function I'll get a message that the Edge browser internet cache is open. So, it's pretty obvious, that this is an Edge problem as you said right at the beginning of this odyssey.

Share this post


Link to post
Share on other sites

I was having this problem ever since the Windows 10 update to v1803. As mentioned earlier, the fix that has worked for me is to turn off Microsoft Edge in the Start button>Settings icon>Privacy link and on the left side scroll down to Background apps and turn off Microsoft Edge.

Here a link that explains how: https://windowsreport.com/microsoft-edge-always-running/

So far this has worked for me. JUST REMEMBER TO RESTART YOUR COMPUTER AFTER performing the steps above before cleaning again to see if it works in stopping CCleaner from popping up that Microsoft Edge needs to be closed before it can clean.

Share this post


Link to post
Share on other sites

Thank you for your comments. What happens when I disable the Edge app? What works, or doesn't work, or doesn't work as well? FYI I submitted a complaint to MS about this and they said they would look into it. Thanks

Share this post


Link to post
Share on other sites

Nothing horrible happens when you turn off Edge in the Background apps. ( have it turned off)

You can still use Edge as normal, it just isn't running in the background all the time.

Share this post


Link to post
Share on other sites
8 hours ago, wtd3 said:

I was having this problem ever since the Windows 10 update to v1803. As mentioned earlier, the fix that has worked for me is to turn off Microsoft Edge in the Start button>Settings icon>Privacy link and on the left side scroll down to Background apps and turn off Microsoft Edge.

Here a link that explains how: https://windowsreport.com/microsoft-edge-always-running/

So far this has worked for me. JUST REMEMBER TO RESTART YOUR COMPUTER AFTER performing the steps above before cleaning again to see if it works in stopping CCleaner from popping up that Microsoft Edge needs to be closed before it can clean.

 

Share this post


Link to post
Share on other sites

I was chatting with someone on the Microsoft forum about this issue and he said that there was some change in version 1803 and that CCleaner and others will need to adjust their software to accommodate the change that seems to be causing this problem-that's what he said. Side note-my sister has a Dell Inspiron 3847 with W10 and she doesn't have this problem. Last-would it do any good to uninstall and reinstall CCleaner? If so, would there be a way to retain my settings, saved cookies etc? Thanks

Share this post


Link to post
Share on other sites

This is a workaround rather than a solution which I presume will require an update to CCleaner. 

I have tried the solutions mentioned in previous posts without success.  But I have noticed that if I open Edge and then close it (even if I do nothing with it), CCleaner runs normally.

I have only recently come across this issue.  I don't run CCleaner all that often and I may well not have noticed the problem simply because I have always run Edge earlier in the session every time for the last two months.

Share this post


Link to post
Share on other sites

this is why most people hate edge...IE...microsoft.

I had this annoying problem too...suprised Piriform can't fix it.....look in each start menu tile, click more, turn live tile off........seems to have fixed it...

thanks to earlier posts in this thread

Share this post


Link to post
Share on other sites

did not work after 30 minutes....disabling all edge checking since i never use that piece of crap...although interesting the piriform opens it....no wonder they did not fix this bug.

Share this post


Link to post
Share on other sites

Turning off the tiles does not fix the problem. I'm sure its a Edge browser issue, although, the folks at the Microsoft forum say it's not therir problem and that the third party software people should fix their software. There is one way to get around this issue. In the Edge browser if you enable the "clean on closing" function it will effectively stop this problem, but, it requires that you open and close Edge. Bothersome, yes, but it's the only sort of solution at the moment until someone fixes the issue.

Share this post


Link to post
Share on other sites

Add me to the list too, for Ccleaner always having to close Edge before running. 

Just last week I installed a brand new SSD and did a fresh Win10 install on it. That's when Ccleaner started having this problem. I never use Edge as I'm satisfied with Chrome. I do use Firefox for all youtube videos as the AdBlock kills all those annoying commercials, but for everything else I use Chrome.

The only time Edge opened is by default just after the Win10 install, when it opens to msn.com, trying to become your home page. You pretty much have to use Edge to download Chrome so you can change browsers.

Share this post


Link to post
Share on other sites
20 minutes ago, st8kout said:

Add me to the list too, for Ccleaner always having to close Edge before running. 

Just last week I installed a brand new SSD and did a fresh Win10 install on it. That's when Ccleaner started having this problem. I never use Edge as I'm satisfied with Chrome. I do use Firefox for all youtube videos as the AdBlock kills all those annoying commercials, but for everything else I use Chrome.

The only time Edge opened is by default just after the Win10 install, when it opens to msn.com, trying to become your home page. You pretty much have to use Edge to download Chrome so you can change browsers.

See my reply in you other post

https://forum.piriform.com/topic/53955-microsoft-edge-holding-up-ccleaner/

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×