Jump to content
Piriform Community Forums
arejfour

Edge Browser always seems open

Recommended Posts

Lately when I use CC it always says that the Edge browser is open and do I want to close it. I rarely use Edge much preferring Chrome and FF. It seems to have started within the last week so I don't know if it had something to do with a recent CC update and/or and Edge update. So the question now is this a CC issue or an Edge issue or some combination of both?

Share this post


Link to post
Share on other sites

There have been a few similar questions this week.

I suspect that its edge.

Microsoft  uses internet explorer to store temporary files even if you were not using ie.

Edge is supposed to replace ie so I expect that they are now doing the same with edge.

Share this post


Link to post
Share on other sites

Are any windows store apps open/running?

Share this post


Link to post
Share on other sites

I wouldn't call it an 'issue' with CC, CC is just doing it's job as it's supposed to.

It's more of an issue of why Edge is running all the time.

If you untick all Edge items then CC will not analyse or clean them, then you could right click each unticked item and do a manual clean once in a while.
That way you won't get the popup asking you to close Edge everytime you run CC.

The real solution would be to find out what is causing Edge to be open all the time and stop it from doing so.
If you are not using Edge yourself then something else must be starting it in the background.

I'm not sure just what this would be on your machine, it may depend on what you have in 'startup', but also I would be looking at things like 'live tiles' on the start menu.
These are the ones that have an image that updates itself, or a video playing.
Things like news feed live tiles or weather live tiles may be opening Edge in the background. (To access the latest news, etc.).

More about live tiles:
https://www.windowscentral.com/how-to-use-windows-10-live-tiles

To see what you have running automatically at startup, right click on the taskbar and open Task Manager, then select the Start-up tab, this will show you what applications are being started automatically.
More info on Task Manager Startup tab:
https://www.howtogeek.com/162446/how-to-manage-startup-applications-in-windows-8/

Or you could use CCleaner Tools>Startup which can also show your schedued tasks as well as the startup items.

Share this post


Link to post
Share on other sites

Thank you for your prompt reply. I followed you suggestions and here's what I found out:

1.The only live tile I have active is the weather tile. I can turn that off if you think that's the cause of the problem.

2. I checked start up programs and Edge was not listed in either the task bar or CC Tools start up.

 

If you would like to see a screen shot of my start up programs please advise and I will send it along.

Share this post


Link to post
Share on other sites

TBH I'm not sure at all, I'm only suggesting what I would try in your shoes.

If anyone else has suggestions please feel free to jump in with them.

You could try the testing below, or if you can't be bothered with the testing then it may be time to consider rolling back CCleaner a version to see if that works.
You can download previous versions from filehippo, look on the right of this page:
https://filehippo.com/download_ccleaner/

You could try turning off the weather tile, restarting the computer, and running CCleaner analyze to see if that makes a difference. (You can always turn it back on again if it doesn't).

As for the startup files, I wasn't thinking that you would see Edge itself there, if it was then Edge would probably be opening a window when you started the computer.

The point was that something else might be using Edge files/storage locations in the background.
Again I'm not sure just what would do that, so a screenshot would probably not help.
To test could be a long process.
You would have to :-
Disable one of the startup items (right click on it in taskmanager to disable/enable), restart the computer, run CCleaner to see if the problem has gone.
If not then disable the next one, restart the computer, run CCleaner to see if the problem has gone.
And so on for each one at a time.
If one of the startup items is causing the problem then disabling it and restarting the computer should cause the problem to go away and you can then decide whether you need that item to start automatically or not.
Don't forget to re-enable the items you want once you have finished the testing.

 

PS. I've just noticed that in all of this you have not said which Windows version, and which CC version, you are using.
But as you have live tiles I assume it's Windows 8, 8.1 or 10?
 

Share this post


Link to post
Share on other sites

Just thought I'd chime in here. To try and explain, what can happen with the UWP apps (aka retro, or MS store apps) is that windows treats them similarly to how a phone treats apps, in that they don't always close like a desktop app does. Instead when they close they essentially disappear and instead of "unloading" completely they are moved to the background as a "suspended" process. You can't see these types of processes in task manager, but you can see them in something like Sysinternals Process Viewer. I suspect this is what's happening with edge, and CCleaner is seeing it as open, while you think it's closed but it's actually suspended so kind of both.

The other issue is these apps can start suspended. One scenario is when you shut down windows, and you have the fast boot option active (which it is default) when the computer shuts down, it doesn't completely shut down instead it goes into a kind of uber-hibernation. When it restarts, if edge was running (suspended) it will be again. Perhaps disabling the fast start option in power settings will help but it may not.

Another One scenario I can think of is due to your prefetch settings. Edge may have made it into your prefetch folder and as a result to speed up start times it loads it suspended meaning you don't have to open it for it to "start". Another scenario is there is a setting in the windows registry called EnableActiveProbing, which if set to 1 may cause the browser to start on log in, I'd probably start with this one as it's simpler and will limit the changes to the browser only. In either scenario you'll have to change settings in the registry using regedit.exe, so if you're not sure about doing things like this, search the web, for instructions, and backup your registry, it is simple to do IMO, but you should be aware that doing it wrong can result in heartache (unless you enjoy re-installing windows).

EnableActiveProbing is in the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet" and can be 1 or 0. Essentially 1 is enabed 0 is disabled.

Regarding the prefetch folder, it has a bunch of *.pf files, and the files themselves are safe to delete (not the folder though) and ccleaner may be able to do this part by clearing "Old Prefetch Data" except it may be missed as it may not be considered Old. The issue is windows restricts access to this folder by default, and even if you delete the relevant files (they are easy to identify, they look like "[name of program] [some random number].pf") it could come back (i.e be re-cached) as you'd also need to alter the settings for prefetch. As far as I'm aware you can only alter the prefetch settings within the registry so it would mean using regedit.exe to alter the "Enable SuperFetch" key.

The "Enable SuperFetch" setting is in the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters" key and needs a value of 0-3, where:0: Disable SuperFetch
1: Cache applications only
2: Cache boot files only
3: Cache everything (default)

For your scenario, a value of 2 or 0 would work but I'd recommend 2 over 0, and like I mentioned before, I'd try the EnableActiveProbing setting first before delving into this part.

Share this post


Link to post
Share on other sites
4 minutes ago, Noesis said:

 Instead when they close they essentially disappear and instead of "unloading" completely they are moved to the background as a "suspended" process. You can't see these types of processes in task manager,  

 

 

Open Task manager..right-click on 'Name' tab and select 'Status' you will then get a status column where suspended processes will show.

Share this post


Link to post
Share on other sites

So far, since I disabled the live weather tile, I have had no repeat of the Edge browser being open. I'll update this post with any further developments. Thanks for everyone's comments.  FYI W10

Share this post


Link to post
Share on other sites

Happened again. So much for that idea. As for the comments regarding the Registry-I'm not playing with the registry. Maybe I'll just uncheck Edge since I rarely use it anyone.

Share this post


Link to post
Share on other sites
41 minutes ago, arejfour said:

 Maybe I'll just uncheck Edge since I rarely use it anyone.

That would be the easiest if you can't be too bothered tracking down what else may be opening Edge in the background.

As I said above you could uncheck all Edge items, and right click each unticked item to do a manual analyise/clean once in a while, or if you have used Edge.
(And if there are files found on a manual analyze/clean that could point to what is using it).

Share this post


Link to post
Share on other sites

Well I unchecked everything and it still came up. If I uncheck clear cookies it appears to stop. When unchecking cookies in edge it also unchecks it in IE. I'm thinking is has something to do with the cookies. As for going back to a previous version, I tried that, and the same thing happened. Perhaps I'll just use the Edge cleaning function-what a pain. I'll keep you posted as I investigate this further.

Share this post


Link to post
Share on other sites
39 minutes ago, arejfour said:

Well I unchecked everything and it still came up. If I uncheck clear cookies it appears to stop. When unchecking cookies in edge it also unchecks it in IE.

Welcome to the fun of trying to find out  what the **** is going on inside your computer.
(It sounds like you are on your way to learning more about it).

Sometimes you can find it, sometimes you just have to work around it.
(Computer Logic is not always logical once humans get their hands on it).

Unless it is stopping you from working it's best to treat it like a puzzle game.
If you like puzzles you will spend time trying to track it down, if you don't like then you will just get frustrated.

Who needs to buy an overpriced game when you have this stuff to tax your mind?

Share this post


Link to post
Share on other sites

In doing my puzzle solving I discovered that Edge has a feature that cleans the browser, e.g. cookies, cache etc automatically on closing the browser. I enable that feature. So far I've had no CC issues-so far. I'll keep you posted. Have a nice weekend.

Share this post


Link to post
Share on other sites

That sounds as if running Edges own cleaning routine is closing down whatever it was that caused CC to say it was still running.

So that's a result even if we still don't know exactly what it was.

As an extra I would run a scan with Malwarebytes, ADWcleaner, or a similar adware/tracking detection program, just to make sure that it's not an unwanted tracker that was left running.

Either of those will find any potentially unwanted programs (PUPs) and remove them if you choose to.

Share this post


Link to post
Share on other sites

Thank you for your comments. My security software is as follows:

1. McAfee Live Safe: Runs full time with real time protecttion

2. Super Anti Spyware: Free version which I run daily. It usually finds somewhere between 1-5 tracking cookies

3. Malwarebytes: Free version which I run about once a week. Usually find nothing

     So far, since I enabled the Edge cleaning function, I have had no repeat of the CC finding the "Edge browser open" issue. So it seems that that issue has to do with cookies in the Edge browser. When I run CC analysis the Edge cookie results are not listed. The only way to deal with this problem, at this time, is to enable the Edge "clean on closing" function-it works.  You might want to pass along this remedy to other Edge users who are experiencing this same problem. As I said before I rarely use Edge, for a variety of reasons, much preferring FF or Chrome which have never had this problem.

     Thanks for you continued help.

 

Share this post


Link to post
Share on other sites

Hi again, arejfour, It suddenly dawned on me there might be a really simple way to fix this, assuming you haven't tried it already. Open "settings" then go to  Privacy, and then "Background Apps", and scroll down the list and make sure the entry for "Microsoft Edge" is in the off position, if not make it so. Just figured I'd mention it in case you haven't tried it already.

Share this post


Link to post
Share on other sites

It's not in Edge settings, it is in your computer settings.

Start..settings... privacy..Background apps

Share this post


Link to post
Share on other sites

I tired your suggestion-no joy. It has something to do with cookies. For right now I'm just going to disable all Edge cleaning functions in CC and either do it manually or use Edge's" cleaning at close" function. It just not worth anymore time for something I hardly use. Are you sure it's not a CC cleaner issue?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×