Jump to content
Piriform Community Forums
WileC

Update-Error 0x2f07 on Windows Server

Recommended Posts

Hello dear forum,

i'm using ccleaner 5.38 on my windows server 2016. If i click on "check for updates" there opens a popup with the errorcode "0x2f07". On my other Win7, Win8 and Win10 machines, ccleaner updates as recognized.

 

best regards
Tobias

Share this post


Link to post
Share on other sites
On 1/28/2018 at 16:22, WileC said:

Hello dear forum,

i'm using ccleaner 5.38 on my windows server 2016. If i click on "check for updates" there opens a popup with the errorcode "0x2f07". On my other Win7, Win8 and Win10 machines, ccleaner updates as recognized.

 

best regards
Tobias

Hi WileC

The full explanation of this error is: "The application is moving from a non-SSL to an SSL connection because of a redirect. [ERROR_INTERNET_HTTP_TO_HTTPS_ON_REDIR]"

Can you ensure that the TLS v1.2 security protocol is enabled in both your default browser and also in Internet Explorer and Edge. Windows and many applications use some of the functionality in the latter two for internet communications (e.g. retrieving files over the internet).

If needed, you can work around this by downloading and applying the update manually from https://www.ccleaner.com/ccleaner/builds

Share this post


Link to post
Share on other sites

Hello,

i've tried your preferences, but this doesn't resolve my problem on my SBS2016. My standard browser is Mozilla Firefox 58.0.1, Internet Explorer 11, Edge isn't installed. Download from the builds isn't a real option, because all other clients do the update very well, from Win 7 to win 10 with no problems..

 

Greetings
Tobias

Share this post


Link to post
Share on other sites

I've found a solution for mine, see screen shot in my german windows 10 / server 2016:

I have disabled the red marked option in the advanced tab of the internet settings...

Now the upgrades are working fine :) This is only a workaround. I think it should be resolved in the core of ccleaner, so that updates don't switch http and https...

 

screenshot_IE_Optionen.jpg

Share this post


Link to post
Share on other sites
18 hours ago, WileC said:

I've found a solution for mine, see screen shot in my german windows 10 / server 2016:

I have disabled the red marked option in the advanced tab of the internet settings...

Now the upgrades are working fine :) This is only a workaround. I think it should be resolved in the core of ccleaner, so that updates don't switch http and https...

 

screenshot_IE_Optionen.jpg

The solution works for me too. Thank you very much

Share this post


Link to post
Share on other sites

We're aware of this workaround, but we don't recommend it because that warning is very important for security and should only be disabled by those that fully understand the risks involved to their home network security.

Share this post


Link to post
Share on other sites

I'd been having trouble updating my Pro version. This article was posted yesterday: "I'm having trouble updating CCleaner. How can I resolve this?"  https://support.piriform.com/hc/en-us/articles/360018683371   

This article refers to an older version but it did update me, with my advanced settings intact, to the current version 5.55.7108 that was released yesterday.  I found this solution in the Piriform support blogs. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×