Jump to content
CCleaner Community Forums
gumper

Firefox vers 56 History not cleaning

Recommended Posts

I cannot get Firefox history fully cleaned. The History tab shows the history as clean, but when I run Ccleaner and then open Firefox again, the last page I was on opens or sometimes FF will say, sorry something went wrong, reload last page visited and give a history of pages.

 

Apparently since the newest FF update, there is a cache file somewhere not getting wiped.

If I revert back to previous FF version (using 53.0), it does not happen. This occurs with the latest CC update (5.29.6033) and previous versions.

 

Is this something Piriform is aware of and fixing?

Share this post


Link to post
Share on other sites

Latest ccleaner is 5.35

Share this post


Link to post
Share on other sites

since FF is changing how/where things are stored, CC is constantly playing catchup.

making sure your CC version is as new as possible will reduce your chances of it no longer being relevant to those FF changes.

Share this post


Link to post
Share on other sites

Thanks for the response.

When I click the Check for Updates link at the bottom of CC, it tells me that I have the latest edition.

I don't always go scouring websites to fact check as I don't usually have time, so I take the message at face value.

 

anyway, I just installed vs 5.35

Unfortunately, Its still doing the same thing.

Share this post


Link to post
Share on other sites

It's a change in FF56.

 

I posted in another thread which file is causing this.

 

Sorry can't paste a link on this phone, search my recent posts to find it.

 

Quickest fix is to untick Firefox 'sessions' in CCleaner.

Share this post


Link to post
Share on other sites

It's a change in FF56.

 

I posted in another thread which file is causing this.

 

Sorry can't paste a link on this phone, search my recent posts to find it.

 

Quickest fix is to untick Firefox 'sessions' in CCleaner.

 

Is this the post you mean nukecad?

 

https://forum.piriform.com/index.php?showtopic=48945&do=findComment&comment=287382

Share this post


Link to post
Share on other sites

That's the one thanks Hazel.

 

At an engagement party today, normal service will be resumed when I sober up.

Share this post


Link to post
Share on other sites

do we even want to know why, during an engagement party, you are checking the Piriform forum on your phone???  :P

must be a hell of a party?

Share this post


Link to post
Share on other sites

The band was pissing about setting up, did half a song had an argument and went outside for half an hour.

 

All the best bands fight.

 

So I had a quick look about online.

Share this post


Link to post
Share on other sites

Sorry I hadn't updated my post sooner.

The other thread linked above led me to a fix that is working for me.

 

Rather than un-ticking the Sessions box in FF, I added a file in Options/Include.

C:\Users\{Username}\AppData\Roaming\Mozilla\Firefox\Profiles\{ProfileFolderName)\sessionstore.jsonlz4

 

Now FF opens to my home page as usual and bypasses that annoying Session Restore page.

Thanks for the info earlier.

Share this post


Link to post
Share on other sites

The new CC version, v5.36.6278, has fixed this now so you should be able remove your exclusion.

I have removed the exclusion that I put on and FF still opens to my homepage rather than the last session.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...