Jump to content
Piriform Community Forums
Sign in to follow this  
vmsh

Defraggler freezes when selecting a drive from the list while running a defrag

Recommended Posts

Hello,

As already outlined in the title, Defraggler permanently freezes when I select a drive from the list while defragging a different drive.
I did this while trying to defrag two drives at the same time (I'm not sure this is possible - I was just experimenting).

 

I can consistently reproduce the bug with the following steps:

  • Open Defraggler
  • Click on D: drive
  • Click on "Defrag"
  • Click on V: drive

After doing this Defraggler freezes and never comes back. Task Manager still shows 100% D: drive utilization, so I'm guessing the defragmentation still continues in the background even when the GUI is frozen.

 

My Speccy: http://speccy.piriform.com/results/qsZqu2nT2TjHTNYFpOnspV1

Share this post


Link to post
Share on other sites

when I open DF, click on D:\ drive, click Defrag, it starts doing its thing.

the Defrag button is then greyed out and cannot be clicked.

 

so for you, you can still select other drives and the Defrag button is available?

Share this post


Link to post
Share on other sites

I confirm that after clicking Defrag on the D: disk the button is grayed out.

 

I cannot see whether the Defrag button button is grayed out or not for the other drives, as when I select any other drive from the list the program freezes before the GUI is redrawn.

Share this post


Link to post
Share on other sites

I can't repeat the issue you describe.

After I start defragging one drive, the GUI allows me to pick any other of my drives, albeit, I can't actually start another defrag process on any of them as the Defrag button is not available.

But I can go back to the initial drive selected, check its progress, and continue clicking other options in DF happily.

Share this post


Link to post
Share on other sites

Got the same Issue.

Windows 10 & latest Defraggler.

I started defragging my HDD, then clicked on another drive and it froze.

Now I cant see the progress it makes or cancel it. Very annoying.

Seems like this wasnt a problem in earlier versions.... might switch back then

Seems like delivering Crappy / worse updates is becoming a trend recently

Just created this account so I can let you know this is still an Error.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×