Jump to content
CCleaner Community Forums
xlr8

Issue with windows 10 creator update and cccleaner.

Recommended Posts

I will try to explain this as easy as I can. I have been using ccleaner for a very long time (free edition). Its been a great program until this issue.

 

I got the windows 10 creators update  and installed it. All worker fine until I ran cccleaner. After running cccleaner cleaner mode (all options checked but wipe hard drive option) and then rebooted my computer, I get the windows logo with the loading circle at bottom of screen. After waiting  some time (30 min to 45mins), I rebooted  the computer. Then I got a black screen.

 

After some time trying to find out what happen, I found out that windows lost some/all of its files. Thinking this was a fluke situation, I had to reinstall windows 10.

 

So yesterday about 3 or 4 days later I got the windows 10 creator update again. DL and installed it. Later that day I ran cccleaner as usual (as I do every day for years before shutting down my pc).

 

I restarted my pc this morning and guess what? I had the same issue as before.

 

After some more research of my own I determened that ccclean cleaned some windows file that it should not have.

 

This seems to be a issue with the windows 10 creators update.

 

In my case I lost some files I wished I had not lost, but no big issue.But someone might loose much more than me.

 

My final thought is that cccleaner is removing something in the creators update.

 

Thanks for a great program. Please respond why this may be happening.

Share this post


Link to post
Share on other sites

Yes it is. I didn't want to sound angry or anything, just wanted to let folks know. The software is  great. Do you happen to know if there is afix?

Share this post


Link to post
Share on other sites

No fix yet as it was only reported the other day. Until Piriform comes out with a fix it's recommended that nobody uses CCleaner to remove the Windows.old folder.

 

If you must remove Windows.old instead only use the built into Windows tool Disk Cleanup to do it which supposedly doesn't damage the OS.

Share this post


Link to post
Share on other sites

This issue has completely shafted me tonight... two Alienware Alpha machines DOA after removing windows.old with CCleaner. Hoping to locate an easy/quick fix. All of the above hasn't done it. I'll update here if I find anything... (they're not critical machines, so no backups, just a PIA)

Share this post


Link to post
Share on other sites

Please, please, can anyone with this issue say what build  and version of CCleaner they are using.

 

For example CCleaner Free, build 5.29 (or whatever yours is)

Share this post


Link to post
Share on other sites

do you remember when you downloaded CC? or where you installed the program from?

that may narrow down the version involved.

Share this post


Link to post
Share on other sites

I'm not sure to be honest, I likely updated in the last few weeks. It wanted to an update yesterday before I ran it and chose to remove 'Previous Windows Versions'... and everything broke x2. 

 

Anyhow... 5 hours later... My solution was to wipe the SSD and clone these two machines from another good source. 

 

Take aways from this... Have a better backup plan... and sorry team, I won't be reinstalling ccleaner for a while. This was a deep burn of time. 

Share this post


Link to post
Share on other sites

I usually try to get anything from the official site .When is a tricky question . I didn't figure out it was ccclean until I reformated 4 times . I thought it was anything but the cccleaner program until I ran cccleaner then rebooted, thats when I put 2 and 2 together . I got the windows 10 update last night . I installed and rebooted fine . I did (sorry piriform) uninstalled cccleaner . I did run disk clean up and another competitors program after words before shutting down for the night and my PC booted into windows fine .

 

I hope you guys get this fixed as you all have some fantastic software .

Share this post


Link to post
Share on other sites

Heya,

I got exacly this same problem and i find a way to repair this.

 

Before update to creator edition uninstall completly CCleaner.

After update just install and everything works fine....

I just test it and working :-)

 

Best Regards

TaKeN

Share this post


Link to post
Share on other sites

@taken,

what's the point of that video?

I'm not sure how it benefits anyone. :)

Share this post


Link to post
Share on other sites

I'll pass it up the food chain for confirmation.

Share this post


Link to post
Share on other sites

Is this issue fixed now with the latest update? Is it now able to remove the files contained in the "windows.old"  folder without any issues?

 

official word is it was not included in the current version, so until that changes I personally wouldn't be cleaning that area by any other means than the Windows in-built cleaner.

Share this post


Link to post
Share on other sites

if I hear (and remember) then I'll update this, but I'd not be holding my breathe if I were you.

I'm not sure it is still on their radar as there have been no new reports of it reoccurring and they were not able to recreate the problem apparently.

Share this post


Link to post
Share on other sites

I also realised that registry cleaning in Creators Updated Windows 10 causes another problem. I downloaded the free version and cleaned registry with ccleaner. For some odd reason My touch screen sensors stop functioning after the registry cleaning. The obvious outcome is losing the Rotation Lock  option in action center. When I restore the registry backup and reboot it goes back to normal. It seems CCleaner is deleting a registry key which it shoyld not be deleting.

 

One note which I think may help is I'm using a secondary external monitor. Could it be the case that ccleaner thinks the computer is not using a touch screen and deletes the registry key? I've gone through the deleted items but I couldn't find an obvious key which refers to sensors though.

Share this post


Link to post
Share on other sites

Before i was aware of this post , i too tried running CCleaner from Windows 10 ( Creators Update 1703 )  and got this error message .  " This app can't run on this pc . CCleaner doesn't work on this version of Windows . An updated app may be available ."  CCleaner was automatically placed into C:\ Windows.old  folder after Creators Update . Thankfully , Windows protected me from opening CCleaner as it would have damaged critical system files according to others here ! 

Share this post


Link to post
Share on other sites

this was an issue with CC v5.25 (or so), but since then, all versions of CC have worked on all version of W10.

Share this post


Link to post
Share on other sites

Hello,

 

i too had this bug on 2 different machines (maybe more i don't remember), after upgrading them on creator's update 1703.

 

In place upgrade save me twice to correct this. 

 

On both machines the last ccleaner was installed (old one couldn't run), i think 5.30 and 5.31.

 

The Windows.old folder takes too much place, i realy would like to remove it.

 

I didn't try with ccleanr 5.32, is it fixed now? And is it working well with windows cleaner tool?

 

 

Thanks for answers, have a great day!

 

By the way i realy like your tool!

 

 

Pedroo7

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×