Jump to content
CCleaner Community Forums
Sign in to follow this  
daguerrero

Last version 5.28 does not work with Windows XP

Recommended Posts

Hello there

 

I have been using CCleaner for a long time. I never had any issue until now, with and old windows XP professional. I had to locate an old CCcleaner version and re-install the old version.

This computer was running good 10 year ago, but now i have to use it. I had to find "light" programs and still is slow but enough for my requeriments.

 

I was using the prior version without any issue, but I am not certain if this was the 5.27 or 5.26 version.

 

Any suggestions?, from my side I would say you need to say the minimum requeriments for old machines using windows XP

 

Thank you

f1e7_appcompat.txt

post-78669-0-62700500-1490452734_thumb.png

post-78669-0-09963700-1490452770_thumb.png

Share this post


Link to post
Share on other sites

Works fine on my XP system. Make sure you have Service Pack 3 installed - that's the really big one as allot of software requires it.

 

The only other thing that may give you an issue is if your system hardware doesn't support SSE2.

Share this post


Link to post
Share on other sites

Works fine on my XP system. Make sure you have Service Pack 3 installed - that's the really big one as allot of software requires it.

 

The only other thing that may give you an issue is if your system hardware doesn't support SSE2.

Yes same as this post :

https://forum.piriform.com/index.php?showtopic=47794

 

No mention of hardware requirement in the changelog since version 5.27 :(

(work well on 5.26)

The update should be disabled for a CPU that doesn't support SSE2 !

Share this post


Link to post
Share on other sites

on my xp machine too, but on my machine is not a error-report displayed.

 

i have an athlon xp 2000+ without sse2, only with mmx+, 3dnow and sse instructions on hardware

 

 

the same as above --> ccleaner v527 and v528 not working, v526 is the last good one

 

i use the portable-version of 5er-line, i have installed v419 with old known face ;-)

Share this post


Link to post
Share on other sites

Yes same as this post :

https://forum.piriform.com/index.php?showtopic=47794

 

No mention of hardware requirement in the changelog since version 5.27 :(

(work well on 5.26)

The update should be disabled for a CPU that doesn't support SSE2 !

 

They really should disable the installation for those systems which aren't compatible. I'll point the admin to this topic too, and hopefully that will get the ball rolling with them blocking the installation in the future.

Share this post


Link to post
Share on other sites

please let the developers supplementle this info in the version history (v527)

 

 

 

"end of support on os with cpu without sse2" or similar

Share this post


Link to post
Share on other sites

I have a similar issue on Windows XP, but my cpu does have SSE2 instructions.

Xeon 3070:  https://ark.intel.com/products/27206/Intel-Xeon-Processor-3070-4M-Cache-2_66-GHz-1066-MHz-FSB

 

When I run 5.28, it runs through the cleaning process completely, but at the end, it crashes and closes.  If I re-run it, it finds nothing to clean, so I know the cleaning occurred before the crash.

 

Where do I find previous versions to download?  I use the portable version.  I had skipped a bunch of versions (I was running 5.18 previously), so I don't have access to 5.27, 5.26, etc.

Share this post


Link to post
Share on other sites

Thanks, that is the installer, though.  I need the portable version.

 

How to avoid installation and restore your portable version:

1. Get 7-Zip (installs), or 7-Zip Portable (no install).

2. In 7-Zip or 7-Zip Portable right-click the installer and select "Open Inside", this opens the installer without running it.

Screenshot (click for full sized image):

post-26-0-62451800-1490716599_thumb.png

3. Then extract CCleaner.exe into your folder where the portable version is. If your XP system is 64-bit you'll need to extract both of the CCleaner .exe files.

Share this post


Link to post
Share on other sites

How to avoid installation and restore your portable version:

1. Get 7-Zip (installs), or 7-Zip Portable (no install).

2. In 7-Zip or 7-Zip Portable right-click the installer and select "Open Inside", this opens the installer without running it.

Screenshot (click for full sized image):

attachicon.gif7zip_open_inside.png

3. Then extract CCleaner.exe into your folder where the portable version is. If your XP system is 64-bit you'll need to extract both of the CCleaner .exe files.

Thanks!  I've used 7-zip before to manually extract files from .EXEs, so I'm embarrassed I didn't think to try this myself. 

Share this post


Link to post
Share on other sites

any chance this is all part of the current issue with cleaning Firefox, untick Compact Database and see if it helps.

Share this post


Link to post
Share on other sites

please let the developers supplementle this info in the version history (v527)

 

 

 

"end of support on os with cpu without sse2" or similar

 

 

hello developers, please change the version history with this important info

 

 

not necesarily my suggestion but a hint to the changed hardware requirement

 

eighter

v5.26

last version without sse2 support

 

or

v5.27

no support for older cpu without sse2

 

or whatever you think

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...