Jump to content
CCleaner Community Forums
Willy2

Ccleaner: Willy2's bug reports

Recommended Posts

I found 2 bugs in CC v5.16:

 

- Go to the "Disk Analyzer" and select - at least - 3 sorts of files and hit "Analyze".

 

Bug #1:

- Now select/highlight the 2nd row (from the top) and use the "down" key (or the computer mouse) to highlight all the other lines (3rd, 4th, 5th, etc.) that are being displayed in the list under that 2nd line.

- The user will notice that when the "highlighted" line reached the 2 lines (that are marked with a red Arrow in the picture) the highlighting disappears. The user needs to press the "Down" key once more to make the highlighted line appear again.

 

Bug #2:

In the picture attached one can see that CC thinks that a number of video files are only 0.01 Kb in size (see inside the red & blue boxes. And that's outright wrong. These files are - at least - 1 MB in size. And one file is about 180 to 200 MB in size ("Larry Parks ........."). CC thinks that that file is only 0.01 Kb in size.

(The size of that one file (200 MB) was confirmed by the "Search" feature in Piriform's Defraggler !!!!)

 

See attached screenshot for more info.

Share this post


Link to post
Share on other sites

The situation with CC v5.16 is actually different than reported in the previous reply.

 

According to CC v5.16 I have 3 video files that all start with "Larry Parks ............. " but have different sizes. One is ~ 205 MB in size and the 2 others are only 0.01 Kb in size. But when I run EVERYTHING (2nd picture) the message is different. EVERYTHING reports that each of the 3 files ("Larry Parks .............. ") is 205 MB in size. See the pictures in the attachment for more details.

 

And this bug also makes CC v5.16 to mis-calculate the amount of diskspace that's occupied by (in this case) videos files. I have one folder ("C:\Videos1") with over 70 GBs of videos. While CC estimates that video files occupy "only" ~ 66 GBs on my HD.

Share this post


Link to post
Share on other sites

- Yep. Found another bug in CC v5.21. When I have selected the option called "Wipe Free Space" (in the "Advanced" pane) and nothing else then CC won't run that option. Only when I select a second option/tick a second box then CC will execute that "Wipe Free Space" option.

 

(Or was this done intentionally ???).

 

- I continue to think that the "Wipe Free Space" box should be removed from the "Advanced" pane.

- I also think that the "Drive Wiper" Screen should be expanded. Move the option "Wipe MFT free space" to the "Drive wiper" screen as well.

Share this post


Link to post
Share on other sites

- Is this a bug in Ccleaner ?? Or was this done on purpose ??

 

When I select "Temporary Files" (under "System") then CC doesn't clean the temporary folder called

 

C:\Users\<--Username-->\Appdata\Local\Temp\.........

 

- To be added in a next version of CC ?

Share this post


Link to post
Share on other sites

- Another language related bug in CC (v5.23).

 

- Run the CC set up program. Change the language to dutch, select "Aanpassen" (= "Customize"). A new screen will open and then this (language) bug shows up. Instead of the dutch word "Verder" an english word ("More") shows up in the GUI.

- I changed the language from english to dutch, italian, russian, spanish, french and german but in all cases this (english) word ("More") kept popping up. And that clearly suggests that this word is overlooked when it comes to "translating" the text strings.

Share this post


Link to post
Share on other sites

- The bug as described in the previous post has been fixed in CC v5.24 but there still isn't a dutch translation for that one word. E.g when I change the language to german or russian then this word does get translated.

Share this post


Link to post
Share on other sites

- The program code for CCleaner PRO (from the PRO Plus suite) can be improved. To be able to use the programs the user must enter the license key. The annoying thing is that for say 2 or 3 days (can't remember the precise amount) the license key window kept popping up for say 10 seconds before disappearing again.

 

This exposes a flaw in the program code:

- The checking for the (existence of the) license key should be done BEFORE the program code actually lets that window show up.

 

The Piriform developers should also check the following:

- Is the license key window popping up at the right moment ? As far as I remembered, the main CC GUI showed up before the license key window popped up.

 

(The story above also applies to the other parts of the Professional PLUS suite).

Share this post


Link to post
Share on other sites

- Another language related bug in Ccleaner (v5.38):

 

- Select "Options", "Settings".

- In this screen the text "Enable silent background updates" never gets "translated" no matter what language ( dutch, german, French, italian, vietnamese, .................. ) the user selects. To be fixed in the next version.

Share this post


Link to post
Share on other sites

- Found a bunch of language related bugs in CC v5.41.

- I started CC and switched the language from dutch to english. Then a number of words remain in dutch in the "Duplicate Files" screen. See inside the red rectangles in the picture attached.

- There's another small bug in this same screen. When the language is dutch and I open this screen for the 1st time then inside the blue rectangle the 2 arrowheads aren't being displayed. Only when I click on where I think these Arrow heads are supposed to be then those arrowheads show up.Duplicate-EN.thumb.PNG.ce717c4d904e169870a95bd580f77a13.PNG

Share this post


Link to post
Share on other sites

yes willy2, by me too.

 

but it seems only to be in TOOLS->Duplicate Finder.

as you say, if i change the language settings from german to english -> the german translations be there

 

only changesettings to english:
 

Quote

 

Searches for duplicate files

- Match by

- Include and Exclude

- Drive or Folder

 

---> all others be in german.

 

but if i click on another tool and than back to duplicate finder -> ccleaner translates it correctly in english and complete.

 

the same curios translations from english to german:

only changesettings to german:
 

Quote

 

Suche nach Duplikaten

- Übereinstimmung

- Einschießen and Ausnahmen

- Laufwerk oder Ordner

 

and again -> if i click on another tool and than back to duplicate finder, ccleaner translates it correctly and complete.

-

 

 

 

Share this post


Link to post
Share on other sites

- Right. In other words, when the user has changed the language and then opens the "Duplicate Files" screen/option (from the "Tools" menu) the program code doesn't read all the new text strings that are needed for that screen.

Share this post


Link to post
Share on other sites

- I made a screenshot of what happens to the "Size options" in the "Duplicate files" screen on my dutch Win 7 system. See inside the blue rectangle in the picture in the attachment.

- To let this bug show up twice (!!) the user has to check both (!!) "Size" boxes. When the user only checks one box then the bug shows up only once.

- (A) similar bug(s) show(s) up in other languages as well (I tried dutch, german and italian).

- What I consider to be VERY odd is the following: When another program opens a (new) window (partially) overlapping the CC "Duplicate files" screen and I then close/minimize that new window then this bug also shows up (again !!). Seems the handling of that kind of windows pushes CC (a bit) "off the rails".

 

Duplicate-Dutch-MBs-1.PNG.b750ff5691fd86eae6906ff7d2fbfca0.PNG

Share this post


Link to post
Share on other sites

- And this is what those "file size" options are supposed to look like. Compare that with the previous post. See inside the red rectangle in the picture attached.

CC-dutch1.PNG.1cc3706be73ec2111c6f072d79ea33bd.PNG

Share this post


Link to post
Share on other sites

- This is odd. I installed CC v5.46 today. The installation recognized that I have a non-english system. All texts show up in my language. But after installation CC has switched back to english. Needs to be fixed in the/a next version of CC.

Share this post


Link to post
Share on other sites

if nothing else Willy, I have to give it to you for your determination. :)
deaf ears and all - you chip, chip away, all the while hoping but deep down knowing nothing is getting done.

Share this post


Link to post
Share on other sites
13 hours ago, Willy2 said:

- This is odd. I installed CC v5.46 today. The installation recognized that I have a non-english system. All texts show up in my language. But after installation CC has switched back to english. Needs to be fixed in the/a next version of CC.

Hi Willy2,

Can you let me know which language you are running Windows and CCleaner, and finally which version of CC you upgraded from.

I will pass this info onto the devs and get them to look into it.

Thanks

Share this post


Link to post
Share on other sites

- The problem is that all the developers, moderators and beta testers live in countries in which the native tongue is english. And my native tongue is not english. Although I have no problem reading english and german. That's why I found many language related bugs in CCleaner, Speccy and Defraggler.

- I did the following on my dutch system (see my signature for the system setup)

- Installed CC v5.45.

- Perhaps I removed CC v5.45 ?? (I can't remember anymore)

- Installed CC v5.44.

- Installed CC v5.46.

 

Share this post


Link to post
Share on other sites

- Just a few minutes ago I installed (in the following sequence, I still have all three versions) CC v5.45, v5.44 and then v5.46. And it seems (!!!) that all programs have the same problem. The installation part of the program recognizes that I have a dutch system but in CC the GUI itself the texts continue to show up in english.

Edited by Willy2

Share this post


Link to post
Share on other sites

- Another language related bug in CC v5.46: When I change the language to dutch then CC forgets to translate something. The language of the CC system tray icon remains english. Instead of displaying a dutch text, an english text shows up ("CCleaner Smart Cleaning is enabled"), when I place the mouse cursor over that system tray icon. Keep in mind this is AFTER a restart of my system !!!!

- Bug in the program code ? Translator having a "bad hair day" ?

Share this post


Link to post
Share on other sites

For the system tray icon text and the smart cleaning section remaining in english, as this is relativley new functionality we have yet to complete all the translations.

As to it reverting to english after installation can you confirm which installer you are using (regular, slim or other version)

Share this post


Link to post
Share on other sites

Update:

- System Tray Icon: It seems that the 1st time, after installation, the icon shows up with the tooltip in the selected language (For me that's dutch). But when I start the program (CC v5.46) for a 2nd, 3rd, 4th, 5th, ....... time the language (seems to) revert(s) back to english.

- I used the "regular" version downloaded from the Piriform website.

- This is odd, very odd. I repeated the things I have reported before (monday, september 3 (@ 14.01) 2018). And now all seems to be well. And no, I didn't "lose my marbles". Is there here interference from some other program ?

- What I saw is that the installation program looks what language version the user has selected for an older\previous version and then displays the texts in the installation program in that language.

Share this post


Link to post
Share on other sites

Two more language related bugs in CC v5.46:

1) Installation program:

- I switched the language to german and also checked the box "Save settings to INI file" in CC. Then ran the CC installation program and the texts in the installation program were all in .......... english.

- After unchecking the "Save settings to INI file" I ran the installation program again and now all texts showed up in german. This means that the CC installation program checks the registry but not the INI file (I always use the default installation folder).

- It reminded me of what happens when the user has checked the same "Save settings to INI file" box in Defraggler. Then that program also goes (a bit) "off the rails".

- I also noticed that - in this case - the main CC program fails to look whether or not there's an INI file. Because when I opened CC it started with the default options/boxes checked. Perhaps the INI file must be read at a (much) earlier stage in the program code ?

2) "Smart Monitoring" feature:  When this option has been enabled CC (after performing the steps under 1)) after a while a window shows up with the message that the program has found files that can be deleted. But this window showed up with both english & german texts.

Conclusion: CC has some (severe ??) problems when it comes to handling the INI file.

Share this post


Link to post
Share on other sites

- More odd behaviour in CC v5.46.

Took the following steps:

1) Opened CC (switched to english and checked the "Save settings to INI file" and the  "Enable  monitoring" boxes.)

2) Maximized the CC GUI.

3) Closed the main CC GUI.

4) Closed the  CC tray icon.

5) Re-opened CC but now the CC GUI reverted to a much smaller size.

Share this post


Link to post
Share on other sites

I must add some more comment to my previous post.

- When the user executes steps 1) through 5) (see previous post) then the GUI reverts back to (what seems to be) the default size of the GUI right after a fresh new installation.

- But CC does remember what boxes were ticked when the user closes CC with the "Exit" option (in the menu of the system tray icon).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×