Jump to content
CCleaner Community Forums
apolymath

CCleaner not deleting chrome history

Recommended Posts

I would bet on Google intentionally changing something to thwart cleaning tools like CCleaner, etc., because it's just too much of a reoccurring issue as made evident when looking at old topics over the years.

Share this post


Link to post
Share on other sites

I have the same problem since Chromium update. For fix the issue i have add "C:\Users\UserName\AppData\Local\Chromium\User Data\Default\History" file into CCleaner include file.

A screenshot of the CCleaner's include menu:


5b7Jz.png



I hope this could help somebody!

Share this post


Link to post
Share on other sites
  • Windows 7 Professional (64-bit) + Service Pack 1
  • CCleaner 5.14.5493 (64-bit)
  • Chrome 48.0.2564.116 m (32-bit). Process completely closed and no sort of syncing enabled for history/bookmarks/etc..

 

CCleaner hasn't been clearing Google Chrome's history. As DrJones (thanks) suggested, I added the following file inclusion for Google Chrome under:

Options > Include > Add > File >

%LocalAppData%\Google\Chrome\User Data\Default\History

Google Chrome's history file is now properly cleared after running CCleaner.

Share this post


Link to post
Share on other sites

Hello, just FYI, updated to the latest version 20 minutes ago 5.15.5513 and chrome history is still not cleared. The fix might not be ready, but if it is it hasn't worked. If you're still working on it I'll shush and let you get on with it :)

Share this post


Link to post
Share on other sites

Hello,

I wasn't sure if I should make a new thread as I have this same issue which for me has been resolved for Windows, but not for Mac.

I'm currently experiencing the same symptoms from this thread but for Mac. I'm also using the latest release to CCleaner for Mac v1.12.

 

Thanks.

Share this post


Link to post
Share on other sites

@mmjr2000,

maybe the Mac threads would be a better place, if so, a Moderator will move it for you.

 

have you tried the INCLUDE solution (obviously changing to suit the Mac) offered above as a quick fix until a future version fixes the issue?

Share this post


Link to post
Share on other sites

March 8th and still not fixed? Seriously? I use SRWare Iron (Chromium based Browser)  I noticed after using ccleaner even after unchecking let apps run, That anything yahoo or google will automatically sign me in! This is unacceptable! A history Cleaner is supposed to clean history! It is not supposed to help keep easy to find login information for hackers and snoops! I hate being rude, But it seems all people do now is make excuses or guilt trip you, Or try to social engineer you to annoyance! It has been more than enough time to fix a simple issue! Unless you are taking money from google! 

Share this post


Link to post
Share on other sites

It has been more than enough time to fix a simple issue!

On that logic, one can conclude it is not a simple fix.  As the flip-side of your argument is Piriform is leaving the bug in place on purpose just to..... what..... tick off its user base.  I hardly think so.

But until such times as a solution is released, there seems to be a temporary fix that works.

Share this post


Link to post
Share on other sites

I've revisited this again and found something, although I don't know if it's the reason or not.

 

I wonder if this is the cause (taken from the cleaning routine in CCleaner v5.18.5607):

 

[Google Chrome - Internet History]
ID=2014
LangSecRef=3029
LangRef=3162
Section = Chrome
Default=True
SpecialDetect=DET_CHROME
SpecialKey1=N_CHROME_HISTORY

 

Notice the "Section = Chrome" part in the above cleaner, it's the only Google Chrome cleaner I found that has that in it, and usually when in the winapp2.ini file it would instead be "Section=Chrome" with no space in the naming.

 

It's weird for it to be in that built-in default cleaner since it already has a LangSecRef area which would mean there's no need for Section= since we use those to skip using LangSecRef when making a winapp2.ini cleaning routine.

 

I wonder if it could be causing the History to be skipped?

Edited by Andavari

Share this post


Link to post
Share on other sites

Hi TrytobeCleanGuy,

 

Can you please verify if you have your Chrome connect to a Google Account and History synchronization turned on. This will download your history back to your browser even after being cleaned by CCleaner.

 

On another note, we noticed the "Section" entry above and are removing it in the next release. But this is not causing any problems cleaning History. Thanks, Andavari for pointing it out.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×