Jump to content
CCleaner Community Forums
hazelnut

Nvidia graphics uninstall problem

Recommended Posts

This was on Win 10 64bit.

 

I had an Nvidia GeForce card with all the bells and whistles. I was having black screen issues when restarting only (not shut down just restart)

 

So I removed the graphics card as I also have an on board Radeon basic Windows one to see what would happen.

 

All my problems disappeared :) Or so I thought.

 

The Nvidia drivers and all the other Nvidia stuff refused to uninstall no matter what I tried (safe mode etc)

 

So I tried Display Driver Uninstaller from guru3d as a last resort before throwing the machine out of the window. Ran it in safe mode

 

I was so surprised, everything related to Nvidia is gone, even from the control panel.

 

This is not a recommendation for everyone to do this as I don't know anyone else's circumstances.

 

I'm just telling what worked for me :)

 

 

Share this post


Link to post
Share on other sites

... before throwing the machine out of the window.  ...

 

:lol:  I bet everybody knows that feeling.

 

And yet, through it all you stayed calm (or at least rational), true to your profile suggestion.  

 

Out of curiosity, what graphics setup did you finally settle on?  

Share this post


Link to post
Share on other sites
 

 

Out of curiosity, what graphics setup did you finally settle on?  

 

Just left it as the onboard basic Windows Radeon one.

 

Works really well so it's staying for now :)

 

I hate graphics drivers as much as printer ones !!

Share this post


Link to post
Share on other sites

Same issue occurs with my mother's HP Envy touchscreen which runs NVIDA ge. I've had to rebuild the machine thrice and sent back to HP once. I'm now trying with a clean install of windows 10 (as opposed to a dirty upgrade). I think it may result from NVIda and Microsoft both attempting driver updates.

Share this post


Link to post
Share on other sites

and on the driver update issue, something I only learnt this week.

some Windows 10 Updates can be made to stop: device driver updates.

 

bring up the Power Menu (Windows key + X)

click System, Advanced System Settings, Hardware tab, Device Installation Settings, click No and Save Changes.

Share this post


Link to post
Share on other sites

Glad my mothers laptop only has the onboard AMD ATI Radeon graphics, I certainly don't feel like fiddling with that Win10 laptop anymore than I have to.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...