Jump to content
CCleaner Community Forums
Kas

Defraggler does not defrag

Recommended Posts

For years I have - 1. Analyze Drive 2. Defrag Drive under Action and all went OK to defrag.. But now, it does not defrag..

 

The Analyze works OK but not defrag. It gallops off doing a Calculating Disk Performance and stops there with a nice green GOOD. Clicking Defrag on the bottom button or Defrag Drive under Action makes it gallop off yet again to Calculating Disk Performance and no Defrag.

 

If I View Files and check them, then hit Defrag Checked, it defrags them. But it did that before.

 

Please advise.

 

Version v2.19.982

Share this post


Link to post
Share on other sites

I did as you highlighted, and bugger me, you are correct - sort of.

I did the Analyse, hit Defrag, it built the file list then sort of hinted it was starting a defrag then stopped.

Hitting the Defrag button again, and now it's actually defragging a measly 238 files.

 

 

 

Hmmm, spoke too soon.

It did three files as I was typing that and then stopped.

Hit Defrag again, nada, hit it again and now it's defragging where it left off.

 

OK, that time it did one then stopped.

Hitting Defrag, it doesn't, hitting it again, it does.

 

Definitely not happy about something.

Luckily I almost never use it that way so it ain't going to bother me.

 

I normally go to File List, Analyse, sort by Size and select the first few screens of worst offenders and Defrag them then do the same for the Fragments column.

 

 

 

Win10 Pro build 10240.  DF v2.19.982

Share this post


Link to post
Share on other sites

Analyze :

 

94sNOY3.jpg

 

Defrag :

 

8Y5EKzJ.jpg

 

Says Defrag Compete - wrong, it has done nothing, just another Health check.

 

Conclusion - Defraggler does not work.

Solution - Used [Moderated] for a perfect defrag with no problems.

Edited by Nergal
removed competition software

Share this post


Link to post
Share on other sites

yeah, really shouldn't mention the competition on this forum, for any of their products @Kas

Share this post


Link to post
Share on other sites

Thanks MTA competition software name removed

Share this post


Link to post
Share on other sites
Guest MrJ

Hi Kas,

 

We've been unable to reproduce this issue using the default settings in Defraggler. Please could you confirm if you have "Move large Files to End of Drive during whole drive defrag" enabled in Settings > Options > Defrag?

Share this post


Link to post
Share on other sites

Hi Kas,

 

We've been unable to reproduce this issue using the default settings in Defraggler. Please could you confirm if you have "Move large Files to End of Drive during whole drive defrag" enabled in Settings > Options > Defrag?

Thank you for your comments. YES I do have that item enabled.

Do you reckon if I uninstall Defraggler and re-install, it may cure the problem ?

 

See :-

MuQyamx.jpg

Share this post


Link to post
Share on other sites
Guest MrJ

Thanks for providing that information. This is a known issue in the latest version of Defraggler.

 

The workaround is as follows:

 

On the screen Kas posted ^^:

 

1) Tick "Move only selected files, folders and file types"

2) Create a new category for all files, file type is *.*

3) Check this new category in the below box.

 

You can find a screenshot below:

 

 

 

post-72202-0-46705900-1449068296_thumb.png

Share this post


Link to post
Share on other sites

I jumped the gun and uninstalled Defraggler using Revo-Uninstaller which scooped up all the leftover Registry items.

 

I re-installed Defraggler version v2.19.982 and run it. Analyze first, then Defrag. It went fine with no problems.

 

See :-

1H2gArC.jpg

 

All OK now without needing any diplomas. Thank you all for your comments. Just one of those hiccups I guess, these things happen. What went wrong ? Only God knows and he `ain't telling.

Share this post


Link to post
Share on other sites

Apologies for necropost but...

Experiencing same issue. Uninstall and reinstall did not rectify.

Why would I need "Move large Files to End of Drive during whole drive defrag" checked if I didn't want that feature in operation. Neither that or the other solution of creating an "all" category work either.

Also, Defraggler thinks 2 of my external HDDs are SSDs when they are not.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...