Jump to content
CCleaner Community Forums
siliconman01

Windows Event Logs not removed

Recommended Posts

This applies to Windows 7 x86 Pro and Windows 8 x64 Pro and CCleaner V4.05 and V4.06.

 

The Advanced>Windows Event Log does not removed any of the Event Viewer logs. I suspect that this is a permissions problem. A reboot does not remove them either. The Event Viewer shows hundreds of logs on my system and CCleaner finds 0 logs on Analyze and Clean

Share this post


Link to post
Share on other sites

No problem here with XP or Windows 7 64bit.

 

The 'amounts cleaned' for event viewer logs are not shown in the summary window (and that's the same for everyone)

 

When you say permissions problems, what do you mean?

 

(I know I shouldn't but I have to ask, did you tick the box for event viewer logs?)

Share this post


Link to post
Share on other sites

They may be locked by the event viewer service.

 

Yes, I agree. I'm wondering if they need to be handled like Index.dat or set to be deleted on next reboot?

 

This feature does not work on any of my computers which are running either Windows 7 x86 Pro or Windows 8 x64 Pro

Share this post


Link to post
Share on other sites

Have you given the 'event logs' clean a run, rebooted, and then looked?

 

Or are you saying no matter what you do this doesn't work?

 

What security set up do you run?

Share this post


Link to post
Share on other sites

Have you given the 'event logs' clean a run, rebooted, and then looked?

 

Or are you saying no matter what you do this doesn't work?

 

What security set up do you run?

 

No matter what I do on the Windows 7 and/or Windows 8 computers, it does not clean out the Event logs. I am running under Administrator privileges on my User account on all systems.

I even tried CCleaner with my Windows 7 system booted into Safe Mode....still no cleaning of the Event Viewer logs. And I'm showing event log entries as far back as 09-Jan-2013.

Share this post


Link to post
Share on other sites

Are you able to clear your logs manually or does even this not work?

 

Yes, I can clear them manually. Always have been able to. The .bat file at the link below will clear all of the event viewer logs on Windows 7 and 8 (32/64 bit). It does have to be "Run as Administrator".....at least it does on my systems. I run with UAC turned off.

 

http://www.sevenforu...lick-clear.html

Share this post


Link to post
Share on other sites

Yes, I can clear them manually. Always have been able to. The .bat file at the link below will clear all of the event viewer logs on Windows 7 and 8 (32/64 bit). It does have to be "Run as Administrator".....at least it does on my systems. I run with UAC turned off.

 

http://www.sevenforu...lick-clear.html

1.

I understand that "Run as Administrator" jumps over hurdles that block Administrator privileges on a user account,

hence to be fair you should ONLY compare BAT file capabilities with CCLeaner under the same condition.

If your "Administrator privileges on a user account" are NOT sufficient to use the BAT file then you are running CCleaner WITHOUT adequate access.

 

2.

When I updated Macrium Reflect from version 5.1.???? to 5.2.???? I lost the context menu ability to unmount a mounted image.

The first reason suggested by a Macrium user on the Macrium forum was that I ran with UAC turned off.

 

A Macrium developer rapidly corrected him and advised that this Only Applies to Windows 8 (or perhaps 8.1 - I forget)

My particular problem was identified as a failure of the update installer to register an executable,

and a couple of "Run as Administrator CMD.EXE" Dos commands sorted out the registration and my context menu worked.

 

The point of this anecdote is that I learnt from this experience that even when the executables are correctly registered,

For Windows 8 THAT CONTEXT MENU ITEM ONLY WORKS WHILST UAC IS TURNED ON.

 

Moral of the story - If you do not want UAC then Windows 8 is not the O.S. for you - choose Linux to avoid surprising failures :wacko:

Share this post


Link to post
Share on other sites

For me the Windows Event Viewer log cleaning works on XP, Windows 764bit and Windows 8 64bit.

 

UAC on.

 

(Just tested it on my Win 8 machine)

Share this post


Link to post
Share on other sites

For me the Windows Event Viewer log cleaning works on XP, Windows 764bit and Windows 8 64bit.

 

UAC on.

 

(Just tested it on my Win 8 machine)

 

I turned on UAC and tried....no luck. Tried CCleaner "Run as Administrator", etc....no luck.

 

Are you running with "elevated administrator" or with the unelevated administrator account? I'm running the unelevated.

Share this post


Link to post
Share on other sites

When you very first select it to clean the eviewer logs, do you get the ccleaner warning for what it will do?

 

(I'm not right-clicking ccleaner and selecting run as admin)

 

.

Share this post


Link to post
Share on other sites

Perhaps running ccleaner in debug mode while you attempt the eviewer cleaning might show something for the devs.

 

http://www.piriform.com/docs/ccleaner/troubleshooting/running-ccleaner-in-debug-mode

 

If you feel uncomfortable about posting the logs on forum you can always pm me with them and I'll forward them on.

Share this post


Link to post
Share on other sites

Perhaps running ccleaner in debug mode while you attempt the eviewer cleaning might show something for the devs.

 

http://www.piriform....r-in-debug-mode

 

If you feel uncomfortable about posting the logs on forum you can always pm me with them and I'll forward them on.

 

Sent you a pm with the debug log attached. System is Windows 8 x64 Pro.

Share this post


Link to post
Share on other sites

Thanks much. Hopefully the developers can resolve the issue. I will be more than happy to supply any further info and/or run any tests in an effort to identify the problem(s).

Share this post


Link to post
Share on other sites

Hi siliconman01,

 

I am sorry to hear that you are having problems with Windows Event log cleaning.

 

Can you please be kind to PM me the debug log file?

 

Thank you!

 

MrT

 

PS: Or maybe hazelnut can also forward it to me.

Share this post


Link to post
Share on other sites

This issue still exists in CCleaner v4.07. Removal of the event logs does not work on any of my computers under Windows 7 x86 and Windows 8.1 x64 Professional. And I always sign on as an administrator. UAC is turned off.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...