Jump to content
CCleaner Community Forums
six..pack

Cleaning Temp folders failes

Recommended Posts

There is an option to clean temp folders when the files are older than 24 hours.

That does not work.

 

I only can delete files when I uncheck this option.

 

Nice bug.

 

CCleaner isn't able to work with date and time.

 

:lol:

Share this post


Link to post
Share on other sites

Works fine for me. Run CC, then right click/analyse on System/Temporary Files and there are no files to clean. Untick the Only delete files etc older than 24 hrs, run analyse again and 13 files show up. Do you have something different from this scenario?

Share this post


Link to post
Share on other sites

I came here specifically to report what I believe is this exact same bug. You can easily duplicate it as follows:

 

Start CCleaner

Options/Advanced, check Only delete Temp older than 24 hours

Run Analyze - notice all the Temp files total size & quantity (for me anyway since I haven't been deleting them after moving to 4.05 so I could report this bug first)

Run Analyze again - notice Temp files are not listed any more

Options/Advanced, uncheck Temp older than 24 hours

Run Analyze again - the Temp files will be listed again

Compare to total size & quantity noted on 1st run & you'll see they're probably pretty close

 

CCleaner must be somehow modifying the date it checks for Temp age when it runs Analyze. I suspect it's now checking the Accessed date rather than the Modified date but I could be wrong. Whatever it is, it didn't start doing this until I updated from 4.04 to 4.05!

 

XP Pro SP3 + all hotfixes

CCleaner Portable 4.05.4250

 

Thanks in advance for the fix!

Share this post


Link to post
Share on other sites

My experience with CCleaner under XP a couple of years ago was that ACCESSED was the relevant date.

 

It really SHOULD be accessed and NOT modified

because surely the relevant date is not how long since you last modified a file,

but the last time you USED and presumably needed that file.

 

CCleaner can look at a file without changing its time stamps.

Windows Explorer under XP is UNABLE to look at a file in a listing without changing its Accessed time stamp,

but Windows cache will confuse you because it shows what it saw in the past and will NOT show time stamp changes until a reboot.

I seem to remember that DIR under CMD.EXE will show the time stamps as they are and will NOT cause a change to them.

Whatever was true of XP is likely to remain true for subsequent versions.

 

I suggest that it is not CCleaner that alters the Accessed date,

but using Windows Explorer to see if the file exists and what its time stamps might be before running CCleaner.

 

If you desist from checking up on the presence of temp files and their time stamps then the Accessed date should eventually become more than 24 hours.

 

N.B. I vaguely remember information from 2 years ago that the actual time period was 3 days and not 24 hours.

Share this post


Link to post
Share on other sites

@dvdbane - I don't understand what you're trying to tell us. Could you please clarify or say it differently?

 

@Alan_B, I understand how XP changes the Accessed time stamps & you can actually change its behavior but that has nothing to do with what I'm (not) doing with CCleaner to encounter this problem. I am not using Explorer at all when this occurs. I also am not doing anything differently than I was with previous CCleaner versions.

 

The bottom line is that CCleaner is treating those files differently in 4.05 than it did in 4.04 & earlier! When I run Analyze the first time, it identifies many (0.5 GB or so) to be removed. If I then Analyze again or Run Cleaner, it finds none. If I then change it to ignore age & Analyze, it "refinds" those Temp files...plus a few more. All of this occurs without leaving CCleaner & doing anything else - that is a bug in the 4.05 version! Or, at the very least, an undocumented feature/fix in 4.05 compared to earlier versions. I don't want to remove the last 24 hours of Temp & I do want to review the Analyze results (as I always have) before I Run Cleaner. Something has changed in CCleaner 4.05 that causes this different behavior.

 

In other words, I want it fixed to work as it did before 4.05 or I'll either have to revert to 4.04 or find an alternate cleaner - pure, plain & simple!

 

@Augeas, will you look at this problem please?

Share this post


Link to post
Share on other sites

First we should confirm that we're all talking about the same thing. Temporary Files under Cleaner/System?

 

I can't reproduce this at all (the OP seems to suggest a different problem but as he hasn't responded I'm not going to follow it). For me CC works just as it should: x files found with 24-hr box checked, y files found if unchecked, no matter how many times I analyse or check/uncheck.

 

I'm on the same CC portable version as you but Win8P.

 

If I show the summary results and open the containing folder and look at the file properties, the older than 24 hrs files all have last modified dates of today, but last accessed date of a few days ago. So it seems that CC is acting on last accessed date. You could check what your dates are and what happens to them when you run CC.

 

I can't look into this as you suggest, as I have no such capability, but there have been a number of posts recently about 4.05's cleaning so I'm sure Piriform are aware of these things.

 

A little later.... I've just tried this on Win XPSP3H. It works just as the above, using both CC 4.05 portable and 3.36 slim installed. I can't get it to go wrong so I'm not sure what your pc is doing.

Share this post


Link to post
Share on other sites

Yes, Windows System Temporary Files. I ran CCleaner 4.05 yesterday in sequential order, doing nothing else in between, with the following results:

 

24 hour box checked

Analyze - Temp = 466,143 in 1,343 files out of a total 528 MB to be cleaned

Run Cleaner - Temp = 19,716 in 25 files removed out of a total 91.4 MB cleaned

 

24 hour box unchecked

Analyze - Temp = 446,572 in 1,320 files out of a total 436 MB to be cleaned

Run Cleaner - Temp = 446,572 in 1,320 files out of a total 436 MB cleaned

 

This is not the behavior that I've experienced in the past. I normally do the first 2 operations but get equal results for both Analyze & Clean in the Temp files section, as I did when I unchecked the 24 hour box. I suppose I could roll back to 4.04 & prove things work normally then come back to 4.05 & not normal again. The main thing is that I need to know how to get Piriform to take a look at this bug! I'm not just a "typical" user either; I'm an IT Consultant & have worked in IT longer than probably many of the users here have been alive.

 

I'm on XP Pro rather than Home but I don't know any reason that would make a difference. Have you tried 2 Analyzes back to back without messing with the 24 hour box? Or an Analyze immediately followed by a Clean? The only thing I do in between the Analyze & Clean is look through the details of the files within CCleaner but I've always done that. The key here is that I haven't changed anything in the routine I follow with CCleaner but I'm getting totally different results on 4.05!

Share this post


Link to post
Share on other sites

I believe my issue might just be related to this one. I use PocoMail as an e-mail client and when I tic "Temporary files' and run "Analyze," nothing shows up as being about to be deleted. However, when I "Run Cleaner," my client e-mail gets trashed somehow, disallowing the receiving of e-mails. This holds true whether I tic "Only delete files older than 24 hours," or not. This email client is portable and does not write to the registry or to any other folders that I am aware of. No files within the PocoMail folder appear to be changed or deleted, so it's something else relating to CCleaner's "Temporary files." I would like to know what temporary files are deleted or folders cleaned by CCleaner that do NOT show up when I "Analyze." Clearly it's somehting...

 

PS) I've gone back as far as the last V3.X of CCleaner - same issue.

 

Well, I finally solved the problem. It wasn't CCleaner after all - it was avast! antivirus! When avast! is set to scan incoming mail, it creates an empty folder "_avast_" as a subfolder under the "Temp" folder; When I run CCleaner with "Temporary files" ticked, it removes this empty avast! folder and pop3 email will no longer be imported (avast! stops it.) As soon as I create a new "_avast!_" folder under "temp," my incoming email works fine again. So leaving that folder in tact when running CCleaner fixes the problem. However, keep in mind that if you do have this same scenario, you must do one of two things; disable the cleaning of temporary files in CCleaner and then add the files in that folder that you do want cleaned via the Winapp2.ini file OR disable the scanning of incoming pop3 mail in avast! (my personal choice.) If there is a way to make exceptions to ticking "Temporary files," I am not aware of it. Now that avast! is doing this, it might be a nice improvement to be able to exclude files and/or folders of your choice while cleaning temp folders. Suggestion for Piriform.

 

And oh, by the way, it's certainly possible that you could be running other apps that create temporary files or folers in your temp folder and CCleaner may be having an adverse effect on them, as well.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...