Jump to content
CCleaner Community Forums
srwpchelp

CCleaner & Google Search Settings

Recommended Posts

Just recently, CCleaner has started to clear my search settings in Google.

You change the settings by doing a search and then clicking on the "Options" icon.

One person has reported the same problem with Ixquick.

I've updated CCleaner twice recently (currently v3.26.1888). Perhaps the problem is as a result of one of the updates.

It never used to clear the Google settings.

 

All my Google related cookies have been added to the "cookies to keep" list.

Unticking "cookies" in the CCleaner main menu ("Windows") makes no difference.

I have Windows 7 Professional & IE9.

Share this post


Link to post
Share on other sites

When I run CCleaner using my wife's user account, the Google search settings are not re-set.

They are only re-set when I use my account.

Help !!

Perhaps the difference is that your wife does not have admin privileges.

 

Hazelnut is not logged in so I will risk saying "That is how I manage my computer as well :) "

Share this post


Link to post
Share on other sites

Just a long shot, but try unchecking "Adobe Flash Player" in case it's a flash cookie thing.

 

I can't think of anything else which could cause this to happen, and I'm guessing this is only when you run CCleaner, and isn't something within IE9 causing the problem?

 

 

EDIT: Also have a look here if you use the registry cleaning feature of CCleaner ...

 

http://forum.piriform.com/index.php?showtopic=37526entry228335

Share this post


Link to post
Share on other sites

Unticking "Adobe Flash Player" made no difference.

 

I have found a solution to the problem.

I unticked all boxes on the "Windows" tab and gradually added them back.

You need to leave the "Temporary Files" box unticked.

The only downside is that I'll have to delete my temporary files every now and again using CCleaner and then change the Google settings again.

 

Google appears to store the Search Settings in one of the following folders :-

 

C:\users\xxxxxx\Appdata\Local\Temp\

C:\users\xxxxxx\Appdata\Local\Temp\cookies\

C:\users\xxxxxx\Appdata\Local\Temp\History\History\IE.5

C:\users\xxxxxx\Appdata\Local\Temp\Temporary Internet Files\Content IE.5\?????\ Various subfolders.

 

It's not obvious which file needs to put in the "Exclude" list.

Share this post


Link to post
Share on other sites

Simple

 

Add them all to the "Exclude" list;

Clean;

prove that you have preserved your settings.

 

Now remove one item and clean and test to see if settings still preserved. and if not then add it back

Repeat for each item.

Share this post


Link to post
Share on other sites

Already tried that. The settings weren't preserved.

 

I can't see any of the files shown in the "Exclude" list on my PC.

Strange because I don't hide any of my folders/files.

Share this post


Link to post
Share on other sites

this behavior (edit: the placement of ie temp tile in %temp%) is caused by using protected mode in newer internet explorer versions.

 

Edit: to see these files (temporarily) set windows explorer to show system protected files.

Edited by Nergal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...