Jump to content
CCleaner Community Forums
cazboy

Can't delete files from external HD, help please!

Recommended Posts

I use an external hard drive to back up my photos and music files. All of a sudden, seemingly out of nowhere, I cannot delete files from the drive! HELP!!! Before I do a new backup, I normally delete the folder from the previous backup, and then perform the backup of the same folder with the latest photo additions. It used to be that all I had to do was plug in my external hard drive into the USB port, and then navigate to the folder I want to delete - all I had to do was right-click on the folder and select "Delete". But now, the "Delete" option isn't even there at all!! The "Properties" option is still there at the bottom of the context menu, and the "Delete" option used to be 2 or maybe 3 options above that. But no more........HELP!!! What happened to me? How can I fix my problem? I cannot fit two backups of my photos folder onto the external HD because the folder is too big for that.

 

I'm running Windows 7 Home Premium.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Probably had the context menu option erased by some program or registry cleaning operation.

 

You should still be able to delete it by selecting what you want to delete with your mouse, then pressing the Delete key on your keyboard.

Share this post


Link to post
Share on other sites

or to go even more 'old school', in the toolbars in Windows Explorer, there's File, Delete or Organize, Delete

Share this post


Link to post
Share on other sites

How about removing the external drive and plugging in a Flash drive and allocate to the flash drive the drive letter that was used by the external.

 

Then plug in the external and it will be given a new drive letter,

and just possibly any access restrictions that were applied to the old letter will not apply to the new,

and then you may be able to delete the Files,

after which you can remove the Flash and then apply the original letter to the external.

Share this post


Link to post
Share on other sites

That could possibly work. Were the user to simply change the drive letter, it may or may not work, but I believe Alan's line of thinking here, is to deceive the Windows OS into believing it has aquired a totally new drive.

 

It may work even better to safe eject the drive, then plug in another drive, & while still plugged in, plug in also the old drive (thereby forcing Windows to assign the new drive letter automatically for you).

 

Of course, this is making the assumption that this is strictly because of drive letter access restrictions of sort, instead of context menu option disappearing.

Have you tried a reboot? Sometimes extended up times can cause problems to occur that may be resolved by a reboot.

Share this post


Link to post
Share on other sites

That could possibly work. Were the user to simply change the drive letter, it may or may not work, but I believe Alan's line of thinking here, is to deceive the Windows OS into believing it has aquired a totally new drive.

 

Unfortunately Windows isn't that dumb because devices have serial numbers.

Share this post


Link to post
Share on other sites

My experience has been that Windows XP is dumb as a box of rocks :rolleyes:

 

If the power supply for the external Drive was not switched on before the computer was powered up,

then Windows would note its initial absence and when it was connected its partitions would still get the intended drive letters,

BUT it would re-enable Restore Point monitoring on its NTFS drives regardless of the registry fixes that should have stopped it.

 

I applied the Final Solution to fix it.

I took ownership of the folder "System Volume Information"

then deleted it,

then replaced it with a file having the same name of "System Volume Information".

 

More recently I have found that Windows 7 is dumb as two boxes of rocks.

It cannot properly enumerate SATA ports to which drives are connected,

but organizes according to some power-up race hazard.

 

Before I had an SSD my WDC HDD was seen by Windows Disk Management as Disc 0

and my Samsung HDD was seen as Disc 1.

Since changing connections to the SATA ports and connecting an SSD to Port 0 which SHOULD have resulting in Disc 0,

I find the SSD is normally Disc 2 and the two HDD are still Disc 0 and Disc 1, BUT ONLY ON POWER UP.

If the PC is NOT shutdown before a power-up, but instead restarted,

then the SSD becomes either Disc 1 or even Disc 0.

 

I never expect Windows to do what it ought to do when I need it to,

but agree that due to its perversity it might base ACL restrictions on serial numbers instead of drive letters.

Share this post


Link to post
Share on other sites
Guest Keatah

For future reference USBoblivion will wipe USB serial numbers from the registry, and then Windows will think it's a new out-of-the-box device.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...