Jump to content
CCleaner Community Forums
EastExpert

Speccy 1.17: "No such interface supported"

Recommended Posts

Hi there,

 

After installing an update to 1.17 I am getting "No such interface supported" instead of all results.

 

I am not a programmer anymore for ten years, so can't crack this one and suggest the resolution.

Thus would you please have a look at it.

The file is attached to this posting.

 

Cheers

M

post-62114-0-14588000-1343610234_thumb.png

Share this post


Link to post
Share on other sites

make sure the wmi service is running

if it is. Run speccy from command line with a /debug switch and you'll find a log created in the speccy folder. Post it as an attachment to this thread.

Share this post


Link to post
Share on other sites

@Eastexpert,

 

If the WMI part of Windows is to blame (as Nergal suggests) then do the following:

- download the program called "Windows Repair" (WR) (www.tweaking.com)

- tick the "Repair WMI" box.

- hit start (in WR)

- rerun Speccy and see what pops up.

 

Perhaps you need to tick the box "Set window services to startup default" in WR as well.

 

And above all: Let us know if this was helpful.

Edited by Willy2

Share this post


Link to post
Share on other sites

that's only if the issue is with WMI. I was spitballing, we should let the OP answer if it is running or not before making suggestions. ;)

Share this post


Link to post
Share on other sites

I know. After all, I wrote "If". But I know WMI is used to pull up A LOT OF computer info.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×