Jump to content
CCleaner Community Forums
Augeas

Filter in 1.43 is strange

Recommended Posts

The new (unannounced at the moment) version of Recuva, 1.43, acts rather strangely with the File/Path filter, which thew me for a while.

 

If you scan with something present in the File/Path box, either a char string or a file type (pictures, etc), then the display shows what you filtered on, as you would expect. But you can't get out of this filter, either by clearing the box or selecting another file type. This is rather puzzling, you have to clear the box and do another scan. That's not too bad with a normal scan, but you would be peeved if you'd run a deep scan with a filter and then had to do it all over again. Unless I've missed something, of course.

Share this post


Link to post
Share on other sites
Guest Keatah

I have not played with it yet, it does sound awkward. I would hope for a point release to change the behavior.

Share this post


Link to post
Share on other sites

I think it's screen resolution issue, or I'm not understanding your error

I typed in a search and pressed the red x and the filter left

post-21882-0-27464400-1342140324_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Nergal,

 

I opened Recuva in my default Advanced mode, typed zz into the filter box, and pressed scan. The display panel showed four hits, and 1868 ignored. If I press the red x, or clear the filter box, or select any file type from the drop-down list without rescanning, I still get four (or fewer) hits. The original filter parameter is maintained.

 

If I clear the filter box and rerun the scan I get the full display with no files ignored. I can then enter zz or whatever and get any filter variation I wish. It's entering the filter value before the scan that's the problem. More of a nuisance really as a normal scan only takes a few secs, but a deep scan with a filter parameter would be aggravating, I imagine.

Share this post


Link to post
Share on other sites
Guest Keatah

@Nergal - I don't believe this is a screen resolution issue.

@Augeas - I just verified, too, that is indeed the behavior.

 

 

I believe *IF* you begin a scan with something already in the box like *.jpg (for example) then this particular scan instance will only show *.jpg files. Forever and ever! Clearing the red box at this point will not reveal any other files like .doc or .txt or whatever. Just try it. You cannot change your mind and now look for *.doc files. This scan instance is valid for .jpg files only. It seems the scan filter is permanently applied for this scan run.

 

But.. If you begin a new scan with nothing in the box, then after the scanning and processing, all files are recognized. And you can *THEN* type in *.jpg to filter, and then type *.txt or perhaps *.zip. You can go back and forth between filetypes/filters without having to re-scan.

 

Does that clarify the OP's comment?

 

I also think that there should be a drop-down option in there (where you type the filter) that reads as -- [All files *.*] --

People may sometimes think you need to have the box populated and that you can go back and forth between categories. When in reality, if you start out with "pictures" you need to stay with "pictures" or the file extensions limited to pictures.

 

I see this being a problem with multi-hour scans.

Share this post


Link to post
Share on other sites

ahh you're typing the filter before the scan?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×