Jump to content
CCleaner Community Forums
Tom AZ

Where is my external drive?

Recommended Posts

I have two USB external HDDs on my Windows XP SP3 system. From time to time, one of the two drives (always the same one) doesn't display (show up) in "My Computer" even though it seems to have loaded properly at startup and is functioning. Usually after one or two reboots, it finally displays properly..

 

Any thoughts as to what might be causing this?

Share this post


Link to post
Share on other sites

Is it possible the "dodgy" one may sometimes be connect at a downgraded USB1 speed.

Windows does not always play nice with USB drives.

Share this post


Link to post
Share on other sites

Seagate FreeAgent 500 gb external USB HD here.

That happens here also, more often after computer goes to sleep. The way I wake the USB drive up is to

- use the safely remove hardware option, wait till the light goes out, then unplug the usb cable

- unplug the power, make sure it stops spinning,

 

Then plug the power cord back, then the USB cable. Never failed yet. Bit easier than restarting the whole computer, maybe. :)

 

Edit, after Alan's post while I was typing. My USB HD has always done that, since it was new. But lately it is making disturbing noises, so I backed up the whole drive to another one.

Edited by login123

Share this post


Link to post
Share on other sites

Is it possible the "dodgy" one may sometimes be connect at a downgraded USB1 speed.

Windows does not always play nice with USB drives.

Not sure - how would I know? And what would I do about it if it were?

Share this post


Link to post
Share on other sites

Check the disk manager to see if it shows, perhaps it is not initiating correctly

Share this post


Link to post
Share on other sites

Not sure - how would I know? And what would I do about it if it were?

I would know because in USB1 mode it will take much longer to transfer a file.

To fix would probably involve looking for an intermittent contact, or tweaking something in Windows Control Panel - but I forget what :)

 

If you test speed and it is slow USB1 then hopefully someone else can advise on what to tweak.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...