Jump to content
CCleaner Community Forums
zammer

Time duration for free-space wipe

Recommended Posts

It took 33 hours to accomplish a free-space one-pass wipe. Free-space had 2386MB. That seems like a long time. Is it about right? (Windows 7, CPU: Intgel Moblie Core 2 Duo T6500 @ 2.10GHZ; Ram: 4.00 GB Dual-channel DDR3@666MHz.)

Share this post


Link to post
Share on other sites

It took 33 hours to accomplish a free-space one-pass wipe.

 

I commend you for your patience — I couldn't endure 33 hrs wiping only 2.33 GB space 1-pass.

 

My Win 7, AMD A8 3800, last 1-pass wipe of 63 GB took 13 mins.

My Vista, Celeron 440, last 1-pass wipe of 62 GB took almost 2 hrs.

 

Your processor is much faster than my Celeron, slower than the AMD. Here's a comparison table

Share this post


Link to post
Share on other sites

Besides the processor possibly being on of the determining speed factors what I also do is exit as many running programs as I can when performing Wipe Free Space which includes stopping services, and completely disabling the installed antivirus.

Share this post


Link to post
Share on other sites

An afterthought ? the program may be struggling with so little free space cos it needs room for a temp file. Maybe if you transferred some files to another drive it would run faster?

 

Experiment, and like Andavari mentioned, suspend all unnecessary processes. I don't multitask while running any Piriform programs.

Share this post


Link to post
Share on other sites

Thanks,Kroozer and Andavari. For most of the 33 hours, Piriform was the only thing actively in use. I didn't shut down everything else that was running in the background, nor disable the anti-virus. To do all those things would be a lot, I trust you agree. Also, there's nothing saying they're necessary. I can't transfer files to another drive because I don't have one. Please don't take this personally, but if all that needs to be done to get a timely 1-pass wipe, it isn't worth it. (By the way, can forum be set so that the quesioner is notified when there's been a response?)

Share this post


Link to post
Share on other sites

Hi zammer.

 

Other people are having problems with the notifications for replied to posts etc, so it is a known issue which hasn't been resolved yet with this forum software. You're not alone.

 

Just a thought on your 33 hour free space wipe (that's a painfully long time), did you have the "Wipe MFT Free Space" box checked in "Options\Settings"?

 

Not having the same drive state as you (size etc), I don't know whether having it checked or not would alter the time taken, but CCleaner wipes the drive in different ways depending upon that box being checked or not.

 

Explained here ...

 

http://forum.piriform.com/index.php?showtopic=35239&view=findpost&p=212256

 

Just a thought.

Share this post


Link to post
Share on other sites

Here is what I would do. Just for a test, try this:

 

- Ensure you have downloaded & installed the latest CCleaner & Defraggler versions.

 

- Right-click My Computer/Properties/System protection & disable system restore to clear the points, then re-enable it again to create a new one. Can free 15 + GB at times.

 

- Run CCleaner, then run Defraggler. Be sure there are no un-needed programs loading in CCleaner startup area, including BHO/Scheduled tasks. Usually, just A/V is fine.

 

- Reboot, & tap F8 key repeatedly about once per second till you see the safe mode options, & boot into safe mode.

 

- Try drive wiper in safe mode, with MFT wipe unselected as per Denniss's suggestion above.

 

* If your computer still does a very slow wipe after defraggling to get your free space unfragmented, & clearing the old restore points/disabling startup items, etc, I have to say that it sounds like either your computer is running very slow (overheating? check your fans & blow out any dust around CPU/Graphics/Case fans) or perhaps you have malware inhibiting the performance of such due to a hidden filter driver impeding the normal operation of Windows.

 

Alternatively, it is possible your installation got corrupted somehow, & that could cause your system to run improperly. Whether registry corruption, or file corruption, both can interfere with normal operation.

 

Lastly, check your DMA settings in the Device Manager. If they are PIO mode, you need to right click the controller, uninstall it, & let it re-install it after you reboot. If Windows coughs, takes a long time to do things, or has other problems, it can cause it to decide that it needs to step down the controller speed.

 

This can result in 33 hr speeds as listed above. Normal drives operate in DMA 2 for CD/DVD drives, & DMA 5 or 6 for HDD drives.

 

Letting Windows reinstall the controller usually can restore default DMA settings, unless there is a problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...