Jump to content
CCleaner Community Forums
Sign in to follow this  
oryan_dunn

Devs, what causes XP to not report battery remaining time?

Recommended Posts

Here's what Speccy reports:

battery.png

 

Windows XP also does not show time remaining, only percent. What causes this to be unknown? I tried uninstalling/reinstalling the battery in the device mananger, but that didn't change anything. Is there an option in the OS somewhere that will enable this? I believe when the laptop was new, it showed the time remaining.

Share this post


Link to post
Share on other sites

It also doesn't show the battery full time - whatever this means. This could be the estimated time to full recharge. If this is so then a better name should be used i.e. "ETA to full charge". Likewise, the other filed could be "ETA to full discharge".

 

One can estimate this based on timestamping the 100% and when it reaches 99% charge get the system clock and timestamp that value. Using simple math one can compute the rate of discharge and estimate time remaining. Since the rate of discharge can be variable based on cpu and hardware loading one will have to recompute the estimated time remaining.

 

see www.passmark.com batterymon program. It gives the data that speccy should, along with a graph showing discharge or charging of the battery. Speccy can do the graphing if this option was added. Moreover, the battery has an internal count of the number of recharge cycles. Usually when it reaches 300 recharges, (or about two years), the batteries need to be replaced. Thus one should be able to read the battery pack via the smbus and read this count along with other prestored date in the internal battery pack flash chip that would be of interest to the user of Speccy.

 

Moreover, the program "speedfan", shows a "temp1" value. Their usage of this by them is that it means the ACPI temperature. That is this is the temperature of the battery pack or any of the power electronics (if it has temp probes).

Share this post


Link to post
Share on other sites

do you have an APC UPS and have PowerChute software installed? the software might be interfering with the readings on this software since it superseeds the windows native power manager's prefs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...