Jump to content
CCleaner Community Forums
Tom AZ

Some help needed with internet speed

Recommended Posts

I'm using high speed internet(cable) with a rated download speed of 15Mbps. Also using a fast modem and fast wireless router by way of an ethernet connection.

 

Here's the problem... my download speed is generally in the range of 6-8Mbps - on occasion slightly higher or slightly lower. Thought there might be a problem with the my provider, so had them come out to analyze things. Turns out that I was getting a strong signal. In fact, when he bypassed my desktop computer (Windows XP SP3) and went directly his own netbook, he got around 20Mbps from my modem and about the same from my router.

 

So it appears the problem lies with my computer. Something seems to be holding back the speed, but I can't figure out what it is. All along I've been using optimized TCP settings, so that's probably not the problem. Not sure what else it could be unless it's a defective network card. Or, are there some other network settings somewhere I should be checking?

Share this post


Link to post
Share on other sites

Aren't network speeds dependent on the companies that control them or the underwater cables (maybe satellites) they're connected to?

Share this post


Link to post
Share on other sites

Try booting into safe mode w/networking (press F8 key at startup just after the bios post screen for the boot selection menu). Then run a speed check again. If it runs better, then your issue involves one or more applications or processes running in normal mode. The usual suspects would be the personal firewall, antivirus, and other security software. Try temporarily disabling these items and test again. Performing a clean boot would also help (see MS help and support for instructions). Good luck.

Share this post


Link to post
Share on other sites

Thanks so much, Legacydude, for the suggestion. With your help I found the culprit -- it's the "Web Shield" in my Avast 6.

 

Don't know whether or not you use Avast, but obviously, I can disable that individual "Shield" and it definitely takes care of the problem. Short of that, there are some individual settings and Exclusions in that shield, but I'm not sure just what to change to correct the problem and still be able to keep the Shield active.

Share this post


Link to post
Share on other sites

Good to know, Tom. I sandbox windows in vm's these days and almost exclusively use avast for these and for clients for whom I consult. I'll keep a close eye on this anomaly associated with an otherwise good product.

Share this post


Link to post
Share on other sites

Actually, I was able to recover a little less than half of my lost speed by simply unchecking "Use Intelligent Stream Scanning" in the Main Settings window of the Web Shield. That way I was able to keep the shield active for at least some protection. Because I also use Sandboxie, I figured that making this setting change was probably not a significant issue.

 

Sure wish there were a couple other settings in the Web Shield that could either be modified or disabled to pick up even a little more speed without totally disabling this "shield," but I don't have the knowledge to know which ones.

Share this post


Link to post
Share on other sites

I see the following condition a lot:

 

1. Speed test provided by isp (internal to its domain) results in speeds at or above subscription rate.

 

2. External speed tests, such as toast.net or cnet.com, results in speeds markedly lower, sometimes by 50% lower or even more.

 

Moral: once you venture past the gates or perimeter of your isp, all bets are off.

 

What if your isp does not offer its own internal speed test utility or service? You can still measure download/upload speeds via ftp between your PC and the online storage space the isp provides for your account (many do).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...