Jump to content
CCleaner Community Forums
Willy2

Text string bug in CCleaner

Recommended Posts

Came across another small (!!) text string bug in the latest CC v3.11. Here's how to find the bug.

 

1). Untick every box in the Windows and Application pane except for ""Adobe Flash Player"" in the ""Multimedia"" section in the Application pane.

2). Hit ""Analyze"" and then (hopefully) one line appears with a summary of files to be removed. CC clearly states ""(Note: No files have been deleted yet )"".

3). Click on the line that's being displayed and CC will display the details of the files to be removed.

4). If the user has one or more flash cookies then CC displays one or more times the text ""Removed cookie: "", followed by the name of the cookie/website. That text ""Removed"" VERY clearly contradicts the message displayed as mentioned under 2) (See above, in bold characters).

 

The text string should be e.g. ""Cookie: ....."" or ""Flash cookie: ..."" before the user hits ""Run Cleaner"".

And e.g. ""Removed cookie: ...... "" after the user has hit ""Run Cleaner"". Or perhaps CC should use a more neutral text like e.g. ""Cookie: ..."" or ""Flash cookie ....."" for the text that's being displayed both before and after the user will hit/has hit ""Run Cleaner"".

 

Now when I am writing this, I have another suggestion for CC:

1. Let CC display an additional text something along the lines of ""Files to be removed :"" somewhere at the top of the screen that details which files are to be wiped.

2. Let CC display an additional text something along the lines of ""Files wiped"" or ""....... removed"" "" somewhere at the top of the screen that details which files actually have been wipe/removed.

This certainly would reduce the remaining confusion, because now the user can - IMO - be confused whether files are actually removed or not. It's a confirmation at what stage CC is.

Edited by Willy2

Share this post


Link to post
Share on other sites

This error/bug hasn't been fixed in the latest CC version (v3.19).

Share this post


Link to post
Share on other sites

Gold Star for perseverance Willy.

(reminds me of Shawshank Redemption - keeps writing those letters and the State will answer you - eventually)

Share this post


Link to post
Share on other sites

@mta: I know for sure the Piriform developers are aware of this bug but they seem to have other things on their mind.

Share this post


Link to post
Share on other sites

@mta: I know for sure the Piriform developers are aware of this bug but they seem to have other things on their mind.

 

In fairness, a minor display bug that takes half a page to describe is never going to be considered a critical issue for any software project.

Share this post


Link to post
Share on other sites

What I have learned is that the most blatant bugs "get squeezed" first. The more a bug is "buried deeper" in the program code the more effort it takes to "uncover" that bug. And CC is in this regard no exception.

 

Besides that, I presented two solutions for this bug. A simple one and a more elaborate one. The simplest solution would take the developers - IMO - less than five minutes to implement.

Share this post


Link to post
Share on other sites

Ooops, Yes, but in both versions (v4.04 & v4.05) this still hasn't been fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×