Jump to content
CCleaner Community Forums
Willy2

Bugs in Defraggler

Recommended Posts

Bugs in Defraggler v2.04:

A. I have two (logical) drives C: and D: and it seems DF behaves weird. I did the following:

1. Started DF.

2. Analyzed drive C: and there were no defragmented files.

3. Analyzed drive D: and then were 3 defragmented files.

4. Now, when I returned to drive C: then DF didn't update the view of the list of defragmented files. DF still displays the file list of drive D:

See attachment.

 

This weird behaviour occurs only before I defrag - at least - one drive. And this behaviour didn't occur in previous versions of DF.

 

B. When are the Piriform folks going to fix the ""Defrag free space"" bug/issue ???? This bug has been around since DF v1.18 and was NEVER fixed ! It's just a matter of swapping two pointers !!!

When I want to perform ""Defrag Free Space"" then DF v2.04 actually performs a ""Defrag Free Space (Allowing Extra Defragmentation)"" and when I want to perform a "Defrag Free Space (allowing fragmentation)"" then DF v2.04 actually performs a ""Defrag Free Space"".

Share this post


Link to post
Share on other sites

Here're two more bugs in the GUI of Defraggler. In two cases the user is asked for confirmation. But no matter what language I choose the language always is dutch ("Ja" and "Nee") instead of e.g. "Yes" and "No" (english), "Ja" and "Nein" (german) or ""Oui"" or "Non" (french).

 

See the pictures in the attachment for more details. In the pictures I choose the DF language to be english.

Share this post


Link to post
Share on other sites

More bugs in DF v2.04:

1. When I change the language then DF "forgets" to ""translate"" three strings:

-- "Check for updates..." on the bottom left hand side,

-- "Drive map" on top of the filelist,

-- "Online help" on the bottom right hand side.

The only way to get these strings translated is to restart the program. So, these three stings are left out of the, what I would call, "language refresh screen"-(sub-)routine.

 

2. On the bottom right hand side of the screen ("Online help"): When the user rolls through one of the scroll down menus then on the left hand side bottom of the main screen (pane ?) an extra explanation is displayed. Then the strings "Check for updates..." and "Online help" disappear temporarily. But when I select e.g "Settings", "options..." then only the top, say 20% of the words "Online help" are displayed. And this distorted view pops up as well when the user selects a number of other menu items:

-- "Drive legend" (in "Help")

-- "Drive map" (in "Settings")

-- "Defrag File" (under "Action")

When I choose one of the other DF menu-items (e.g. "Help", "About...") then this distorted view disappears.

 

See the encircled words in the three pictures in the attachments for more details.

Share this post


Link to post
Share on other sites

Bug in DF v2.05: DF still forgets to translate the word ""drive map"" on top of the filelist when I change the language. See also post #4 in this thread. It remains ""Schijfkaart"" (dutch for ""drive map"") even in german, english, danish or polish. I need to restart the program to get the proper language string displayed.

 

Note: I write this post on a friend's PC with Win 7 64bit installed. But this shouldn't be a OS related bug.

Share this post


Link to post
Share on other sites

Perhaps I need to elaborate more regarding the bug described in post #2, because that particular bug hasn't been fixed (yet?). My native tongue is dutch so the language of Windows I use is, of course, dutch. When I change the language from english to e.g. danish, german, spanish or french, those two choices ("Yes" and "No") are still in dutch ("Ja"and "Nee").

 

This suggests that DF uses for these two particular dialogs a sub-routine/API from Windows itself, instead of using a sub-routine within DF. Then Windows notices that the language used on my computer is dutch and then displays those two dutch texts no matter what language has been selected in DF. Or perhaps Df uses the proper Windows API but it has the wrong entry parameters ? Can anyone replicate this bug ? DennisD ? Aethec ? ........ ?

Share this post


Link to post
Share on other sites

Well this happens in all applications that use windows dialogboxes (MessageBox), instead of their own forms.

Share this post


Link to post
Share on other sites

I came across another bug in DF (v2.11): Again, one word doesn't get translated when I change the language. It's the word "Color" in the tab "Drive map". I need to restart DF to get this word translated/string replaced. Seems DF doesn't read the proper word from the appropriate language file when I change the language. But DF does read it when DF (re-)starts.

 

The attachment shows this word after I changed the language from dutch to english. The dutch word "Kleur" should be replaced by "Color" but it wasn't. The word "Kleur" continues to be displayed whereas all the other text is changed/translated into english.

Share this post


Link to post
Share on other sites

Came across other translation related bugs in DF. Two words don't get translated inmediately after I change the language from e.g. english to dutch:

1. I need to click on the drivemap to get the string "[File entry"] translated to the dutch string "[Mapwaarde]".

2. The word "Highlighted" also doesn't get translated. I need to close that tab and click on block that represents a piece of a file to re-open that "Highlighted" tab. Then the dutch translation string shows up.

 

See attachment.

Share this post


Link to post
Share on other sites

I encountered some odd behaviour in DF v2.15 on my Win 7 system. And I consider this to be a bug.

 

First of all, I want to say that I like v2.15 because it lists the file type & the time a file was last modified. Thumbs up for DF !!!!

 

 

When DF comes across a defragmented directory file then DF displays the line

 

"[Folder Entry] ................................... Bestandsmap ............................... "

 

"Bestandsmap" is dutch for "Directory File. It's clear DF pulls up/tries to pull up the dutch name for this filetype. And in about 99% (100% ????) of the cases it pulls up the right dutch name. E.g. When DF comes across a defragmented "*.MOF" file, DF displays the dutch text "MOF-bestand" (= "MOF-file" in english) and not the english text "MOF-file". Thumbs up for DF !!!

 

When I change the language from dutch to english then DF still pulls up the dutch filetype names. So, it seems the file type name is pulled up from one's Operating System and the file type name is not stored in DF itself.

 

Up to this point I have nothing to complain about.

 

But when a file doens't have an extension, DF still marks that file as a (defragmented) "Directory file" (dutch: "Bestandsmap") but it should be obvious that when this file doesn't have the "Directory" attribute set, it shouldn't be marked as such. It should be named "bestand" (=file).

 

See also the picture in the attachment. E.g. the file named "Search[4]" is a file while at the same time the file named "{1778657e-35dd-......" is a folder. But DF marks both files "Bestandsmap" (=Filedirectory).

Share this post


Link to post
Share on other sites

Topic: Search function.

 

I DO think this is a flaw big enough to call this a BUG !!!!

 

When I let DF (v2.16) let do a search for a (defragmented) file then DF closes the "Search" tab and opens the "File list" tab that only shows the fragmented files !!! Instead of showing the files that DF found in the "Seach" tab. Now I have to re-open the "Search" tab again. Only then DF shows the files DF found (both defragmented & fragmented).

 

Needs to be improved, IMO !!!!

Share this post


Link to post
Share on other sites

Topic: Search function.

 

I need to add more info regarding this bug. And it certainly is a BUG !!!!

 

The bug, as described above in the previous post, only happens when DF does a "Search" for the first time after the user has started the program. The second time DF behaves as it should.
 
This can be one of those "Minor bug fixes" the developers are talking about. Needs to be improved !!!!

Share this post


Link to post
Share on other sites

Tried DF v2.17 and I can say the bug in the "Search" funtion, as described in the previous 2 posts has been fixed. Thumbs up for DF v2.17 !!!!

Share this post


Link to post
Share on other sites

Another GUI bug in Defraggler (v2.18.945) !!!!

 

I took the following steps and I noticed DF's behaviour changed:

1. - Open Defraggler and let the program analyze one disk.

2. - Reduce the size of DF the GUI window from "Maximized" (full screen) to say 60% of the screen. (it happens also when the DF GUI window is maximized. One then has to enlarge the column's width.) As a result the columns "Last Modified" & "Path" are no longer shown in the filelist in the DF GUI window.

3. - Click on each column header (e.g. "Path" or "File name") once to sort the info in that column. DF behaves as it should. E.g. when I click on "Path" (as many times as I want) then the column "Path" and the info in that column remains visible in the DF GUI window.

 

4. - Now set DF to work. Select a number of files and let the program defrag those files and after that the behaviour of DF changes.

5. - Whenever I click on any column header to sort the info in that column the GUI "freaks out". E.g. when I click on "Path" (situation as in the 1st screenshot) to sort that column, the column "Path" disappears out of the visible part of the DF GUI window and the entire column "Filename" shows up in the DF GUI window, in the left hand side of the DF GUI window. (See 2nd screenshot). And that happens everytime I click on a columnheader to sort the info in that column. It even happens when I click on the "Filename" header when that header/column is only partially visible in the DF GUI window. This behaviour is VERY confusing/annoying for a user and I consider it to be a bug. Because it doesn't happen when I haven't defragmented any files.

 

In other words: when I click on the "Path" column header (to sort the info) the GUI changes from screenshot #1 to screenshot #2.

Edited by Willy2

Share this post


Link to post
Share on other sites

Small bug in Defraggler v1.19:

 

Take the following steps:

1. - Select "Settings", "Options", "Defrag".

2. - Tick the box called "Move large files ........... "

3. - Select a number of other options.

4. - Now put DF to work with the option "Defrag (whole drive)".

5. - Select "Settings", "Options", "Defrag" again, while DF is busy. The entire tab shows up greyed out (because DF is busy) but nonetheless the tab also shows which options have been selected. (I like that feature). So far, so good.

6. - The small bug is that the box in front of the option "Move large files ............ " shows up greyed out, but UNTICKED as well !!! (Remember, I ticked the box in step 2 !!!!)

Share this post


Link to post
Share on other sites

DF still seems to have a number of bugs when it must selectively defragment & move a bunch of files. But I can't discover a pattern yet.

Share this post


Link to post
Share on other sites

Another bug in DF v2.19.

- I tried to reduce the amount of folders under the option "Move only selected folders/........... " ("Defrag" tab in the "Options" window). But after I removed three folders and restarted DF those folders keep popping up. I simply can;t get rid of them.

 

Is this a bug in DF v2.19 or is some odd registry setting "wreaking havoc" ?

I added the "Defraggler.ini" file to this post for more info.

Share this post


Link to post
Share on other sites

- The solution for the problem in the previous post was to manually remove (with a text editor) the lines that were causing the trouble.

Share this post


Link to post
Share on other sites

Nope. DF v2.19 makes the same mistake again. I was fiddling around with the program (can't recall all the things I did and in which sequence I did those things). But the endresult was that when I opened the "Exclude" tab ("Settings", "Options") three folders were listed more than once.

 

I also noticed that the program doesn't sort the "MoveToDriveEnd=......... " folders. However, the "Excluded=........... " folders are sorted. Odd. Looks like this DF program code needs some decent improvements.

 

For more details, see also the *.zip file in the attachment.

Share this post


Link to post
Share on other sites

The folder "C:\Windows" was listed 4 times in "Exclude". I removed 3 of those 4 lines (using the GUI), closed DF. But in "Defraggler.ini" those 4 lines remained. So, DF somehow fails to remove those lines in the *.ini file.

 

Update: I told DF to store the settings in the registry and now (it seems) this odd behaviour doesn't show up anymore.

Share this post


Link to post
Share on other sites

The behaviour of the "QuickDefrag" tab (Settings >> Options) is a mess.

 

- Consider the lines (in italics) below. These 5 lines are the default values/settings for "QuickDefrag". Even when these 5 lines don't exist.

 

QDUseCustomParameters=0

QDMinFragmentSize=1;50

QDMaxFragmentCount=0;2

QDMinFileSize=0;0

QDMaxFileSize=0;100

 

I would like to see the following changes made to this tab.

1). If one or more of the lines above don't exist/are missing then the value of each missing line should be set to zero or read as zero (0 or 0;0).

2). If QDUseCustomParameters=0 then DF should display the current/active values/status of the other 4 lines and should be greyed out. Even when those values are zero or are read as zero.

3). If QDUseCustomParameters=1 then DF should display the current/active values/status of the other 4 lines and (of course) not grey them out.

Edited by Willy2

Share this post


Link to post
Share on other sites

In the previous days I tested DF v2.19 (especially QD) even more. And yes, there're more things that don't behave well and need to/can be improved.

 

Let me start first by saying that the search algorithms for the "QuickDefrag" (QD) tab seem to WORK (unlike those for the "Defrag" tab) !!!! Thumbs up !!! But QD also takes the settings of the "Exclude" tab into consideration. An additional "Thumbs Up" is appropriate.

 

- Get rid of the option "Have smaller fragments than". Because DF doesn't show how large the fragments of a defragmented file is. That remains a mystery for the user.

 

- When the user has put DF to work, is busy, then the user is able to open "Settings" (main screen) again to see which settings are active but those options are then greyed out. (I DO like that feature !!). But I would to like to see that in this particular situation, DF greys out (much) more options or simply greys out everything in those/all tabs. Then DF doesn't run the risk of being "thrown off the rails" when the user changes one of those non-greyed out options.

 

- In the previous post I explained how the greying out of the QD tab should/can be improved. A good example of how this should be done is already available in DF itself. Just change some settings for QD, put DF to work and while DF is busy, open the QD tab again. That's a GOOD example of how the greying out should work.

 

-The current behaviour of the QD tab also strongly suggests that there're 2 different subroutines in DF that each grey out this tab. Perhaps those 2 subroutines can be merged into one ?

 

- "Defrag" tab GUI bug.

 When "Defraggler.ini" contains this line:

 

MoveLargeFilesToEndOfDrive=1

 

and the user has put DF to work and opens the "Defrag" tab again then the subroutine, that greys out this tab, assumes

 

MoveLargeFilesToEndOfDrive=0 !!!!

 

(i.e. DF greys out the entire tab but unchecks (!!!) the associated box.)

But when DF has finished it operations then the GUI of "Defrag" assumes

 

MoveLargeFilesToEndOfDrive=1

 

again !!!!! (i.e. DF shows the "Defrag" tab in the normal way but also checks (!!!) the associated box again).

 

(Is this the reason why the search algorithm fails to function properly ? Does DF somewhere in this routine temporarily changes this setting ?? with the result of messing up the "Move to drive end" algorithm ?)

 

- Another suggestion regarding QD:

When the user puts this option to work then DF will compile a list of files that match what's specified in the "Exclude" tab but at the same time it doesn't apply the QD options. I think DF should apply those QD options as well, BEFORE DF displays the file list. Then the user knows of what files meet both the QD & "Exclude" requirements.

 

- Is it really necessary that DF calculates "Disk Performance" ? I personally would get rid of it. Or is there an option to switch it off ? Perhaps DF can provide, in a next DF version, the user an extra option for switching off and on this feature ?

Edited by Willy2

Share this post


Link to post
Share on other sites

Post removed.

 

Linking to a thread about your own suggestions does not have anything to do with your bug reports.

Share this post


Link to post
Share on other sites

I need to re-write two things from reply #22:

- I overlooked that DF already has an option called "Disable Benchmarking After Defrag".

- If

 

MoveLargeFilesToEndOfDrive= 1

 

and DF (temporarily) greys out the "Defrag" tab then, due to the way DF greys out this tab, the user is led to believe that

 

MoveLargeFilesToEndOfDrive= 0  !!!!!!

Edited by Willy2

Share this post


Link to post
Share on other sites

More bugs in the "Defrag" tab (DF v2.19) !!!

 

- I had specified 4 folders to be moved to the end of the drive. (see below, in italics)

 

MoveToDriveEndFiles1=PATH|R|C:\Antiwar|*
MoveToDriveEndFiles2=PATH|R|C:\Diverse dames Uitzoeken|*
MoveToDriveEndFiles3=PATH|R|C:\Win 7 Pro 64bit - Nieuw|*
MoveToDriveEndFiles4=PATH|R|C:\Een Rotterdamse Aziaat|*

 

but when I deleted 3 of those folders (using the "Defrag" tab GUI), closed DF & started DF again then those 4 lines showed up again in Defraggler.ini.

 

This behaviour clearly suggests that the DF subroutine that writes info to the *.ini file (not the registry ??) has some serious problems. Because this behaviour also shows up in the "Exclude" tab.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×