Jump to content
CCleaner Community Forums
dimi63

Speccy 1.08.218 erroneous RAM report

Recommended Posts

Speccy 1.08.218 reports installed RAM as the available RAM and does not report spd.

On a second instance, everything is reported correctly!

As you can see in the attached screenshot of 2 instances of portable speccy, it's showing different memory sizes and no spd in the first one, on an hp probook 4520s with 4GB RAM, running Windows7 Pro 32-bit, i3-370 CPU.

Any ideas??

post-45210-0-05113000-1298368081_thumb.png

Share this post


Link to post
Share on other sites

Run speccy and post debug data: - "C:\Program Files\Speccy\speccy.exe" /debug (including quotes)

 

Richard S.

Share this post


Link to post
Share on other sites

In 32 bit Operating Systems the CPU can only address up to a total of 4GB of RAM, however the top of this address space is reserved for your graphics card and PCI I/O space so you never get the full 4GB to use.

You need a 64 bit Operating System and a BIOS capable of hardware address remapping to use 4GB RAM or more.

 

Richard S.

Share this post


Link to post
Share on other sites

This is not what I'm reporting...and I do know that much about PCs after 25 years. :)

If you can please take a look at the initial post and the pic, you will see that, in the left screen, speccy reports as installed RAM the RAM available (to the OS), and does not report spd, whereas in the right one, it reports the correct installed and available RAM + the spd.

 

In that pic you see two speccy instances for the same PC...and that is erroneous RAM reporting!!! It should have been the same at all times.

 

By the way CPU-Z reports the RAM and the spd correctly at all times, i.e. there is nothing wrong with the laptop, that's why I created this post, to report a possible speccy bug.

 

Thank you. Dimi

Share this post


Link to post
Share on other sites

Yes, this is a known problem and the developers are looking into it.

When you ran it in debug mode a Log was written to the speccy folder

can you please attach (as an attachment) that log to this thread

Thanks

Share this post


Link to post
Share on other sites

I am just a user with a few extra privilages (the abilty to ban spammers mostly) but the developers read every post so they will look into this.

 

(Note to all I would have directed the poster to the other topics on this subject but they seem to be not available at the moment)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...