Jump to content
Piriform Community Forums
Sign in to follow this  
rampmonkey

Ccleaner won't clean Firefox

Recommended Posts

I've been using both Firefox and Ccleaner for many years now, and Ccleaner not cleaning Firefox has been a problem for a while. No matter what version of either I use, Ccleaner will only clean Firefox the first time after installation. After that, I get no results showing that it has done so. I've uninstalled and reinstalled both. I make sure that there are no Firefox.exe processes running, and Ccleaner will not clean anything from Firefox. My .ini file confirms that Firefox is selected to be cleaned, and the progress bar shows Firefox being cleaned, yet no results. Currently, I am running FF 3.6.13, and Ccleaner 3.02 on WinXP Pro SP3. Please help.

Share this post


Link to post
Share on other sites

Is there anything to clean? If Firefox is already configured to clear history when it closes there may not be anything. CCleaner will look, and that might be what you're seeing. In FF Options/Privacy see if "Clear history when FF closes" is checked. If so, open "Settings." There are options to clean Cache, Browsing History, Download History, and some others when FF closes. I'm not sure what the "Internet History" entry in CCleaner is. It might correspond to "Offline Website Data" in FF's options. If so, FF has never stored any Offline Website Data as long as I've been using it ( many years). It's different from regular cache but as far as I can tell it has no purpose at all.

 

That may or may not help. If that's not it then I don't know.

Share this post


Link to post
Share on other sites

I've been using both Firefox and Ccleaner for many years now, and Ccleaner not cleaning Firefox has been a problem for a while. No matter what version of either I use, Ccleaner will only clean Firefox the first time after installation. After that, I get no results showing that it has done so. I've uninstalled and reinstalled both. I make sure that there are no Firefox.exe processes running, and Ccleaner will not clean anything from Firefox. My .ini file confirms that Firefox is selected to be cleaned, and the progress bar shows Firefox being cleaned, yet no results. Currently, I am running FF 3.6.13, and Ccleaner 3.02 on WinXP Pro SP3. Please help.

As an experiment I would suggest that you run CCLEANER as a portable, i.e. not installed, but from a flash drive. I use it everyday that way and it appears to work. Then again I am running on XP 64.. :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×