Jump to content
CCleaner Community Forums
cookieeater

Temp folder hang when analyzing and cleaning

Recommended Posts

Recently, I unchecked the "Only delete files from the Windows Temp folder older than 24 hours" and then checked it again. Before I unchecked it the analysis of the Temp folder was almost instant. Now it hangs for ~20 seconds before proceeding despite being on the same settings.

 

Is there a way to remedy this so that I can regain the 'pre-meddling' analysis time?

 

Thanks.

Share this post


Link to post
Share on other sites

Yes.

 

It seems to scan everything in the Temp folder now as opposed to before, for example, it now scans and analyses anti-virus IDE files in there. And when the analysis finishes it displays that there is a greater amount of data to be deleted than it actually does. It says ~100MB of data will be deleted if I actually clean it but the post-clean screen displays ~1MB being removed and it hangs during the cleaning of the Temp folder for 10 seconds which it didn't do before.

 

Could it possibly be something to do with the settings and entries in the registry? I've already tried uninstalling it and then re-installing it.

Share this post


Link to post
Share on other sites

Could it possibly be something to do with the settings and entries in the registry?

 

You could try saving the settings to INI file.

Options > Advanced > Save all settings to INI file.

 

Did you run the Cleaner with the box cleared for "Only delete files in Windows Temp folders older than 24 hours"?

 

If it's a file that's difficult to delete while explorer is running, you could try TFC - Temp File Cleaner by OldTimer.

Share this post


Link to post
Share on other sites

I ran it once with the "Only delete files in Windows Temp folders older than 24 hours" unchecked.

 

It's not so much that there are files that are difficult to delete; it's that CCleaner takes the time to analyse and report files it is not going to delete.

Share this post


Link to post
Share on other sites

Nothing else comes to mind that would help with your situation.

 

Maybe someone else will chime in with a new idea.

 

Please post your Operating System and the version of CCleaner that your using.

Share this post


Link to post
Share on other sites

You could check the ini file to see what the setting is in it for temp files 24hrs, in case it is 'stuck' ( unlikely but hey, you never know!!)

 

What about reinstalling ccleaner over the top of itself to see if it 'mends' it.

Share this post


Link to post
Share on other sites

I've tried re-installing CCleaner over itself as well and it didn't work. I've looked at the before and after .ini file and there is no discernible difference except for the DelayTemp value which is 0 for when "Only delete files in Windows Temp folders older than 24 hours" is unchecked and 1 for when it is. I think I'm just being too pernickety, in any case, I'm going to click on the "Restore default settings" button (so stupid to have not seen it) now to see if it fixes the 'problem'.

Share this post


Link to post
Share on other sites

Updating to CCleaner v3.01 and restoration to default settings seems to have done the trick. It's gone down from 30+ seconds to ~4 seconds.

 

Glad to see that you worked it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×