Jump to content
Piriform Community Forums
nickanis

Display Recent Documents

Recommended Posts

After running CCleaner (which is an otherwise GREAT program) on several machines, I can no longer get the list of recent documents to display even when I enable that function with the start, right click, properties, not classic menu, customize, advanced, and check "list my most recently opened documents" - how can this list be displaced in the future after using CCleaner because Microsoft's instructions do not work ?

Share this post


Link to post
Share on other sites

Do you mean the list is empty (which it should be if you selected Cleaner Settings > Windows > Windows Explorer > Recent Documents)? or do you mean that you've lost the shortcut on your Start menu?

Share this post


Link to post
Share on other sites
Do you mean the list is empty (which it should be if you selected Cleaner Settings > Windows > Windows Explorer > Recent Documents)?  or do you mean that you've lost the shortcut on your Start menu?

 

 

 

 

I mean that if you press START there is no longer any Recent Documents Folder and there are no recent documents listed and Recent Documents can not be re-enabled by altering the register or by checking the box in the start up menu. CCleaner not only removed the Recent Documents listed it also removed the folder and appears to have permenantly disabled Recent Documents.

Share this post


Link to post
Share on other sites

I just renabled this on my pc and it works fine(and I have been using CCleaner for over 2 years). Look here:

 

untitled9nc.th.jpg

 

Make sure you are pressing ok when you check the box to display this folder and are not just pressing the x to get out of the menu.

Share this post


Link to post
Share on other sites

To eliminate the possibility of the obvious ... did you check to see if you have a C:\Documents and Settings\[userName]\My Recent Documents folder?

Share this post


Link to post
Share on other sites
To eliminate the possibility of the obvious ... did you check to see if you have a C:\Documents and Settings\[userName]\My Recent Documents folder?

 

No I do not have that folder - and if I create it - it makes no difference. I noticed CCleaner once had a bug with Recent Documents, but the history does not elaberate what the problem was. I am also using hitmanpro.

Share this post


Link to post
Share on other sites

My Recent Documents on the Start Menu isn't really a folder, it's a shortcut to the folder. Enabling it in Start Menu > Customize doesn't work because the target folder is missing.

 

If I recall correctly, creating a new My Recent Documents folder won't work because that's not the correct name. I tried copying mine to another folder and deleting the desktop.ini. The folder name then showed as "Recent". The desktop.ini was:

 

[.ShellClassInfo]

InfoTip=@Shell32.dll,-12692

IconFile=%SystemRoot%\system32\shell32.dll

IconIndex=-21

LocalizedResourceName=@shell32.dll,-12691

 

I don't think it would hurt to try but get a second opinion. You'll have to determine how it got deleted.

 

P.S.: I realized the desktop.ini might be the issue. If you have a C:\Documents and Settings\[userName]\Recent folder instead of a My Recent Documents folder, CCleaner or your other app may have deleted just the desktop.ini, not the whole folder.

Share this post


Link to post
Share on other sites

"Perhaps" Microsoft Tweak UI may work to repair the Recent Docs since it has the capability of disabling and enabling document history.

 

In Tweak UI:

Click 'Explorer', and scroll down to 'Maintain document history', if the check mark is missing click it to reenable the feature, then click 'Apply'.

 

If 'Maintain document history' already has a check mark in it, disable it and click 'Apply', then reenable it and click 'Apply'.

 

You may have to logoff, or reboot for the setting to work.

Share this post


Link to post
Share on other sites

Has anyone found a solution to this? I am having the same problem. I have enabled the recent documents under the start menu properties, and have disabled the deleteing of the recent docs in the tweak UI, but I still can't get documents to appear in my recent documents list!

 

Thanks

Share this post


Link to post
Share on other sites
Has anyone found a solution to this? I am having the same problem. I have enabled the recent documents under the start menu properties, and have disabled the deleteing of the recent docs in the tweak UI, but I still can't get documents to appear in my recent documents list!

 

Thanks

Hello cush,

I have been researching this problem for many months.

I am coming to the conclusion that problems come about by complications caused by some of the settings made the user within TweakUI.

More on this later.Don't have time now but I thought it may help you to review all the Explorer settings in TweakUI as regards Recent and History and classic.Pay attention to the words "maintain" ,"allow", and "show" . Checking(ticking) all those boxes helped get rid of a lot of self created problems for me. Recent documents was a major problem that I fixed and accidentally recreated while testing to try to figure this out.

 

P.S. OH YES. REMEMBER THESE ARE PER USER SETTINGS. GET EACH OF THE USERS SETTINGS CORRECTED.

Later,

:) davey

P.S. I use WinXP Pro SP3 and TweakUI ver 2.10

Edited by davey

Share this post


Link to post
Share on other sites
Hello cush,

I have been researching this problem for many months.

I am coming to the conclusion that problems come about by complications caused by some of the settings made the user within TweakUI.

More on this later.Don't have time now but I thought it may help you to review all the Explorer settings in TweakUI as regards Recent and History and classic.Pay attention to the words "maintain" ,"allow", and "show" . Checking(ticking) all those boxes helped get rid of a lot of self created problems for me. Recent documents was a major problem that I fixed and accidentally recreated while testing to try to figure this out.

 

P.S. OH YES. REMEMBER THESE ARE PER USER SETTINGS. GET EACH OF THE USERS SETTINGS CORRECTED.

Later,

:) davey

P.S. I use WinXP Pro SP3 and TweakUI ver 2.10

 

Thanks davey. I actually only installed TweakUI to try and solve the issue. I was not installed when the problem occured. I am still trying to resolve the issue. I know of another person that has this same issue as well. They do not have TweakUI installed.

Share this post


Link to post
Share on other sites

I have been making some changes to the registry, and after rebooting and opening a document, it is now in my recent documents. I'm not sure, but I think it was setting the following registry setting to all zero's that did it:

 

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

"NoRecentDocsHistory"=hex:00,00,00,00

 

Thanks Hazlenut. It was your earlier post about Kelly's Corner that let me to this area of the registry. I found the actual key myself.

Share this post


Link to post
Share on other sites

Watch out for other CCleaner users with this problem then you will be able to help them. :)

 

Glad you are sorted now cush.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×