Jump to content
CCleaner Community Forums

Recommended Posts

Am running Win XP Pro SP3, IE8 and Office XP, plus others. Have just started using CCleaner and have tried versions 2.27 - 2.32. My problem is that when I run CCleaner I lose all the options I have set up in Word and it reverts back to basic, ie cm not inches, different fonts to the ones I have set up, etc. Have tried editing the normal.dot and saving it and tried deleting the word data key in the registry but the problem still comes back. Have tried re-installing Office to no effect. The started re-building my hard disk and checking when the problem occurrs. CCleaner is the culprit, have re-checked four times and without CCleaner all is well, with it and running it I get the problem. Has anyone any ideas. I like CCleaner but not with this problem.

Share this post


Link to post
Share on other sites

Welcome to the forums!

 

Have you deselected the various Office check boxes in the Applications tab? That would be the first place to look. Remember that you do not have to use the default set of cleaning options, they are only a good guideline for you. I don't use the default settings myself and I know a LOT of the others here on the forums don't use that set either. If you look around here you will find some very advanced users that have extensive configurations.

 

The link below will show you my settings, but more importantly, it will show you what to look for on your own.

https://www.viclovan.com/downloads-and-links/ccleaner-2-settings#OptionsAdvanced

 

https://www.viclovan.com/downloads-and-links/ccleaner-2-settings#OptionsAdvanced

Share this post


Link to post
Share on other sites

Billjf,

 

This is not a bug. Unticking various Office boxes won't help. Only unticking the ""Office XP"" box will save those settings. CC uses an embedded script that tells CC where various info can be found and what can be wiped. And in a number of cases CC simply wipes too much. But you can finetune the CC wiping process in such a way that it doesn't wipe those settings anymore.

 

A. Click ""Options"", ""Exclude"". There you can tell CC which entries from the registry must be excluded from wiping. Add all the lines in the attachment to the registry exclude feature. Run CC with the option ""Custom Folders"", in the main screen of CC, ticked. If all is OK then CC won't wipe any setting of Office XP anymore.

 

B. Now remove step by step one line at a time from the ""Exclude"" section (as programmed under (A ) and run CC again every time after removing one line. That's how you'll find out which line causes the settings of Office XP to be wiped. There could be more than one line that wipes settings that you want to keep. A matter of trial and error.

Share this post


Link to post
Share on other sites

Thanks unclebic and Willy2. Looks like I've got some work to do. Luckily I use Norton Ghost so it is very easy to revert back if everything goes wrong. Again my thanks.

Share this post


Link to post
Share on other sites

Thanks to willy2 and unclebic it seems fixed. I de-selected OfficeXP in the Applications tab, and in the Exclude list I added a line "HKCU\Software\Microsoft\Office\10.0\Word\Data" which excluded the Word Data entry in the HKey Current User part of the registry.

 

Works OK now. Don't know if there any other implications of what I've done but nothing has shown yet???

Share this post


Link to post
Share on other sites

Billjf,

 

I hope you understand that now you have added that line to the Exclude section you can tick that box Office XP again. Then CC still will wipe a number of Office XP settings but that particular setting will be spared. wink.gif

 

There's - at least - someone who benefitted from your efforts and that's me. I use Office XP as well. wink.gif

Share this post


Link to post
Share on other sites

Billjf,

 

I hope you understand that now you have added that line to the Exclude section you can tick that box Office XP again. Then CC still will wipe a number of Office XP settings but that particular setting will be spared. wink.gif

 

There's - at least - someone who benefitted from your efforts and that's me. I use Office XP as well. wink.gif

 

I have the problem of the return address being 'lost' in Word after having run ccleaner. I tried to do as you suggested, but I have problems. When I go to try and exclude a registry entry, it doesn't seem to be listed. I select registry key, on browse, change to HKCU and type in HKCU\Software\Microsoft\Office\10.0\Word\Data\Settings, but OK is still greyed out - so I can't set it!

Share this post


Link to post
Share on other sites

Gran, welcome to the forum.

 

I think you made an error while typing a line. The last character ""\"" must be a ""|"". When you type a line in the registry section of the Exclude section CC checks (with every character you type) whether that registry entry/key/line exists or not. As long as CC can't find that line in the registry, it greys out the OK button.

Share this post


Link to post
Share on other sites

Gran, welcome to the forum.

 

I think you made an error while typing a line. The last character ""\"" must be a ""|"". When you type a line in the registry section of the Exclude section CC checks (with every character you type) whether that registry entry/key/line exists or not. As long as CC can't find that line in the registry, it greys out the OK button.

 

 

I tried changing the backslash, but no joy. After all - it is just a copy of the text posted earlier in this thread. The version of Office I am using is Office 2000, but a friend (who requires the change) uses Office 2003. Is that my problem?

Share this post


Link to post
Share on other sites

If you're using Office 2000 then start a new thread in the ""Ccleaner Discussion"" section. Then I'll respond to your question.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...