Jump to content
CCleaner Community Forums
user4

not enough space?

Recommended Posts

When Defragler is set to move large files to the end of the disk, the defragmentation process stops at some point with an error message: not enough free space on the disk.

 

This happens with the C and the D drive. D has 122 GB of free space... :blink:

Share this post


Link to post
Share on other sites

Stating which version of defraggler used, and also which operating system, will help people make a comment on this.

Share this post


Link to post
Share on other sites

Hello, I have the same problem with the new Defraggler version 1.08.132 (message about free space with XP sp3, NTFS (AHCI mode)) :( . If I re-execute the previous version (1.07.124), there is not any free space problem message. :huh:

Share this post


Link to post
Share on other sites

I am having the same problem as everyone above (Windows SP3, Defraggler 1.08.xxx).

 

I discovered that if you go to the "Files" tab and check all, then use "Defrag Checked," it will work (or seems to) and I don't get the "not enough space" error message. HTH

Share this post


Link to post
Share on other sites

yup same here

 

using windows XP sp3 - defraggler 1.08.132

 

i wanted to defraggle my c drive which have the following stats: used 4.43GB free 5.4GB. It gives me an error message: ''not enough space" :blink:

 

so i downloaded ccleaner did a free space wipe on my c drive and tried defraggler again

same problem :unsure:

 

help ?

Share this post


Link to post
Share on other sites

Same here as well.

 

OS: Windows XP SP3

Patches / Hotfixes: All of them + a bunch of Office 2003 ones.

Defraggler: v1.08.132

Volume: NTFS - I don't think compression is enabled on it.

 

I can also confirm that just defragmenting files does work. Just needed to defragment the drive before making an image of the system :)

Share this post


Link to post
Share on other sites

Me too....

 

Win XP Pro 32 bit - Service Pack 2.

 

details here:

 

http://forum.piriform.com/index.php?showtopic=21095

 

I'm sorry, I looked for a similar discussion before creating the new topic, but I found only a similar one (about disk space) but talking about spyware.... (and this is not the case: I have just formatted and reinstalled - never connected to the web without antispy, anti-rootkit, antivirus and firewall!).

 

ZeBoxx kindly suggested me to move here.

 

Thanks.

Share this post


Link to post
Share on other sites
I'm sorry, I looked for a similar discussion before creating the new topic, but I found only a similar one (about disk space) but talking about spyware....

yeah searching forums (not just the Piriform ones) can be a mess sometimes when the search terms are difficult to narrow down :) Didn't find this thread at first either %)

 

We are looking into this

Awesome - thanks for the status update :)

Share this post


Link to post
Share on other sites
When Defragler is set to move large files to the end of the disk, the defragmentation process stops at some point with an error message: not enough free space on the disk.

 

This happens with the C and the D drive. D has 122 GB of free space... :blink:

Same here, plenty of space and it said not enough space.

Share this post


Link to post
Share on other sites
Same here, plenty of space and it said not enough space.

 

The problem is that Defraggler seems to try to defragment a file called $BadClus:$Bad which is an NTFS system file containing the drives bad sectors. I have a drive without bad sectors (check with chkdsk x: where x: is the driver letter). Most disk are free of bad sectors, at least as seen from windows. Defraggler claims the file is as big as the drive is. So the file does not fit on the drive with all the other files. Maybe a bug triggerd when the number of bad sectors is zero?

 

The file does not show up in the file list. I found the file on the drive map, when you click on a square a tab Highlighted is openend containing the file using that part of the disk. I clicked on a large file and saw this special file with its very big size.

 

There are other reports mentioning this file, how ever I saw in this thread it was not yet connected to this problem, I think its the cause of the problem. So it needs to be fixed. In the mean time you could select all files and defrag only the selected files.

 

I only hope Defraggler did not make a mess of my disk by creating a faulty $BadClus:$Bad file during the defrag attempt...

 

Addition: the $BadClus:$Bad file also shows up when clicking on an unused area since it spawns the whole disk...

Share this post


Link to post
Share on other sites

To quote myself:

 

I only hope Defraggler did not make a mess of my disk by creating a faulty $BadClus:$Bad file during the defrag attempt...

I'm sorry to report that there is a problem now, the master file table (MFT) is way to big now. It looks like I have to take all the files off, reformat the drive and put them back on to get it correct again. (Unless the new Defraggler also makes the MFT smaller, but I guess not...).

 

Bummer...

Share this post


Link to post
Share on other sites

We have fixed an issue related to calculation of free space and this will be included in the next release :)

MrRon

Share this post


Link to post
Share on other sites

i dont know if my problem is related to this but i lost free space after running defraggler. when i started i had 93GB free space. afterwards, i had 80GB...

Share this post


Link to post
Share on other sites
We have fixed an issue related to calculation of free space and this will be included in the next release :)

MrRon

FYI, I received the error under 1.09 this afternoon. When I unchecked the "Move large files to end of drive" box, the defrag completed successfully.

Share this post


Link to post
Share on other sites

Coppertrail, can you run in /debug mode with Move large files enabled and PM me with the log

Thanks

MrRon

Share this post


Link to post
Share on other sites
Coppertrail, can you run in /debug mode with Move large files enabled and PM me with the log

Thanks

MrRon

I will do that during my next defrag on that machine. I'm fine running Defraggler without that option, but wanted to let you know as you'd mentioned that it would be fixed in the next release.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×