Jump to content
Piriform Community Forums
dawnbreaker

Missing MUI reference

Recommended Posts

Every time I scan for issues, I get the following message

 

MissingMUIreference c:\programmefiles\comodo\comodoantiviru\Emgupd\engAutoupd.exe

 

Reg key HKCU\software\microsoft\windows\shellnoroam\MUIcach

 

This happens every time I run CCleaner after every session.

 

Any fix please???

Share this post


Link to post
Share on other sites

Hi, Like many Antivirus and Antimalware programs Comodo antivirus probably does not report correctly to the MUI chache, this is done to make it harder for Malware to disable your protection and/or (as in this case) your protection's ability to update itself. It is common to see one or more entries report as missing MUI in regards to your antivirus solution.

 

If you ARE currently using the Comodo product then you can ignore the entry.

 

 

Highlight the Reg entry right click it and choose open in regedit

Go to Options

Exclude

Click the Add Registry button

Choose HKCU from the drop down and type in the key's value (in your case it'll be something like

software\microsoft\windows\shellnoroam\MUIcach\comodo )

 

Hope that helps

Share this post


Link to post
Share on other sites
Hi, Like many Antivirus and Antimalware programs Comodo antivirus probably does not report correctly to the MUI chache, this is done to make it harder for Malware to disable your protection and/or (as in this case) your protection's ability to update itself. It is common to see one or more entries report as missing MUI in regards to your antivirus solution.

 

If you ARE currently using the Comodo product then you can ignore the entry.

 

 

Highlight the Reg entry right click it and choose open in regedit

Go to Options

Exclude

Click the Add Registry button

Choose HKCU from the drop down and type in the key's value (in your case it'll be something like

software\microsoft\windows\shellnoroam\MUIcach\comodo )

 

Hope that helps

 

Thanks for the info but I don't see OPTIONS OR EXCLUDE

Share this post


Link to post
Share on other sites

Options is the button just beneath the picture of a spanner when you open CCleaner on your desktop.

 

Press options and you will then see the exclude Nergal is talking about.

Share this post


Link to post
Share on other sites
Options is the button just beneath the picture of a spanner when you open CCleaner on your desktop.

 

Press options and you will then see the exclude Nergal is talking about.

 

 

Thanks for the info........tried that but it doesn't work.

Such is life.

Share this post


Link to post
Share on other sites

Use Windows explorer and look for your missing

c:\programmefiles\comodo\comodoantiviru\Emgupd\engAutoupd.exe.

 

actually, start looking for c:\p*

I think you will find the correct spelling is C:\Program Files.

Similarly proceed through the rest of the path perhaps Comodoantiviru should have a space.

You MAY eventually discover that ...\Emgupd\ does exist, but that it is inaccessible.

Inaccessible folders are one of the "benefits" you get for free with NTFS.

 

engAutoupd.exe could exist within a folder, and Comodo could know it is there and use it even if its folder is inaccessible.

 

The folder could be inaccessible due to :-

registry corruption (inevitable "benefit" free with Windows, how I miss *.ini files); or

a side-effect of a battle between Comodo and Malware; or

part of Comodo's self protection.

If you wanted you could probably disable Comodo's protection;

BUT FIRST check on the Comodo forum - I think you could expose yourself to danger and you really need advice before tampering with malware protection.

 

If it is inaccessible for any reason, then CCleaner will always be told by Windows that engAutoupd.exe does not exist,

and when you clean the MUIcache it will be purged from the registry,

and immediately Comodo next uses engAutoupd.exe then Windows will say "I see you" and dump the reference back in the registry

(why it should do that is any-ones guess - mysteries also come free with Windows !!!).

 

Regards

Alan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×