Jump to content
CCleaner Community Forums
rog

Defragmenting is taking too long - I'm suspicius

Recommended Posts

Hi, first, sorry for my english.

 

I'm defragmenting a partition (50gb) of muy main hd (74 total).

 

It was about 9gb of fragmented files.

The program is still running after 12 hours. The last time I cheked it was at 29% and a several hours later stills at 29%.

The program is working and the hd making sound so I don't know if it's normal o maybe I have a problem.

 

Is it good to stop the program when is not complete?

 

I leave a pic here:

 

defragxj8.jpg

Share this post


Link to post
Share on other sites

18 hours since it started and still running.

 

No colors changed. Only thing different is:

Total Fragments: 10.291

 

I don't know if it's normal but I don't have days to defrag a unit (30GB!!!).

I let it go for a while and then I'm gonna stop it.

 

This program doesn't cause me a good impression...

Share this post


Link to post
Share on other sites
18 hours since it started and still running.

 

No colors changed. Only thing different is:

Total Fragments: 10.291

 

I don't know if it's normal but I don't have days to defrag a unit (30GB!!!).

I let it go for a while and then I'm gonna stop it.

 

This program doesn't cause me a good impression...

Hi Rog,

Yes,go ahead and "Stop" it.

Try defragging all the smaller files first.Do not try defragging everything at once.There are some known bugs.

Do not defrag any System Volume files.It will defragment a lot quicker this way.

 

Do it this way.Start Defraggler then click on Analyze.When that completes Click the box on the left next to where it says "filename".

This will check all the files. Now click on Size this will put all small files first in the list.Click on "Size" again this will put all the large files at the beginning of the list.Untick as many large files as possible.Untick all System Volume files.

Of course you don't have anything else running like games or music to slow it down.

Good luck,

:) davey

Edited by davey

Share this post


Link to post
Share on other sites

I think "defrag drive" function is totally messed up in the latest version. "defrag drive" only increases fragments more and more after hours. Don't use it.

 

Use defrag files (push "analyze" button and then "defrag" button) and then perhaps "advanced" -> "defrag freespace" function.

Share this post


Link to post
Share on other sites

I would like to say two things. One I have a run the latest Defraggler on an 83.5 GB partition, half full, and it has at most taken probably around an hour to perform the defrag. Two it increases the fragments because it is quickly moving the files to outside of the disk so that it can then replace them contiguously, combining the defrag files and defrag freespace functions. I do not know why it would take long on other computers, as mine is about four, five years old and everything in it is at least one generation old and mediocre at that. As davey pointed out, maybe you have other things running that are slowing it down. Perhaps you should try turning off your virus scan, as some of them will try to scan every file that is read and written, which is exactly what Defraggler does.

Good luck.

Share this post


Link to post
Share on other sites
Hi Rog,

Yes,go ahead and "Stop" it.

Try defragging all the smaller files first.Do not try defragging everything at once.There are some known bugs.

Do not defrag any System Volume files.It will defragment a lot quicker this way.

 

Do it this way.Start Defraggler then click on Analyze.When that completes Click the box on the left next to where it says "filename".

This will check all the files. Now click on Size this will put all small files first in the list.Click on "Size" again this will put all the large files at the beginning of the list.Untick as many large files as possible.Untick all System Volume files.

Of course you don't have anything else running like games or music to slow it down.

Good luck,

:) davey

 

I stopped the program and I used the windows tool. It worked perfectly. Then I did what you say for the other volumes (including D in the main hd) and it worked!

 

 

The partition has not volume files or programs, just data. I don't know what went wrong perhaps the program have some bugs doing entire volume defragmentation.

Anyway I never use the hd when I running a defragmentetion tool.

 

Thanks to all of you!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...