Jump to content
CCleaner Community Forums
MrRon

Defraggler debug mode

Recommended Posts

I'm trying to use Defraggler with exfat format hard drive but it every time crash

 

Problem Event Name: APPCRASH

Application Name: Defraggler.exe

Application Version: 1.2.0.85

Application Timestamp: 48a407c1

Fault Module Name: Defraggler.exe

Fault Module Version: 1.2.0.85

Fault Module Timestamp: 48a407c1

Exception Code: c0000094

Exception Offset: 0008b1b3

OS Version: 6.0.6001.2.1.0.256.1

Locale ID: 1033

Additional Information 1: 4725

Additional Information 2: b831c86476bad79c4fc984a339ae6492

Additional Information 3: c980

Additional Information 4: 7a194c83e25863fe548ea9b96c71effa

 

Defraggler debug log see attachments

 

Thanks

Defraggler.exe._1_2_85__2008_09_29_02_38_.txt

Share this post


Link to post
Share on other sites

I have the same problem with the new version 1.03.093 only recognizes drive c: and the read card drive, no recognize external usb hard drive. The only way defraggler recognize the external hard drive is if you run first defraggler and after that turn on the external hard drive. I think is kind a problem that wasn't before.

Share this post


Link to post
Share on other sites

This is an errorlog for the "1.03 is significant slower than 1.02"-problem!

 

In this case it was an 56GB partition on an 250GB Hitachi SATA-HDD under Windows Vista Home-Premium 64 Bit connected to an NFORCE-4 Board (DFI-LANparty 4) with an Dualcore AMD 64 X2 3800+.

 

This 56 GB (around ~20 GB are FREE SPACE!) took from 0% to around 90% defragmenting 2 whole days before I stopped it (I could swear that from 0%-80% it was going fast as always), searched the forum and made an short "snapshot" in debug mode from about 1:15h runtime.

 

Then I re-installed v1.02 and it made the last 5-10% in the time I registered my forum account here...

 

Well I have to say this is my gaming partition and Age of Empire 3 alone has a few thousand MP3s as single files, but 2 days are definatly too much ;)

 

I took an short few in the log, and what I found could be part of the problem : "Destination block is not free." and "failed to retrieve file size!"

 

edit: I made a little counting with Total-Commander and here are the facts if you are interested in: 38.341.055.143 Bytes in 18.907 files spreaded in 680 folders.

 

p.s.: Thank you for your great work with defraggler!

 

?Nuff said, here comes the log:

Defraggler.exe._1_3_93__2008_10_04_19_45_.txt

Share this post


Link to post
Share on other sites
Been liking Defraggler for the file defrag, but with the recent update it only sees the floppy drive.

Here is the debug log.

As of version 1.03.094, I no longer have this issue. Thanks!

Share this post


Link to post
Share on other sites

I have used both CCleaner and Defraggler since their young beta days. I am running into some problems with Defraggler and exFat. I have an external 120GB drive that is formated as exFAT. When I try to analyze it with Defraggler the program crashes. Everytime. Below I have attached the log. Hopefully this can be resolved very soon.

 

 

defraggler.exe._1_4_98__2008_11_06_07_29_.txt

defraggler.exe._1_4_98__2008_11_06_07_29_.txt

Share this post


Link to post
Share on other sites

Hello,

 

First, Sorry for my Bad English, I'm French user of your very nice software and like you know French people don't speak very well other languages (they don't speak very well French too :P )

 

I want to say my pleasur to see we can still found free and very good software on the web. :lol:

 

but I have a problem when I try to use this software :(

I'm luky, because it's just on one hard disk :P

 

 

here a description of my problem :

I have 3 hard disk on my computer (C : 80Go, D : 250Go and E : 120Go)

My computer are under Windows XP corporate.

and Defraggler are 1.04.098.

 

when I defrag C: and E: all is good but,

When I try to defrag D: I have a windows error message and Defraggler close.

 

I attach All Log of my problem.

 

Thank a lot for your help

LDC.

Windows_log.txt

Defraggler.exe._1_4_98__2008_11_06_20_29_.1.txt

Defraggler.exe._1_4_98__2008_11_06_20_29_.txt

Windows_log.txt

Defraggler.exe._1_4_98__2008_11_06_20_29_.1.txt

Defraggler.exe._1_4_98__2008_11_06_20_29_.txt

Share this post


Link to post
Share on other sites

Defraggler is installed in the default location and pasted the statement into the Run window which opened Defragger and a small window reading "No updates available." And no log appears in the Defraggler folder and do not see "Debug" in the Defraggler lower status bar.

Share this post


Link to post
Share on other sites

Your instructions quote:

1 - If you installed Defraggler in the default location,

 

* Press and hold the Start button and press R (opens the Run window)

* Cut an paste this

 

"C:\Program Files\Defraggler\defraggler.exe" /debug

 

* Press enter unquote

 

That only works if the Run command is in the start menu. I, and perhaps others, removed it along with some other clutter because I simply use the standard shortcut windows key/R. And when the Run window opens, I paste in your command.

Share this post


Link to post
Share on other sites
Defraggler is installed in the default location and pasted the statement into the Run window which opened Defragger and a small window reading "No updates available." And no log appears in the Defraggler folder and do not see "Debug" in the Defraggler lower status bar.

Hi again MilesCh,

The Piriform staff is a lot smaller than most people think.

The Posting is a little behind the Defraggler development.

The "debug" does not actually occur until you run the program just like you normaly would.

The "Debug" word now appears up in the Defraggler banner area.

Good luck,

:) davey Another member just like you. :P

P.S. We appreciate your report.

Edited by davey

Share this post


Link to post
Share on other sites

With Defraggler running if use the run command, a window reads it's already running. Nothing seen in the banner bar. Then used the run command without Defraggler running and when opened it read "debug" in the banner bar. The program crashed and I went to it's folder in WinExpl and there is no .log file. However, there is a .txt file which presumably is the log you are speaking of, so I've attached it. (But not certain if this is the log of running E or D, but looking reading it it appears cumulative.

 

With a little luck, you decipher why it crashes when running on E drive, else perhaps you could tell me how to return to the prior version which ran fine.

defraggler.exe._1_5_111__2008_12_07_16_34_.txt

defraggler.exe._1_5_111__2008_12_07_16_34_.txt

Share this post


Link to post
Share on other sites
With Defraggler running if use the run command, a window reads it's already running. Nothing seen in the banner bar. Then used the run command without Defraggler running and when opened it read "debug" in the banner bar. The program crashed and I went to it's folder in WinExpl and there is no .log file. However, there is a .txt file which presumably is the log you are speaking of, so I've attached it. (But not certain if this is the log of running E or D, but looking reading it it appears cumulative.

 

With a little luck, you decipher why it crashes when running on E drive, else perhaps you could tell me how to return to the prior version which ran fine.

Prior versions are always available at FileHippo.com . This is true for all Piriform products.

http://www.filehippo.com/download_defraggler/

Select the version you want from the list and Download and install.

:) davey

Share this post


Link to post
Share on other sites

Hi

My C: and H: drives are NTFS and my F: is FAT32, until recently defraggler worked perfectly on all of them. a few days ago, when i tried to analyze C: or H: defraggler either says: "analysis failed" or crashes to desktop, i can analyze and defrag F: as before.

I've attached a debug log, thanks for any help

Philip

 

[ed. never mind, i think it was trojans or viruses, i think ive removed them all now and defraggler works perfectly]

defraggler.exe._1_5_111__2008_12_15_22_28_.txt

defraggler.exe._1_5_111__2008_12_15_22_28_.txt

Share this post


Link to post
Share on other sites

I don't know why, but Defraggler can't defrag 3 Spore packages, and 2 system files : pagefile.sys and hiberfile.sys ...

 

Share this post


Link to post
Share on other sites

hiberfile.sys and pagefile.sys are hard to defrag as they are locked in use by Windows.

 

Disable Hibernate in Control Panel then Power Options then Hibernate then reboot and then defrag the hard drive then Enable hibernate.

 

Download PageDefrag then run it and select it to run at next bootup:

http://technet.microsoft.com/en-us/sysinte...s/bb897426.aspx

 

I have no idea about Spore.

Share this post


Link to post
Share on other sites

Hello,

 

I recieve windows error messages any time I try to start defraggler. It installs fine but won't run. I also tried using the portable version from a thumb drive and recieved error msg: the exception unknown software exception (0xc000000d) occurred in the application at location 0x004885c9. and wants to terminate. I also tried running it in debug mode and recieved this as the debug log. Any help or direction as to the cause would be appreciated.

Defraggler.exe._1_5_111__2008_12_17_12_12_.txt

Defraggler.exe._1_5_111__2008_12_17_12_12_.txt

Share this post


Link to post
Share on other sites

Hi. I've had defraggler working on some machines with version 1.3. Today, when I tried to run it, I got the error saying that Defraggler has encountered an error and needed to close. First I tried installing the newest version, then I did the debug. I attached the debug information that was generated. Defraggler.exe._1_6_118__2009_01_12_14_54_.txt

Defraggler.exe._1_6_118__2009_01_12_14_54_.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×