Jump to content
Piriform Community Forums
Panda

CCleaner won't remove registry entry

Recommended Posts

When removing registry entries in the new beta of CCleaner, one entry won't remove (clicking Fix Issue does nothing).

The entry says "The icon referenced by: ZAMailSafe\DefaultIcon could not be located."

 

Any ideas, or is this a bug?

Share this post


Link to post
Share on other sites
When removing registry entries in the new beta of CCleaner, one entry won't remove (clicking Fix Issue does nothing).

The entry says "The icon referenced by: ZAMailSafe\DefaultIcon could not be located."

 

Any ideas, or is this a bug?

Same problem here. Waiting for the fix. :o

 

edit: happens on the latest version also.

Share this post


Link to post
Share on other sites
When removing registry entries in the new beta of CCleaner, one entry won't remove (clicking Fix Issue does nothing).

The entry says "The icon referenced by: ZAMailSafe\DefaultIcon could not be located."

 

Any ideas, or is this a bug?

 

Actually this is a problem with ZoneAlarm (also present in a number of other applications, such as Adobe's Reader 8.0), where the application changes its icon pointer to an icon that isn't embedded within the application each time you run the application.

 

ZoneAlarm embeds its MailSafe into many email applications (such as Outlook Express) and each time you run your email application the icon pointer is changed resulting in a brand new problem for CCleaner to fix.

 

Jef

Share this post


Link to post
Share on other sites
ZoneAlarm embeds its MailSafe into many email applications (such as Outlook Express) and each time you run your email application the icon pointer is changed resulting in a brand new problem for CCleaner to fix.

But that doesn't explain why CCleaner can't fix it at all... Nothing happens when I click on Fix Issue, it stays there and stops all other issues getting fixed which means I have to fix each one manually.

Share this post


Link to post
Share on other sites
But that doesn't explain why CCleaner can't fix it at all... Nothing happens when I click on Fix Issue, it stays there and stops all other issues getting fixed which means I have to fix each one manually.

 

I found that if you turn off and then on the Inbound/Outbound MailSafe Protection (or vice versa) in the ZoneAlarm setting (email protection window), the data in the registry is changed to C:\Program Files\Zone Labs\ZoneAlarm\zonealarm.exe,-279, which CCleaner won't be upset by as it's a proper path. So that is an easy, if somewhat unexpected way to correct that registry key :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×