Jump to content
CCleaner Community Forums
Sign in to follow this  
PianoServant

Referenced Memory Error

Recommended Posts

When I run CCleaner manually (either by selecting run, or open and then clicking run) it runs without any problems. But when I set it to run during startup, I get the following error message:

 

The instruction at "0x7c910e03" referenced memory at "0xfe902c14". The memory could not be "written". Click on OK to terminate the program.

 

Any thoughts that might help eliminate this error?

Share this post


Link to post
Share on other sites

Holy crap...

 

Well, try installing these two items to see if they clear up the problems (these are the latest Visual Basic run-times and Visual Basic Common Controls) :

 

1) http://www.djlizard.net/dload.php?action=file&file_id=131

 

2) http://www.djlizard.net/dload.php?action=file&file_id=132

 

Don't be alarmed if the first one runs and shows a dialog for a few moments and then disappears - that is normal - it means it is done. After both are installed, restart the computer and see how it goes.

Share this post


Link to post
Share on other sites

This is a system instability error, not a CCleaner program error.

 

People get 'memory could not be written' errors due to hardware/Windows problems not specific programs like CCleaner.

 

Starting some programs causes this error to show up, yes but it's a hardware/Windows problem, not CCleaner's.

 

If you have an overclocked system or stability untested system, installing Windows from scratch at stock speeds then immediately installing CCleaner before anything else may show CCleaner running just fine on this very system.

 

I have a dual boot and have gotten this very same error in the past, I reimaged my system and the problem went away, it was not a program-related error.

Share this post


Link to post
Share on other sites

You can't say that it's *always* a hardware or Windows problem. You can't assume their system is unstable either.

 

Yes, I would suppose that if you just freshly installed Windows and nothing else except CCleaner you'd see that it works... it is a clean system at that point. What we're trying to do here is figure out what's on the system now that is causing the problem, rather than recommending that anyone reinstall their entire OS for this one feature to work. Never offer format/reinstall as the first suggestion, never assume, and never say always.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...