Jump to content
Piriform Community Forums

chamberlainpi

Members
  • Content count

    2
  • Joined

  • Last visited

Everything posted by chamberlainpi

  1. Hi, I just wanted to notify you of a bug AND provide my solution to get Speccy to work on my Dell Dimension 8400. I was frustrated yesterday when everytime I launched Speccy, it caused a BSOD. It says it was caused inside of ntoskrnl.exe, but after wasting many hours trying to replace, update, but finally rollback that file, it didn't seem to be the root cause. I then looked into if it could be a weak CMOS battery issue. Yes, I've had the same factory battery inside that prehistoric desktop (almost 10 years now), so I figured changing it wouldn't hurt. Conveniently, I had the correct coin battery kicking around in my toolbag (model: CR2032, 3V. brand: Energizer [doesn't really matter though]), so I popped open the case, moved my Audio card a bit. I couldn't figure out how to remove the Graphics card without breaking a small green plastic lock that is placed right under the card (near the PCI-slot), but thankfully enough - the Video Card wasn't too much in the way and I could still eject the CMOS battery. After I got that replaced, I tried Speccy again... NOPE! Still the same problem (although it seems like it was hesitating a bit longer, could just be me). So I knew among the other files reported in the last MiniDump of my BSOD crash, there was mentioned that "iaStor.sys" could be responsible too. I didn't think it would affect at first, but hey I was wrong! I went over the Dell Support site, and looks like it was a common error for other Dimension 8400 owners. There is a new driver for the Intel Matrix Storage found here: Instructions (however... read below): http://support.dell....8&isLegacy=true The download link is here: ftp://ftp.us.dell.com/SATA/R130119.EXE NOTE: What they FAIL to say though, is that you can't boot up Windows XP when your BIOS is set in the mode "RAID Autodetect / ATA" (at least I couldn't use it, maybe it's because it was initially installed while "RAID Autodetect / AHCI" was activated). In summary, all I had to do was: - Boot-up in SafeMode; - Install the drivers (from the EXE above); - Restart, and voila! When I ran Speccy, bam! All the data populated within a few seconds! The CMOS Battery replacement may have played a role here, but hard to say really, just try the above iaStor.sys driver-update first before you bother to open your case. Hopefully this guide can help other people having similar problems. Who knows, it might not only be Dell related!
  2. Speccy causes BSOD when launched (due to iaStor.sys)

    Haha and now his post is nowhere to be found (didn’t even provide the “basic” steps either). Ah well. Funny you say that, I did let that machine sit for a few years and recently (about a week ago) decided to use it as a gaming rig in our spare living room. But, even after upgrading it from WinXP (which had just too many outdated problems with Steam and other software) to Win10, and even replaced the video card I had inside with an old ATI Radeon 5770 I had originally in my macpro (2012), it surprisingly fit and was compatible with it, but that alone wasn’t enough to run basic games like Celeste or Duck Game (both render retrostyle pixelated games, not sure why they require so much resources). So I’m going to install a SNES emulator, at the very least. Hope it runs smoothly enough, otherwise I can’t think of any other use for that Dell
×