Jump to content
CCleaner Community Forums

andypen39

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About andypen39

  • Rank
    Newbie
  1. When I try to run speecy 1.08, shorlty after it starts I get the message speecy has encountered a problem and needs to close.
  2. I have recently downloaded speccy 1.08. It starts to run, then I get the message "speccy has encountered a problem and needs to close. This happens each time I try to use this version of speccy. I had no problems with the earlier version.
×
×
  • Create New...