Jump to content

Return to Piriform.com

Photo

CCleaner Does not Clean Browsing History


  • Please log in to reply
17 replies to this topic

#1 OFFLINE tdl

tdl

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 07 June 2013 - 09:52 AM

After doing a file clean it shows that it has removed 11.5 MB but after using Recuva all the files seem to be available to view.
Please help

#2 OFFLINE mta

mta

    Forum Regular

  • Members
  • PipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Brisbane

Posted 07 June 2013 - 06:19 PM

Ummm, if you use Recuva, that's it's job - to recover deleted files.
CCleaner deletes what it finds, Recuva restores what it finds.

If you don't won't Recuva(or similar) programs to restore your deleted files, you need to do secure wipes or wipe free space tasks.
And even then, there will be a chance that Recuva can retrieve your data, partially or in full.

Edit: and what's the connection to the title, are those 11.5MB of files your browsing history?

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; birth, death and loss of data. You control the last.


#3 OFFLINE Andavari

Andavari

    .

  • Moderators
  • 16,343 posts
  • Gender:Male
  • Location:U.S.A.

Posted 07 June 2013 - 07:14 PM

Even if a secure delete mode was used, and if a file is small enough to reside inside the MFT it could still possibly be recovered by Recuva.

Piriform software help documentation is available at: http://www.piriform.com/docs

 

Don't PM me for advice! I'll only ask you to read forum rule #15.


#4 OFFLINE 1stTime

1stTime

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 14 June 2013 - 05:50 AM

I have been using CCleaner on all my computers for 3 or 4 years without issues, until I noticed this week that CCleaner will not delete the browser history on IE 10 (which I just got around to upgrading to in the past couple of weeks) running on my Windows 7 Home 64-bit HP netbook (AMD E-450 with 8 MB Ram).

Particularly, the links inside of Craigslist remain in purple showing the links I have clicked, even after running CCleaner.

I used CCleaner to uninstall CCleaner, and then reinstalled the latest version of CCleaner, again, and tested, but the problem persists.

I've looked over all the settings and everything seems to be checked "on" and I had not changed anything anyway for some years, so I don't know why CCleaner is now not deleting all the history files.

I think perhaps this newest version (4.02.4115) might have a bug in it when trying to run on the latest version of MS IE 10?

Any help would be appreciated.

Thanks,

#5 OFFLINE Campbell

Campbell

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 14 June 2013 - 03:42 PM

I have been using CCleaner on all my computers for 3 or 4 years without issues, until I noticed this week that CCleaner will not delete the browser history on IE 10 (which I just got around to upgrading to in the past couple of weeks) running on my Windows 7 Home 64-bit HP netbook (AMD E-450 with 8 MB Ram).

Particularly, the links inside of Craigslist remain in purple showing the links I have clicked, even after running CCleaner.

I used CCleaner to uninstall CCleaner, and then reinstalled the latest version of CCleaner, again, and tested, but the problem persists.

I've looked over all the settings and everything seems to be checked "on" and I had not changed anything anyway for some years, so I don't know why CCleaner is now not deleting all the history files.

I think perhaps this newest version (4.02.4115) might have a bug in it when trying to run on the latest version of MS IE 10?

Any help would be appreciated.

Thanks,


Yes I just noticed the same thing too with MS IE 10 on Win 7 64-bit. I'm assuming that there is a bug in 4.02.4115. I've reverted back to the prior version 4.01.4093 (which appears to work correctly) for now until this is fixed.

#6 OFFLINE 1stTime

1stTime

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 14 June 2013 - 10:10 PM

Yes I just noticed the same thing too with MS IE 10 on Win 7 64-bit. I'm assuming that there is a bug in 4.02.4115. I've reverted back to the prior version 4.01.4093 (which appears to work correctly) for now until this is fixed.


Thanks for the suggestion. I took your advice and reinstalled the older version (4.01) and things are working correctly again.

#7 OFFLINE 1stTime

1stTime

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 17 June 2013 - 12:59 AM

New Discovery.

Okay, it's not just Craigslist, and I've discovered something else which is peculiar: The history as typically disclosed in the Browser History tab has in fact been eliminated from that area, but when you go back to your Search again, even searches in Google, the links you had clicked on in the past still show up as having been clicked on - they are now a different color.

Reiterating - When you bring up past searches (even in Google) or your Craigslist site where you had visited before, the links within the site that you had clicked on, are a different color, even after running CCleaner. The Browser History tab shows cleared, but the indications are still a different color from the individual website links themselves.

Furthermore, I did a seach in Google, and after running CCleaner, I performed the search again using the same search words, and when the results list came up, the same links I had clicked on prior were already highlighted.

Since this is happening even with version 4.01, it is clearly an issue with MS IE 10. Something inside the new IE browser is interfering with CCleaner's functionality.

#8 OFFLINE Nergal

Nergal

    Volunteer CCleaner Demon/Post Meddler

  • Moderators
  • 6,104 posts
  • Gender:Male
  • Location:Get off my Lawn, y'darn kids!
  • Interests:being grumpier
    Laughing
    Crying
    Sleep comes Later though.

Posted 17 June 2013 - 04:34 PM

1st time please stick to one topic, it makes you very difficult to answer if we have to consider the same question (and a copy pasted post) in multiple topics
ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION
DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.
Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)
ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.
CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT www.piriform.com/docs
Link to Winapp2.ini explanation

#9 OFFLINE Neil79

Neil79

    Member

  • Members
  • PipPip
  • 20 posts

Posted 02 July 2013 - 05:35 PM

Ummm, if you use Recuva, that's it's job - to recover deleted files.
CCleaner deletes what it finds, Recuva restores what it finds.


Then CCleaner should in fact have a CLEAN for good option, an unrecoverable state :)

#10 OFFLINE mta

mta

    Forum Regular

  • Members
  • PipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Brisbane

Posted 02 July 2013 - 08:21 PM

yeah but what about those people who pressed the delete button just that little bit too fast or too early, without reading what they were being prompted for?
(hey, we've all been there)

that's the whole point behind MS and the "are you sure?" prompt when deleting?

but, your right, why not - as long as it is by default not 'turned on'.

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; birth, death and loss of data. You control the last.


#11 OFFLINE Neil79

Neil79

    Member

  • Members
  • PipPip
  • 20 posts

Posted 03 July 2013 - 03:47 AM

yeah but what about those people who pressed the delete button just that little bit too fast or too early, without reading what they were being prompted for?
(hey, we've all been there)

that's the whole point behind MS and the "are you sure?" prompt when deleting?

but, your right, why not - as long as it is by default not 'turned on'.


That is true, however ccleaner does warn people against certain options anyway. " are you sure you want to do this? "

But yes an " unrecoverable " delete option would be good and no i'm not paranoid, it was just something else that would benefit many people in cc

#12 OFFLINE Alan_B

Alan_B

    Super Hero

  • Members
  • PipPipPipPipPip
  • 4,232 posts
  • Gender:Male
  • Location:Lancashire, England

Posted 03 July 2013 - 04:09 AM

Then CCleaner should in fact have a CLEAN for good option, an unrecoverable state :)

CCleaner has had the CLEAN option for years.

Use Options / Settings
and look for the name "Secure Deletion"

#13 OFFLINE Augeas

Augeas

    Moderator

  • Moderators
  • 2,954 posts
  • Gender:Not Telling
  • Location:Where Stuff is made, UK

Posted 03 July 2013 - 06:31 PM

Getting back on topic, indeed CC 4.01 does reset highlighted links in IE10. The peculiar and puzzling thing is that:

CC Analyse IE History shows a few more entries than in v4.03. If you analyse IE History in CC, and then for each file found open the containing folder and delete the files one by one, the highlighted links remain. Eventually an analyse on History will show no files found, and the links are still highlighted. Then run CC clean History, and CC will return no files and zero bytes deleted. However the highlighted links are now back to 'unclicked' colour. This is driving me crazy, and I'm not doing any more tonight.

#14 OFFLINE Samal48

Samal48

    Member

  • Members
  • PipPip
  • 17 posts

Posted 13 July 2013 - 10:46 PM

Just noticed that links once again are remaining highlighted after running CCleaner on IE10. It was fixed but I guess after the monthly Windows update a few days ago is when it started again. It contained an IE security update. Everything else appears to be working fine as I haven't noticed any other problems.

#15 OFFLINE btb601

btb601

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 12 October 2013 - 04:57 PM

So what's the deal. I am having the same issues.
Windows 7
Explorer 10
CCleaner v4.06.4324 (25 Sep 2013)

I've been seeing links I have searched for and visited in Google search. Going way back. I ended up using Explorer to clean and that worked.
Looks like it's been going on for awhile now. I had noticed it for a long while now, just got time to check to see if I was doing something wrong with
CCleaner and everything is checked to clean when it comes to the Explorer.

Has this been addressed as a problem and fixed? Or can be fixed?

UPDATE:
I thought I better have a look at my browser addons and got me thinking.
Maybe around the time I noticed this issues, I had installed MS Office Pro 2013. Anyone else?

#16 OFFLINE yellowduck

yellowduck

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 18 October 2013 - 05:31 AM

I have noticed this as well. If you run CC it removed all contents of the IE history, but does not 'reset' any of the hyperlinks clicked on from purple (clicked on) to normal blue (unclicked on).

If I then use IE options to delete internet history, the hyperlinks are restored to their unclicked colour.

I am running a new machine on Win 7 Prof (the option was on the PC to install this or 8) with the latest version of CC. I have other machins running Win 7 and older versions of CC, although has been updated with windows updates. Assuming this older machine has the latest updates from Windows, I am guessing the problem is with CC.

#17 OFFLINE yellowduck

yellowduck

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 18 October 2013 - 05:45 AM

I have just removed version 4.05 and installed previous version 4.00 and the problem does not happen with this version. Lets see for how long......I have also disabled windows updates and will rely on Kaspersky for my security!

#18 OFFLINE Andavari

Andavari

    .

  • Moderators
  • 16,343 posts
  • Gender:Male
  • Location:U.S.A.

Posted 19 October 2013 - 05:52 PM

I have also disabled windows updates and will rely on Kaspersky for my security!


That can be disastrous. While some anti-malware solutions openly state they plug some security holes in Windows most will tell users to keep installing the monthly Windows Updates.

Piriform software help documentation is available at: http://www.piriform.com/docs

 

Don't PM me for advice! I'll only ask you to read forum rule #15.