Jump to content

Return to Piriform.com

Photo

"Install Date" incorrect in list of installed programs


  • Please log in to reply
5 replies to this topic

#1 OFFLINE bjkeefe

bjkeefe

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 18 February 2012 - 11:49 AM

Just noticed this, but I can't say for sure that it just appeared. In any case, if I click the Tools button to get to the Uninstall section of CCleaner, the "Install Date" field for quite a few of the installed programs is wrong. Approximately ten programs are listed as being installed today, several more yesterday, several more the day before.

It is true that the date is correct for a couple; e.g., I updated System Explorer and Firefox today, but the vast majority are programs that were installed weeks, months, or years ago.

CCleaner version: v3.15.1643 (latest, as of this posting). OS: Windows XP SP3. Screenshot here and below.

Posted Image

#2 OFFLINE Super Fast

Super Fast

    Super Hero

  • Members
  • PipPipPipPipPip
  • 2,210 posts
  • Gender:Male

Posted 18 February 2012 - 12:47 PM

This is a Microsoft problem, & has nothing to do with CCleaner or Piriform.

Were you to open the Add/Remove in the Control Panel, you would see the same.

Microsoft also gets the file sizes of installed programs wrong.

#3 OFFLINE hazelnut

hazelnut

    try to stay calm

  • Moderators
  • 12,750 posts
  • Gender:Female
  • Location:Huddersfield uk

Posted 18 February 2012 - 02:35 PM

On Win 7 everything is as it should be.

However on XP lots of the date shown in ccleaner are saying the items were installed in the last few days (they weren't) You cannot see the install date on XP just the last used etc. Going into the program files shows the date of install.
CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND HERE

http://www.piriform.com/docs

#4 OFFLINE gggirlgeek

gggirlgeek

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 11 June 2013 - 01:58 AM

This is still not fixed in my Win7x64 v4.02.4115x64.

Intel Rapid Storage Technology
and
Intel Control Center

They are listed as being installed yesterday even though I haven't updated them sine April 2012. Also, the date in Windows Uninstaller is correct as well as Revo Uninstaller. I checked the C:\Windows\Installer folder and the Program Files folder for the files and nothing has been changed. Date Created, Date Modified, Date Accessed, and Date Last Saved were all checked. Nothing on 6/9/2013 at all!

I can't figure out where ccleaner is picking up this date. Everything else seems OK actually (I have many programs though.)

#5 OFFLINE hazelnut

hazelnut

    try to stay calm

  • Moderators
  • 12,750 posts
  • Gender:Female
  • Location:Huddersfield uk

Posted 11 June 2013 - 02:05 AM

Works okay here on my Win 7 64 bit.
CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND HERE

http://www.piriform.com/docs

#6 OFFLINE Andavari

Andavari

    .

  • Moderators
  • 16,424 posts
  • Gender:Male
  • Location:U.S.A.

Posted 11 June 2013 - 02:37 AM

It's still buggy on my XP SP3 system also. It shows some dates correct, some incorrect, and some with no dates displayed at all.

Piriform software help documentation is available at: http://www.piriform.com/docs

 

Don't PM me for advice! I'll only ask you to read forum rule #15.