Jump to content

Return to Piriform.com

Photo

Free MFT Space with External Hard disk


  • Please log in to reply
2 replies to this topic

#1 OFFLINE Vasanth

Vasanth

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 22 May 2010 - 10:44 AM

Hi there,

I had enabled Wipe Free Space with MFT for my external seagate 320 GB harddisk. While completing 36% of MFT some error like "Windows Delayed Write failed" poped up in taskbar and the MFT% in the screen went back to 0%. I saw some junk folder in J:\ and the system hung. I had to switch off the computer forcefully and when I login back, my computer hangs when I connect my external hard drive.

I even tried disabling the autorun feature for this drive and try connecting it. I was thinking of deleting the junk folder (alphanumeric names with ZZ..ZZZ..ZZZ at the end). But still the system hangs after few minutes without giving me the option to explore the drive.

Is my drive corrupted? Any options?

Thanks,

Vasanth

#2 OFFLINE Aethec

Aethec

    Red Panda

  • Members
  • PipPipPipPip
  • 1,714 posts
  • Gender:Male
  • Location:Lausanne, Switzerland

Posted 22 May 2010 - 11:33 AM

First, don't use Wipe Free Space unless you want to sell your drive. It will not improve performance, and it will not free up space. It only erases already deleted files.Posted Image

Open a Command Prompt (Windows key + R >> type cmd) and type chkdsk J: /R
Piriform French translator

#3 OFFLINE Alan_B

Alan_B

    Super Hero

  • Members
  • PipPipPipPipPip
  • 4,129 posts
  • Gender:Male
  • Location:Lancashire, England

Posted 24 May 2010 - 11:11 AM

Windows provides disk caching for higher performance,
so data you write is temporarily held in a buffer whilst more "urgent" user demands are met,
and with a little luck at some later time the system will find opportunity to write data to disk.
When things go wrong you may, I think, be rewarded with
"Windows Delayed Write failed".
I would worry about WHETHER the system will find an opportunity to write data whilst the MFT etc. are still being filled.

I find disabling the cache on my Internal drive makes Windows take twice as long on start-up.
I have re-enabled it.

Disabling the cache on the external USB drives now avoids
"Windows Delayed Write failed"
and also the terrifying system event log messages about data loss / corruption.
This probably halves my speed of use -
but 99% of the time I am not accessing the external drive anyway,
and my external data is better able to survive a BSOD or a utility supplier power failure.

Alan