Jump to content

Return to Piriform.com

Photo

CCleaner Setting Defaults


  • Please log in to reply
6 replies to this topic

#1 OFFLINE SF_Bev

SF_Bev

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 02 May 2009 - 12:45 PM

I reset CCleaner's settings and unchecked almost everything. Now I'd like to set it back to its default settings, but I haven't been able to find them anywhere. Can somebody tell me which boxes are checked/unchecked when CCleaner is run the first time after it's installed? Thanks in advance for any help. ;)
Bev

#2 OFFLINE ninnpwint

ninnpwint

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 May 2009 - 05:07 PM

I reset CCleaner's settings and unchecked almost everything. Now I'd like to set it back to its default settings, but I haven't been able to find them anywhere. Can somebody tell me which boxes are checked/unchecked when CCleaner is run the first time after it's installed? Thanks in advance for any help. ;)
Bev


i can understand your pain
and it would be very nice to have a box to check for going back to default settings
hope CCleaner will include that soon

#3 OFFLINE DennisD

DennisD

    Member

  • Moderators
  • 10,022 posts
  • Gender:Male
  • Location:England: NE Coast

Posted 02 May 2009 - 05:40 PM

Hi guys, and welcome to Piriform.

I think the easiest way to get back to the default settings, is to go into CCleaners Program Files folder (C:\Program Files\CCleaner), and delete the "ccleaner.ini" file, which keeps your various configurations.

Basically, it's all checkboxes in the Advanced section cleared, and everything else checked apart from the obvious ones you know you personally want unchecked.

Deleting that file, would also lose any "includes" or "excludes" you have, or any cookies kept. In that case, rename the CCleaner file to "ccleaner_mod.ini" for example, re-launch CCleaner, check out the settings, maybe take a screenshot.

Change "ccleaner_mod.ini" back to "ccleaner.ini", and then redo the checkboxes based on your screenshot.

In the registry section it's all boxes checked, although you don't have to use that section if you aren't sure. If you do use it, please make sure you follow the CCleaner dialogue, and make a backup.

And yes absolutely. A "default" button would be helpful to many people, including me after trying to accurately answer this one. :)

Also check out the Piriform Docs site for guides to all Piriform software. Link in my signature.

#4 OFFLINE SF_Bev

SF_Bev

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 02 May 2009 - 06:18 PM

[quote name='DennisD' date='May 2 2009, 03:40 PM' post='135327']
Hi guys, and welcome to Piriform.

I think the easiest way to get back to the default settings, is to go into CCleaners Program Files folder (C:\Program Files\CCleaner), and delete the "ccleaner.ini" file, which keeps your various configurations.

Basically, it's all checkboxes in the Advanced section cleared, and everything else checked apart from the obvious ones you know you personally want unchecked...
etc.

Thanks so much! Just what I was looking for! I'll request a "Restore Defaults" button. I wasn't sure if there was one and I wasn't seeing it.

Bev

#5 OFFLINE Jamin4u

Jamin4u

    Keyboard Walker

  • Members
  • PipPipPipPip
  • 591 posts
  • Gender:Male
  • Location:Michigan

Posted 02 May 2009 - 07:10 PM

Dennis, I just tried what you suggested and it worked just fine.

Pretty slick. B)

If I may add this to your advise. The check box for save all settings to INI file needs to be checked before you can do this.

Options > Advanced > Save all settings to INI file.

#6 OFFLINE DennisD

DennisD

    Member

  • Moderators
  • 10,022 posts
  • Gender:Male
  • Location:England: NE Coast

Posted 02 May 2009 - 07:31 PM

Yes Jamin, you may add by all means. Appreciated.
:)

#7 OFFLINE missdatabase

missdatabase

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 May 2009 - 08:07 PM

I've been following this discussion because I had the same problem as SF Bev: I wanted to get CCleaner back to its default settings.

I'm not very experienced and therefore had some trouble with the suggestions here. I ended up uninstalling the program, reinstalling it, and immediately taking note of the defaults, as follows.

CCleaner, v 2.19.900
Default Settings
Settings below are listed button by button, divided by lines.
______________________
Cleaner Button,
Windows Tab

INTERNET EXPLORER
All are checked except for the last one listed, "autocomplete form history"

WINDOWS EXPLORER
All are checked

SYSTEM
Most are checked except for the last 3, "Windows Error Reporting," "Start Menu Shortcuts," and "Desktop Shortcuts."

ADVANCED
All are unchecked.

________________________
Cleaner Button,
Applications Tab

FIREFOX/MOZILLA
Most are checked except for the last one listed, "Saved Form Information"

APPLICATIONS
All are checked:
Adobe Reader 8.0
MS Office Picture Manager
Office 2003

INTERNET
One listing, Sun Java, which is checked

MULTIMEDIA
Both are checked:
Adobe Flash Player
Windows Media Player

UTILITIES
Both are checked:
Spybot Search & Destroy
Windows Defender

WINDOWS
All are checked

________________________
Registry Button
Registry Integrity
All are checked

________________________
Tools Button
No buttons present

________________________
Options Button

SETTINGS

In the list with 4 check boxes, only the 2 middle options are checked:
Add "Run CCleaner" option &
Add "Open CCleaner..." option

Also, "Normal file deletion" is selected

ADVANCED
2 options are selected:
1st - Only delete files in Windows Temp ...
4th - Show prompt to backup ...

Note: This discussion suggests another Advanced option should be checked as well, the last, "Save all settings to INI file."